aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--BUGS3
-rw-r--r--Makefile16
-rw-r--r--TODO1
-rwxr-xr-xmake-tarball.sh2
4 files changed, 15 insertions, 7 deletions
diff --git a/BUGS b/BUGS
index bfaa7b9..9ab3439 100644
--- a/BUGS
+++ b/BUGS
@@ -3,3 +3,6 @@ KNOWN BUGS
scanelf -tTq ; -T always always triggers a found with quite mode.
+REPORTING BUGS
+--------------
+mail us.
diff --git a/Makefile b/Makefile
index bbc1cb5..4d0ed2d 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,6 @@
# Copyright 2003 Ned Ludd <solar@linbsd.net>
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-projects/pax-utils/Makefile,v 1.29 2005/06/08 03:02:49 vapier Exp $
+# $Header: /var/cvsroot/gentoo-projects/pax-utils/Makefile,v 1.30 2005/06/09 14:57:33 solar Exp $
####################################################################
# This program is free software; you can redistribute it and/or
# modify it under the terms of the GNU General Public License as
@@ -17,13 +17,18 @@
# Foundation, Inc., 59 Temple Place - Suite 330, Boston,
# MA 02111-1307, USA.
####################################################################
+check_gcc=$(shell if $(CC) $(1) -S -o /dev/null -xc /dev/null > /dev/null 2>&1; \
+ then echo "$(1)"; else echo "$(2)"; fi)
####################################################
-WFLAGS := -Wall -Wextra -Wunused -Wimplicit -Wshadow -Wformat=2 \
+WFLAGS := -Wall -Wunused -Wimplicit -Wshadow -Wformat=2 \
-Wmissing-declarations -Wmissing-prototypes -Wwrite-strings \
-Wbad-function-cast -Wnested-externs -Wcomment -Wsequence-point \
- -Wdeclaration-after-statement -Wchar-subscripts -Wcast-align \
+ -Wchar-subscripts -Wcast-align \
-Winline
+# =gcc-3.3 does not support these options.
+WFLAGS += $(call check_gcc, -Wdeclaration-after-statement -Wextra)
+
CFLAGS := -O2 -pipe
#CFLAGS += -DEBUG -g
#LDFLAGS := -pie
@@ -35,7 +40,7 @@ CP := cp
# Build with -Werror while emerging
ifneq ($(S),)
-WFLAGS += -Werror
+WFLAGS += -Werror
endif
#####################################################
TARGETS = scanelf pspax dumpelf
@@ -71,8 +76,9 @@ distclean: clean
install: all
-$(STRIP) $(TARGETS)
- -$(MKDIR) $(PREFIX)/bin/ $(PREFIX)/share/man/man1/
+ -$(MKDIR) $(PREFIX)/bin/ $(PREFIX)/share/man/man1/ $(PREFIX)/share/doc/
$(CP) $(TARGETS) $(PREFIX)/bin/
+ $(CP) README BUGS TODO $(PREFIX)/share/doc/
for mpage in $(MPAGES) ; do \
[ -e $$mpage ] \
&& cp $$mpage $(PREFIX)/share/man/man1/ || : ;\
diff --git a/TODO b/TODO
index 9702804..b7b614b 100644
--- a/TODO
+++ b/TODO
@@ -1,4 +1,3 @@
REQUESTS
----------
-
<psm> feature request for pax-utils, find cause of GNU_STACK = RWX, especially if PAX_FLAGS = E (nested function ,,,)
diff --git a/make-tarball.sh b/make-tarball.sh
index 715abe4..bf226c8 100755
--- a/make-tarball.sh
+++ b/make-tarball.sh
@@ -9,7 +9,7 @@ ver="$1"
bn="$(basename $(pwd))-${ver}"
[[ -d "${bn}" ]] && rm -r "${bn}"
mkdir "${bn}" || exit 1
-cp -r Makefile README *.[ch] man "${bn}/" || exit 1
+cp -r Makefile README TODO BUGS *.[ch] man "${bn}/" || exit 1
rm -rf "${bn}"/man/CVS
tar -jcf "${bn}".tar.bz2 ${bn} || exit 1
rm -r "${bn}" || exit 1