summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2015-06-08 21:58:50 +1200
committerKent Fredric <kentfredric@gmail.com>2015-06-08 21:58:50 +1200
commit4e907419ecad9a41f7116c5439679b21d7f6c2dd (patch)
treee1096881ec2ccfdf9d65312ecebf60838d957661
parent[fixup] File-Find-Rule-VCS: EAPI5, normalise verison, fixup deps (diff)
downloadperl-overlay-4e907419ecad9a41f7116c5439679b21d7f6c2dd.tar.gz
perl-overlay-4e907419ecad9a41f7116c5439679b21d7f6c2dd.tar.bz2
perl-overlay-4e907419ecad9a41f7116c5439679b21d7f6c2dd.zip
[fixup] Module-Math-Depends: EAPI5, normalise versio0n, fixup deps
Package-Manager: portage-2.2.17
-rw-r--r--dev-perl/Module-Math-Depends/Manifest2
-rw-r--r--dev-perl/Module-Math-Depends/Module-Math-Depends-0.02.ebuild20
-rw-r--r--dev-perl/Module-Math-Depends/Module-Math-Depends-0.20.0.ebuild32
3 files changed, 33 insertions, 21 deletions
diff --git a/dev-perl/Module-Math-Depends/Manifest b/dev-perl/Module-Math-Depends/Manifest
index a442276a9..8d3e2bb7a 100644
--- a/dev-perl/Module-Math-Depends/Manifest
+++ b/dev-perl/Module-Math-Depends/Manifest
@@ -1 +1 @@
-DIST Module-Math-Depends-0.02.tar.gz 22991 SHA256 733cd9b92e500e04f388e25413c611f93ad0f262588b2aa83d2f2880888a4f99
+DIST Module-Math-Depends-0.02.tar.gz 22991 SHA256 733cd9b92e500e04f388e25413c611f93ad0f262588b2aa83d2f2880888a4f99 SHA512 0bdb1d4cda10aeda3e1f91a45d631f6e773dc954cfe099c998d7a74cf6547c9c1f6ec53b270b297e4d7be13d957c4b996dfce9b9ef3d438e6b4beeeabb43ce0d WHIRLPOOL 6c0749bca3c12ff3a1f3bd6fc97cde845d8786c6f8305274b95b3087acc2b88ec6931962820092ffcfd992ca4c6de618fa1748de3056a1512a110efad5faf473
diff --git a/dev-perl/Module-Math-Depends/Module-Math-Depends-0.02.ebuild b/dev-perl/Module-Math-Depends/Module-Math-Depends-0.02.ebuild
deleted file mode 100644
index 088ce23f9..000000000
--- a/dev-perl/Module-Math-Depends/Module-Math-Depends-0.02.ebuild
+++ /dev/null
@@ -1,20 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=2
-
-MODULE_AUTHOR=ADAMK
-inherit perl-module
-
-DESCRIPTION="Convenience object for manipulating module dependencies"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND=">=virtual/perl-version-0.74
- dev-perl/Params-Util"
-DEPEND="${RDEPEND}"
-
-SRC_TEST=do
diff --git a/dev-perl/Module-Math-Depends/Module-Math-Depends-0.20.0.ebuild b/dev-perl/Module-Math-Depends/Module-Math-Depends-0.20.0.ebuild
new file mode 100644
index 000000000..2c9e2ed3c
--- /dev/null
+++ b/dev-perl/Module-Math-Depends/Module-Math-Depends-0.20.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+MODULE_AUTHOR=ADAMK
+MODULE_VERSION=0.02
+inherit perl-module
+
+DESCRIPTION="Convenience object for manipulating module dependencies"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+PERL_RM_FILES=(
+ t/97_meta.t
+ t/98_pod.t
+ t/99_pmv.t
+)
+RDEPEND="
+ virtual/perl-Carp
+ >=dev-perl/Params-Util-0.100.0
+ >=virtual/perl-version-0.740.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-0.420.0
+ )
+"