aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-12-03 07:26:30 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-12-03 07:26:30 +0200
commit026c17cbbb120eb3329ff03626bc42911b1a1eeb (patch)
tree6c299f19cb4a888017b050e9dcd6cee01c75f979
parentcore: remove the ability to have multi-level categories (diff)
downloadpkgcore-026c17cb.tar.gz
pkgcore-026c17cb.tar.bz2
pkgcore-026c17cb.zip
bump minimal required python to py3.10
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--.github/workflows/doc.yml4
-rw-r--r--.github/workflows/release.yml4
-rw-r--r--.github/workflows/test.yml6
-rw-r--r--README.rst2
-rw-r--r--pyproject.toml4
5 files changed, 10 insertions, 10 deletions
diff --git a/.github/workflows/doc.yml b/.github/workflows/doc.yml
index a18aecb5e..715042baa 100644
--- a/.github/workflows/doc.yml
+++ b/.github/workflows/doc.yml
@@ -22,10 +22,10 @@ jobs:
- name: Checkout code
uses: actions/checkout@v3
- - name: Set up Python 3.10
+ - name: Set up Python 3.11
uses: actions/setup-python@v4
with:
- python-version: '3.10'
+ python-version: '3.11'
- name: Install dependencies
run: |
diff --git a/.github/workflows/release.yml b/.github/workflows/release.yml
index 833e15760..43e25fb62 100644
--- a/.github/workflows/release.yml
+++ b/.github/workflows/release.yml
@@ -20,10 +20,10 @@ jobs:
- name: Checkout code
uses: actions/checkout@v3
- - name: Set up Python 3.10
+ - name: Set up Python 3.11
uses: actions/setup-python@v4
with:
- python-version: "3.10"
+ python-version: "3.11"
cache: 'pip'
cache-dependency-path: pyproject.toml
diff --git a/.github/workflows/test.yml b/.github/workflows/test.yml
index 0888ea521..e2d261dbd 100644
--- a/.github/workflows/test.yml
+++ b/.github/workflows/test.yml
@@ -13,12 +13,12 @@ jobs:
strategy:
matrix:
os: [ubuntu-latest]
- python-version: ['3.9', '3.10', '3.11']
+ python-version: ['3.10', '3.11']
deps: [newest-deps]
experimental: [false]
include:
- os: ubuntu-latest
- python-version: '3.10'
+ python-version: '3.11'
deps: minimal-deps
experimental: false
- os: ubuntu-latest
@@ -26,7 +26,7 @@ jobs:
deps: newest-deps
experimental: true
- os: macos-latest
- python-version: '3.10'
+ python-version: '3.11'
deps: newest-deps
experimental: false
fail-fast: false
diff --git a/README.rst b/README.rst
index b95c1c3ef..603f82f8e 100644
--- a/README.rst
+++ b/README.rst
@@ -34,7 +34,7 @@ Tools
Requirements
============
-At least python version 3.8, and snakeoil_ — a utility library split out of
+At least python version 3.10, and snakeoil_ — a utility library split out of
pkgcore for others to use.
Installing
diff --git a/pyproject.toml b/pyproject.toml
index 5f246b0ea..51e6a21ed 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -11,7 +11,7 @@ name = "pkgcore"
description = "package managing framework"
readme = "README.rst"
license = {file = "LICENSE"}
-requires-python = "~=3.9"
+requires-python = "~=3.10"
authors = [
{name = "Tim Harder", email = "radhermit@gmail.com"},
{name = "Arthur Zamarin", email = "arthurzam@gentoo.org"},
@@ -22,9 +22,9 @@ maintainers = [
]
classifiers = [
"License :: OSI Approved :: BSD License",
- "Programming Language :: Python :: 3.9",
"Programming Language :: Python :: 3.10",
"Programming Language :: Python :: 3.11",
+ "Programming Language :: Python :: 3.12",
]
dynamic = ["version"]