summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2017-05-30 00:44:17 +0200
committerUlrich Müller <ulm@gentoo.org>2017-05-30 00:44:17 +0200
commite593adfd231d69cbf5e620c2f500f3cb5ca35d53 (patch)
tree35f9241ecd938698b82efc2d08f5435856ee204f
parentpms.cls: Fix margin notes on landscape pages. (diff)
downloadpms-e593adfd231d69cbf5e620c2f500f3cb5ca35d53.tar.gz
pms-e593adfd231d69cbf5e620c2f500f3cb5ca35d53.tar.bz2
pms-e593adfd231d69cbf5e620c2f500f3cb5ca35d53.zip
Makefile: Option for two-sided layout.
-rw-r--r--Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index 74b6439..206a7fc 100644
--- a/Makefile
+++ b/Makefile
@@ -1,6 +1,8 @@
LATEXFILES := $(filter-out vc.tex,$(wildcard *.tex)) pms.cls
SOURCES = $(LATEXFILES) pms.bib vc vc-git.awk Makefile
+TWOSIDE =
+
# latex chokes on aux files produced by tex4ht, so remove them
aux-clean = if grep -q rEfLiNK pms.aux 2>/dev/null; then rm -f *.aux; fi
@@ -13,7 +15,11 @@ pms.pdf: $(LATEXFILES) pms.bbl vc.tex
set -e; \
while true; do \
pdflatex eapi-cheatsheet; \
- pdflatex pms; \
+ if test -z '$(TWOSIDE)'; then \
+ pdflatex pms; \
+ else \
+ pdflatex '\PassOptionsToClass{twoside}{pms}\input{pms}'; \
+ fi; \
grep -q 'Warning.*Rerun' eapi-cheatsheet.log pms.log || break; \
done