aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marien.zwart@gmail.com>2021-05-01 10:38:05 +0200
committerFabian Groffen <grobian@gentoo.org>2021-05-01 10:38:05 +0200
commit2ec2e13a5bbf0b36ec632d9a1306786953c4d66f (patch)
tree057780e4fff0563062a794a087bc29ea6dad7211
parentlibq/tree: return all pkgs found in Packages file, whether or not existant (diff)
downloadportage-utils-2ec2e13a.tar.gz
portage-utils-2ec2e13a.tar.bz2
portage-utils-2ec2e13a.zip
qwhich: fix locations for revisioned ebuilds in the tree and vdb
Signed-off-by: Fabian Groffen <grobian@gentoo.org>
-rw-r--r--qwhich.c4
1 files changed, 2 insertions, 2 deletions
diff --git a/qwhich.c b/qwhich.c
index 05ea064c..24a9ff09 100644
--- a/qwhich.c
+++ b/qwhich.c
@@ -201,12 +201,12 @@ int qwhich_main(int argc, char **argv)
m.print_repo ? "::" : "/",
BOLD, tmcw->atom->CATEGORY,
DKBLUE, tmcw->atom->PN,
- BLUE, tmcw->atom->P,
+ BLUE, tmcw->atom->PF,
DKGREEN, NORM);
} else if (t->cachetype == CACHE_VDB && !m.print_path) {
printf("%s%s/%s%s%s.ebuild%s\n",
DKBLUE, tmcw->path,
- BLUE, tmcw->atom->P,
+ BLUE, tmcw->atom->PF,
DKGREEN, NORM);
} else {
printf("%s%s%s\n", DKBLUE, tmcw->path, NORM);