aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2019-05-02 20:00:17 +0200
committerFabian Groffen <grobian@gentoo.org>2019-05-02 20:00:17 +0200
commit6eee66bd91df5928c0fbf1ee9cd2ff8a3f575d89 (patch)
treef2703c13d7a3ef8f7b45566f865b4df61dba7095
parentREADME: update somewhat (diff)
downloadportage-utils-6eee66bd91df5928c0fbf1ee9cd2ff8a3f575d89.tar.gz
portage-utils-6eee66bd91df5928c0fbf1ee9cd2ff8a3f575d89.tar.bz2
portage-utils-6eee66bd91df5928c0fbf1ee9cd2ff8a3f575d89.zip
qcache: rename to qkeyword
qcache has its roots in reading the metadata cache, but since this is standard functionality provided by libq/cache now, all that qcache does really is things with keywords. Signed-off-by: Fabian Groffen <grobian@gentoo.org>
-rw-r--r--.gitignore4
-rw-r--r--Makefile.am6
-rw-r--r--Makefile.in40
-rw-r--r--TODO.md2
-rw-r--r--applets.h4
-rw-r--r--man/q.16
-rw-r--r--man/qatom.14
-rw-r--r--man/qcheck.14
-rw-r--r--man/qdepends.14
-rw-r--r--man/qfile.14
-rw-r--r--man/qgrep.14
-rw-r--r--man/qkeyword.1 (renamed from man/qcache.1)6
-rw-r--r--man/qlist.14
-rw-r--r--man/qlop.14
-rw-r--r--man/qmerge.14
-rw-r--r--man/qpkg.14
-rw-r--r--man/qsearch.14
-rw-r--r--man/qsize.14
-rw-r--r--man/qtbz2.14
-rw-r--r--man/qtegrity.14
-rw-r--r--man/quse.12
-rw-r--r--man/qxpak.14
-rw-r--r--qkeyword.c (renamed from qcache.c)112
23 files changed, 118 insertions, 120 deletions
diff --git a/.gitignore b/.gitignore
index c571c4e..b65a0fb 100644
--- a/.gitignore
+++ b/.gitignore
@@ -32,18 +32,18 @@ stamp-h1
/*.old.c
/q
/qatom
-/qcache
/qcheck
/qdepends
/qfile
/qglsa
/qgrep
+/qkeyword
/qlist
/qlop
/qmerge
/qpkg
/qsearch
/qsize
+/qtegrity
/quse
/qxpak
-/qtegrity
diff --git a/Makefile.am b/Makefile.am
index 9306019..b36173c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -10,11 +10,11 @@ SUBDIRS = \
APPLETS = \
q \
qatom \
- qcache \
qcheck \
qdepends \
qfile \
qgrep \
+ qkeyword \
qlist \
qlop \
qmerge \
@@ -30,11 +30,11 @@ APPLETS = \
dist_man_MANS = \
man/q.1 \
man/qatom.1 \
- man/qcache.1 \
man/qcheck.1 \
man/qdepends.1 \
man/qfile.1 \
man/qgrep.1 \
+ man/qkeyword.1 \
man/qlist.1 \
man/qlop.1 \
man/qmerge.1 \
@@ -52,11 +52,11 @@ q_SOURCES = \
main.c \
q.c \
qatom.c \
- qcache.c \
qcheck.c \
qdepends.c \
qfile.c \
qgrep.c \
+ qkeyword.c \
qlist.c \
qlop.c \
qmerge.c \
diff --git a/Makefile.in b/Makefile.in
index b211bdd..6af9c8a 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -246,8 +246,8 @@ CONFIG_CLEAN_VPATH_FILES =
am__installdirs = "$(DESTDIR)$(bindir)" "$(DESTDIR)$(man1dir)"
PROGRAMS = $(bin_PROGRAMS)
am_q_OBJECTS = q-main.$(OBJEXT) q-q.$(OBJEXT) q-qatom.$(OBJEXT) \
- q-qcache.$(OBJEXT) q-qcheck.$(OBJEXT) q-qdepends.$(OBJEXT) \
- q-qfile.$(OBJEXT) q-qgrep.$(OBJEXT) q-qlist.$(OBJEXT) \
+ q-qcheck.$(OBJEXT) q-qdepends.$(OBJEXT) q-qfile.$(OBJEXT) \
+ q-qgrep.$(OBJEXT) q-qkeyword.$(OBJEXT) q-qlist.$(OBJEXT) \
q-qlop.$(OBJEXT) q-qmerge.$(OBJEXT) q-qpkg.$(OBJEXT) \
q-qsearch.$(OBJEXT) q-qsize.$(OBJEXT) q-qtbz2.$(OBJEXT) \
q-qtegrity.$(OBJEXT) q-quse.$(OBJEXT) q-qxpak.$(OBJEXT)
@@ -1550,11 +1550,11 @@ SUBDIRS = \
APPLETS = \
q \
qatom \
- qcache \
qcheck \
qdepends \
qfile \
qgrep \
+ qkeyword \
qlist \
qlop \
qmerge \
@@ -1570,11 +1570,11 @@ APPLETS = \
dist_man_MANS = \
man/q.1 \
man/qatom.1 \
- man/qcache.1 \
man/qcheck.1 \
man/qdepends.1 \
man/qfile.1 \
man/qgrep.1 \
+ man/qkeyword.1 \
man/qlist.1 \
man/qlop.1 \
man/qmerge.1 \
@@ -1591,11 +1591,11 @@ q_SOURCES = \
main.c \
q.c \
qatom.c \
- qcache.c \
qcheck.c \
qdepends.c \
qfile.c \
qgrep.c \
+ qkeyword.c \
qlist.c \
qlop.c \
qmerge.c \
@@ -1744,11 +1744,11 @@ distclean-compile:
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/q-main.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/q-q.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/q-qatom.Po@am__quote@
-@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/q-qcache.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/q-qcheck.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/q-qdepends.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/q-qfile.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/q-qgrep.Po@am__quote@
+@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/q-qkeyword.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/q-qlist.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/q-qlop.Po@am__quote@
@AMDEP_TRUE@@am__include@ @am__quote@./$(DEPDIR)/q-qmerge.Po@am__quote@
@@ -1823,20 +1823,6 @@ q-qatom.obj: qatom.c
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
@am__fastdepCC_FALSE@ $(AM_V_CC@am__nodep@)$(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(q_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) -c -o q-qatom.obj `if test -f 'qatom.c'; then $(CYGPATH_W) 'qatom.c'; else $(CYGPATH_W) '$(srcdir)/qatom.c'; fi`
-q-qcache.o: qcache.c
-@am__fastdepCC_TRUE@ $(AM_V_CC)$(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(q_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) -MT q-qcache.o -MD -MP -MF $(DEPDIR)/q-qcache.Tpo -c -o q-qcache.o `test -f 'qcache.c' || echo '$(srcdir)/'`qcache.c
-@am__fastdepCC_TRUE@ $(AM_V_at)$(am__mv) $(DEPDIR)/q-qcache.Tpo $(DEPDIR)/q-qcache.Po
-@AMDEP_TRUE@@am__fastdepCC_FALSE@ $(AM_V_CC)source='qcache.c' object='q-qcache.o' libtool=no @AMDEPBACKSLASH@
-@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
-@am__fastdepCC_FALSE@ $(AM_V_CC@am__nodep@)$(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(q_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) -c -o q-qcache.o `test -f 'qcache.c' || echo '$(srcdir)/'`qcache.c
-
-q-qcache.obj: qcache.c
-@am__fastdepCC_TRUE@ $(AM_V_CC)$(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(q_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) -MT q-qcache.obj -MD -MP -MF $(DEPDIR)/q-qcache.Tpo -c -o q-qcache.obj `if test -f 'qcache.c'; then $(CYGPATH_W) 'qcache.c'; else $(CYGPATH_W) '$(srcdir)/qcache.c'; fi`
-@am__fastdepCC_TRUE@ $(AM_V_at)$(am__mv) $(DEPDIR)/q-qcache.Tpo $(DEPDIR)/q-qcache.Po
-@AMDEP_TRUE@@am__fastdepCC_FALSE@ $(AM_V_CC)source='qcache.c' object='q-qcache.obj' libtool=no @AMDEPBACKSLASH@
-@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
-@am__fastdepCC_FALSE@ $(AM_V_CC@am__nodep@)$(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(q_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) -c -o q-qcache.obj `if test -f 'qcache.c'; then $(CYGPATH_W) 'qcache.c'; else $(CYGPATH_W) '$(srcdir)/qcache.c'; fi`
-
q-qcheck.o: qcheck.c
@am__fastdepCC_TRUE@ $(AM_V_CC)$(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(q_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) -MT q-qcheck.o -MD -MP -MF $(DEPDIR)/q-qcheck.Tpo -c -o q-qcheck.o `test -f 'qcheck.c' || echo '$(srcdir)/'`qcheck.c
@am__fastdepCC_TRUE@ $(AM_V_at)$(am__mv) $(DEPDIR)/q-qcheck.Tpo $(DEPDIR)/q-qcheck.Po
@@ -1893,6 +1879,20 @@ q-qgrep.obj: qgrep.c
@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
@am__fastdepCC_FALSE@ $(AM_V_CC@am__nodep@)$(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(q_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) -c -o q-qgrep.obj `if test -f 'qgrep.c'; then $(CYGPATH_W) 'qgrep.c'; else $(CYGPATH_W) '$(srcdir)/qgrep.c'; fi`
+q-qkeyword.o: qkeyword.c
+@am__fastdepCC_TRUE@ $(AM_V_CC)$(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(q_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) -MT q-qkeyword.o -MD -MP -MF $(DEPDIR)/q-qkeyword.Tpo -c -o q-qkeyword.o `test -f 'qkeyword.c' || echo '$(srcdir)/'`qkeyword.c
+@am__fastdepCC_TRUE@ $(AM_V_at)$(am__mv) $(DEPDIR)/q-qkeyword.Tpo $(DEPDIR)/q-qkeyword.Po
+@AMDEP_TRUE@@am__fastdepCC_FALSE@ $(AM_V_CC)source='qkeyword.c' object='q-qkeyword.o' libtool=no @AMDEPBACKSLASH@
+@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
+@am__fastdepCC_FALSE@ $(AM_V_CC@am__nodep@)$(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(q_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) -c -o q-qkeyword.o `test -f 'qkeyword.c' || echo '$(srcdir)/'`qkeyword.c
+
+q-qkeyword.obj: qkeyword.c
+@am__fastdepCC_TRUE@ $(AM_V_CC)$(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(q_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) -MT q-qkeyword.obj -MD -MP -MF $(DEPDIR)/q-qkeyword.Tpo -c -o q-qkeyword.obj `if test -f 'qkeyword.c'; then $(CYGPATH_W) 'qkeyword.c'; else $(CYGPATH_W) '$(srcdir)/qkeyword.c'; fi`
+@am__fastdepCC_TRUE@ $(AM_V_at)$(am__mv) $(DEPDIR)/q-qkeyword.Tpo $(DEPDIR)/q-qkeyword.Po
+@AMDEP_TRUE@@am__fastdepCC_FALSE@ $(AM_V_CC)source='qkeyword.c' object='q-qkeyword.obj' libtool=no @AMDEPBACKSLASH@
+@AMDEP_TRUE@@am__fastdepCC_FALSE@ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
+@am__fastdepCC_FALSE@ $(AM_V_CC@am__nodep@)$(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(q_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) -c -o q-qkeyword.obj `if test -f 'qkeyword.c'; then $(CYGPATH_W) 'qkeyword.c'; else $(CYGPATH_W) '$(srcdir)/qkeyword.c'; fi`
+
q-qlist.o: qlist.c
@am__fastdepCC_TRUE@ $(AM_V_CC)$(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(q_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS) -MT q-qlist.o -MD -MP -MF $(DEPDIR)/q-qlist.Tpo -c -o q-qlist.o `test -f 'qlist.c' || echo '$(srcdir)/'`qlist.c
@am__fastdepCC_TRUE@ $(AM_V_at)$(am__mv) $(DEPDIR)/q-qlist.Tpo $(DEPDIR)/q-qlist.Po
diff --git a/TODO.md b/TODO.md
index 9d44710..007d906 100644
--- a/TODO.md
+++ b/TODO.md
@@ -30,8 +30,6 @@
- vdb repo/slot think about when it is freed (see cache\_pkg\_close)
-- qcache -> rename to qkeyword
-
- quse -K -> move to qkeyword
# Atoms
diff --git a/applets.h b/applets.h
index 4dd5bc2..8cb537a 100644
--- a/applets.h
+++ b/applets.h
@@ -52,7 +52,7 @@ DECLARE_APPLET(qpkg)
DECLARE_APPLET(qgrep)
DECLARE_APPLET(qatom)
DECLARE_APPLET(qmerge)
-DECLARE_APPLET(qcache)
+DECLARE_APPLET(qkeyword)
/*DECLARE_APPLET(qglsa) disable */
DECLARE_APPLET(qtegrity)
#undef DECLARE_APPLET
@@ -66,7 +66,7 @@ static const struct applet_t {
/* q must always be the first applet */
{"q", q_main, "<applet> <args>", "virtual applet"},
{"qatom", qatom_main, "<pkg>", "split atom strings"},
- {"qcache", qcache_main, "<action> <args>", "search the metadata cache"},
+ {"qkeyword", qkeyword_main, "<action> <args>", "list packages based on keywords"},
{"qcheck", qcheck_main, "<pkgname>", "verify integrity of installed packages"},
{"qdepends", qdepends_main, "<pkgname>", "show dependency info"},
{"qfile", qfile_main, "<filename>", "list all pkgs owning files"},
diff --git a/man/q.1 b/man/q.1
index afba24a..cbf2303 100644
--- a/man/q.1
+++ b/man/q.1
@@ -1,5 +1,5 @@
.\" generated by mkman.py, please do NOT edit!
-.TH q "1" "Apr 2019" "Gentoo Foundation" "q"
+.TH q "1" "May 2019" "Gentoo Foundation" "q"
.SH NAME
q \- invoke a portage utility applet
.SH SYNOPSIS
@@ -37,7 +37,7 @@ Print version and exit.
.B This applet also has sub applets:
q <applet> <args> : virtual applet
qatom <pkg> : split atom strings
- qcache <action> <args> : search the metadata cache
+ qkeyword <action> <args> : list packages based on keywords
qcheck <pkgname> : verify integrity of installed packages
qdepends <pkgname> : show dependency info
qfile <filename> : list all pkgs owning files
@@ -65,11 +65,11 @@ Fabian Groffen <grobian@gentoo.org>
.fi
.SH "SEE ALSO"
.BR qatom (1),
-.BR qcache (1),
.BR qcheck (1),
.BR qdepends (1),
.BR qfile (1),
.BR qgrep (1),
+.BR qkeyword (1),
.BR qlist (1),
.BR qlop (1),
.BR qmerge (1),
diff --git a/man/qatom.1 b/man/qatom.1
index 046b89e..15799c4 100644
--- a/man/qatom.1
+++ b/man/qatom.1
@@ -1,5 +1,5 @@
.\" generated by mkman.py, please do NOT edit!
-.TH qatom "1" "Apr 2019" "Gentoo Foundation" "qatom"
+.TH qatom "1" "May 2019" "Gentoo Foundation" "qatom"
.SH NAME
qatom \- split atom strings
.SH SYNOPSIS
@@ -100,11 +100,11 @@ Fabian Groffen <grobian@gentoo.org>
.fi
.SH "SEE ALSO"
.BR q (1),
-.BR qcache (1),
.BR qcheck (1),
.BR qdepends (1),
.BR qfile (1),
.BR qgrep (1),
+.BR qkeyword (1),
.BR qlist (1),
.BR qlop (1),
.BR qmerge (1),
diff --git a/man/qcheck.1 b/man/qcheck.1
index c139744..336813f 100644
--- a/man/qcheck.1
+++ b/man/qcheck.1
@@ -1,5 +1,5 @@
.\" generated by mkman.py, please do NOT edit!
-.TH qcheck "1" "Apr 2019" "Gentoo Foundation" "qcheck"
+.TH qcheck "1" "May 2019" "Gentoo Foundation" "qcheck"
.SH NAME
qcheck \- verify integrity of installed packages
.SH SYNOPSIS
@@ -64,10 +64,10 @@ Fabian Groffen <grobian@gentoo.org>
.SH "SEE ALSO"
.BR q (1),
.BR qatom (1),
-.BR qcache (1),
.BR qdepends (1),
.BR qfile (1),
.BR qgrep (1),
+.BR qkeyword (1),
.BR qlist (1),
.BR qlop (1),
.BR qmerge (1),
diff --git a/man/qdepends.1 b/man/qdepends.1
index dcaef0c..1020b9a 100644
--- a/man/qdepends.1
+++ b/man/qdepends.1
@@ -1,5 +1,5 @@
.\" generated by mkman.py, please do NOT edit!
-.TH qdepends "1" "Apr 2019" "Gentoo Foundation" "qdepends"
+.TH qdepends "1" "May 2019" "Gentoo Foundation" "qdepends"
.SH NAME
qdepends \- show dependency info
.SH SYNOPSIS
@@ -121,10 +121,10 @@ Fabian Groffen <grobian@gentoo.org>
.SH "SEE ALSO"
.BR q (1),
.BR qatom (1),
-.BR qcache (1),
.BR qcheck (1),
.BR qfile (1),
.BR qgrep (1),
+.BR qkeyword (1),
.BR qlist (1),
.BR qlop (1),
.BR qmerge (1),
diff --git a/man/qfile.1 b/man/qfile.1
index 5cd297a..1440bd7 100644
--- a/man/qfile.1
+++ b/man/qfile.1
@@ -1,5 +1,5 @@
.\" generated by mkman.py, please do NOT edit!
-.TH qfile "1" "Apr 2019" "Gentoo Foundation" "qfile"
+.TH qfile "1" "May 2019" "Gentoo Foundation" "qfile"
.SH NAME
qfile \- list all pkgs owning files
.SH SYNOPSIS
@@ -214,10 +214,10 @@ TGL <degrenier[at]easyconnect.fr>
.SH "SEE ALSO"
.BR q (1),
.BR qatom (1),
-.BR qcache (1),
.BR qcheck (1),
.BR qdepends (1),
.BR qgrep (1),
+.BR qkeyword (1),
.BR qlist (1),
.BR qlop (1),
.BR qmerge (1),
diff --git a/man/qgrep.1 b/man/qgrep.1
index 34fe54d..78ffb19 100644
--- a/man/qgrep.1
+++ b/man/qgrep.1
@@ -1,5 +1,5 @@
.\" generated by mkman.py, please do NOT edit!
-.TH qgrep "1" "Apr 2019" "Gentoo Foundation" "qgrep"
+.TH qgrep "1" "May 2019" "Gentoo Foundation" "qgrep"
.SH NAME
qgrep \- grep in ebuilds
.SH SYNOPSIS
@@ -94,10 +94,10 @@ Fabian Groffen <grobian@gentoo.org>
.SH "SEE ALSO"
.BR q (1),
.BR qatom (1),
-.BR qcache (1),
.BR qcheck (1),
.BR qdepends (1),
.BR qfile (1),
+.BR qkeyword (1),
.BR qlist (1),
.BR qlop (1),
.BR qmerge (1),
diff --git a/man/qcache.1 b/man/qkeyword.1
index 675059e..a575404 100644
--- a/man/qcache.1
+++ b/man/qkeyword.1
@@ -1,9 +1,9 @@
.\" generated by mkman.py, please do NOT edit!
-.TH qcache "1" "Apr 2019" "Gentoo Foundation" "qcache"
+.TH qkeyword "1" "May 2019" "Gentoo Foundation" "qkeyword"
.SH NAME
-qcache \- search the metadata cache
+qkeyword \- list packages based on keywords
.SH SYNOPSIS
-.B qcache
+.B qkeyword
\fI[opts] <action> <args>\fR
.SH DESCRIPTION
diff --git a/man/qlist.1 b/man/qlist.1
index 0b16318..3932319 100644
--- a/man/qlist.1
+++ b/man/qlist.1
@@ -1,5 +1,5 @@
.\" generated by mkman.py, please do NOT edit!
-.TH qlist "1" "Apr 2019" "Gentoo Foundation" "qlist"
+.TH qlist "1" "May 2019" "Gentoo Foundation" "qlist"
.SH NAME
qlist \- list files owned by pkgname
.SH SYNOPSIS
@@ -86,11 +86,11 @@ Fabian Groffen <grobian@gentoo.org>
.SH "SEE ALSO"
.BR q (1),
.BR qatom (1),
-.BR qcache (1),
.BR qcheck (1),
.BR qdepends (1),
.BR qfile (1),
.BR qgrep (1),
+.BR qkeyword (1),
.BR qlop (1),
.BR qmerge (1),
.BR qpkg (1),
diff --git a/man/qlop.1 b/man/qlop.1
index 4dd31c1..83b62f8 100644
--- a/man/qlop.1
+++ b/man/qlop.1
@@ -1,5 +1,5 @@
.\" generated by mkman.py, please do NOT edit!
-.TH qlop "1" "Apr 2019" "Gentoo Foundation" "qlop"
+.TH qlop "1" "May 2019" "Gentoo Foundation" "qlop"
.SH NAME
qlop \- emerge log analyzer
.SH SYNOPSIS
@@ -135,11 +135,11 @@ Fabian Groffen <grobian@gentoo.org>
.SH "SEE ALSO"
.BR q (1),
.BR qatom (1),
-.BR qcache (1),
.BR qcheck (1),
.BR qdepends (1),
.BR qfile (1),
.BR qgrep (1),
+.BR qkeyword (1),
.BR qlist (1),
.BR qmerge (1),
.BR qpkg (1),
diff --git a/man/qmerge.1 b/man/qmerge.1
index d303e45..e0503e1 100644
--- a/man/qmerge.1
+++ b/man/qmerge.1
@@ -1,5 +1,5 @@
.\" generated by mkman.py, please do NOT edit!
-.TH qmerge "1" "Apr 2019" "Gentoo Foundation" "qmerge"
+.TH qmerge "1" "May 2019" "Gentoo Foundation" "qmerge"
.SH NAME
qmerge \- fetch and merge binary package
.SH SYNOPSIS
@@ -75,11 +75,11 @@ Fabian Groffen <grobian@gentoo.org>
.SH "SEE ALSO"
.BR q (1),
.BR qatom (1),
-.BR qcache (1),
.BR qcheck (1),
.BR qdepends (1),
.BR qfile (1),
.BR qgrep (1),
+.BR qkeyword (1),
.BR qlist (1),
.BR qlop (1),
.BR qpkg (1),
diff --git a/man/qpkg.1 b/man/qpkg.1
index 17278ec..4fb265c 100644
--- a/man/qpkg.1
+++ b/man/qpkg.1
@@ -1,5 +1,5 @@
.\" generated by mkman.py, please do NOT edit!
-.TH qpkg "1" "Apr 2019" "Gentoo Foundation" "qpkg"
+.TH qpkg "1" "May 2019" "Gentoo Foundation" "qpkg"
.SH NAME
qpkg \- manipulate Gentoo binpkgs
.SH SYNOPSIS
@@ -55,11 +55,11 @@ Fabian Groffen <grobian@gentoo.org>
.SH "SEE ALSO"
.BR q (1),
.BR qatom (1),
-.BR qcache (1),
.BR qcheck (1),
.BR qdepends (1),
.BR qfile (1),
.BR qgrep (1),
+.BR qkeyword (1),
.BR qlist (1),
.BR qlop (1),
.BR qmerge (1),
diff --git a/man/qsearch.1 b/man/qsearch.1
index 1bea7ab..af27416 100644
--- a/man/qsearch.1
+++ b/man/qsearch.1
@@ -1,5 +1,5 @@
.\" generated by mkman.py, please do NOT edit!
-.TH qsearch "1" "Apr 2019" "Gentoo Foundation" "qsearch"
+.TH qsearch "1" "May 2019" "Gentoo Foundation" "qsearch"
.SH NAME
qsearch \- search pkgname/desc
.SH SYNOPSIS
@@ -60,11 +60,11 @@ Fabian Groffen <grobian@gentoo.org>
.SH "SEE ALSO"
.BR q (1),
.BR qatom (1),
-.BR qcache (1),
.BR qcheck (1),
.BR qdepends (1),
.BR qfile (1),
.BR qgrep (1),
+.BR qkeyword (1),
.BR qlist (1),
.BR qlop (1),
.BR qmerge (1),
diff --git a/man/qsize.1 b/man/qsize.1
index 9733e04..bcad17e 100644
--- a/man/qsize.1
+++ b/man/qsize.1
@@ -1,5 +1,5 @@
.\" generated by mkman.py, please do NOT edit!
-.TH qsize "1" "Apr 2019" "Gentoo Foundation" "qsize"
+.TH qsize "1" "May 2019" "Gentoo Foundation" "qsize"
.SH NAME
qsize \- calculate size usage
.SH SYNOPSIS
@@ -64,11 +64,11 @@ Fabian Groffen <grobian@gentoo.org>
.SH "SEE ALSO"
.BR q (1),
.BR qatom (1),
-.BR qcache (1),
.BR qcheck (1),
.BR qdepends (1),
.BR qfile (1),
.BR qgrep (1),
+.BR qkeyword (1),
.BR qlist (1),
.BR qlop (1),
.BR qmerge (1),
diff --git a/man/qtbz2.1 b/man/qtbz2.1
index bb591b1..f177128 100644
--- a/man/qtbz2.1
+++ b/man/qtbz2.1
@@ -1,5 +1,5 @@
.\" generated by mkman.py, please do NOT edit!
-.TH qtbz2 "1" "Apr 2019" "Gentoo Foundation" "qtbz2"
+.TH qtbz2 "1" "May 2019" "Gentoo Foundation" "qtbz2"
.SH NAME
qtbz2 \- manipulate tbz2 packages
.SH SYNOPSIS
@@ -59,11 +59,11 @@ Fabian Groffen <grobian@gentoo.org>
.SH "SEE ALSO"
.BR q (1),
.BR qatom (1),
-.BR qcache (1),
.BR qcheck (1),
.BR qdepends (1),
.BR qfile (1),
.BR qgrep (1),
+.BR qkeyword (1),
.BR qlist (1),
.BR qlop (1),
.BR qmerge (1),
diff --git a/man/qtegrity.1 b/man/qtegrity.1
index 429c4f7..048d4fa 100644
--- a/man/qtegrity.1
+++ b/man/qtegrity.1
@@ -1,5 +1,5 @@
.\" generated by mkman.py, please do NOT edit!
-.TH qtegrity "1" "Apr 2019" "Gentoo Foundation" "qtegrity"
+.TH qtegrity "1" "May 2019" "Gentoo Foundation" "qtegrity"
.SH NAME
qtegrity \- verify files with IMA
.SH SYNOPSIS
@@ -65,11 +65,11 @@ Sam Besselink
.SH "SEE ALSO"
.BR q (1),
.BR qatom (1),
-.BR qcache (1),
.BR qcheck (1),
.BR qdepends (1),
.BR qfile (1),
.BR qgrep (1),
+.BR qkeyword (1),
.BR qlist (1),
.BR qlop (1),
.BR qmerge (1),
diff --git a/man/quse.1 b/man/quse.1
index bb02306..6f0d8d3 100644
--- a/man/quse.1
+++ b/man/quse.1
@@ -58,11 +58,11 @@ Fabian Groffen <grobian@gentoo.org>
.SH "SEE ALSO"
.BR q (1),
.BR qatom (1),
-.BR qcache (1),
.BR qcheck (1),
.BR qdepends (1),
.BR qfile (1),
.BR qgrep (1),
+.BR qkeyword (1),
.BR qlist (1),
.BR qlop (1),
.BR qmerge (1),
diff --git a/man/qxpak.1 b/man/qxpak.1
index ccd94a1..529e8b3 100644
--- a/man/qxpak.1
+++ b/man/qxpak.1
@@ -1,5 +1,5 @@
.\" generated by mkman.py, please do NOT edit!
-.TH qxpak "1" "Apr 2019" "Gentoo Foundation" "qxpak"
+.TH qxpak "1" "May 2019" "Gentoo Foundation" "qxpak"
.SH NAME
qxpak \- manipulate xpak archives
.SH SYNOPSIS
@@ -55,11 +55,11 @@ Fabian Groffen <grobian@gentoo.org>
.SH "SEE ALSO"
.BR q (1),
.BR qatom (1),
-.BR qcache (1),
.BR qcheck (1),
.BR qdepends (1),
.BR qfile (1),
.BR qgrep (1),
+.BR qkeyword (1),
.BR qlist (1),
.BR qlop (1),
.BR qmerge (1),
diff --git a/qcache.c b/qkeyword.c
index 116f389..17430fc 100644
--- a/qcache.c
+++ b/qkeyword.c
@@ -28,8 +28,8 @@
/* Required portage-utils stuff */
/********************************************************************/
-#define QCACHE_FLAGS "p:c:idtans" COMMON_FLAGS
-static struct option const qcache_long_opts[] = {
+#define QKEYWORD_FLAGS "p:c:idtans" COMMON_FLAGS
+static struct option const qkeyword_long_opts[] = {
{"matchpkg", a_argument, NULL, 'p'},
{"matchcat", a_argument, NULL, 'c'},
{"imlate", no_argument, NULL, 'i'},
@@ -40,7 +40,7 @@ static struct option const qcache_long_opts[] = {
{"not", no_argument, NULL, 'n'},
COMMON_LONG_OPTS
};
-static const char * const qcache_opts_help[] = {
+static const char * const qkeyword_opts_help[] = {
"match pkgname",
"match catname",
"list packages that can be marked stable on a given arch",
@@ -51,7 +51,7 @@ static const char * const qcache_opts_help[] = {
"list packages that aren't keyworded on a given arch.",
COMMON_OPTS_HELP
};
-#define qcache_usage(ret) usage(ret, QCACHE_FLAGS, qcache_long_opts, qcache_opts_help, NULL, lookup_applet_idx("qcache"))
+#define qkeyword_usage(ret) usage(ret, QKEYWORD_FLAGS, qkeyword_long_opts, qkeyword_opts_help, NULL, lookup_applet_idx("qkeyword"))
typedef struct {
depend_atom *qatom;
@@ -60,14 +60,14 @@ typedef struct {
size_t keywordsbuflen;
const char *arch;
cache_pkg_cb *runfunc;
-} qcache_data;
+} qkeyword_data;
static set *archs = NULL;
static char **archlist = NULL;
static size_t archlist_count;
static size_t arch_longest_len;
const char status[3] = {'-', '~', '+'};
-int qcache_test_arch = 0;
+int qkeyword_test_arch = 0;
enum { none = 0, testing, stable, minus };
@@ -200,7 +200,7 @@ read_keywords(char *s, int *keywords)
* 0 (SAME)
*/
static int
-qcache_vercmp(const struct dirent **x, const struct dirent **y)
+qkeyword_vercmp(const struct dirent **x, const struct dirent **y)
{
switch (atom_compare_str((*x)->d_name, (*y)->d_name)) {
case EQUAL: return 0;
@@ -211,12 +211,12 @@ qcache_vercmp(const struct dirent **x, const struct dirent **y)
}
static int
-qcache_imlate(cache_pkg_ctx *pkg_ctx, void *priv)
+qkeyword_imlate(cache_pkg_ctx *pkg_ctx, void *priv)
{
size_t a;
- qcache_data *data = (qcache_data *)priv;
+ qkeyword_data *data = (qkeyword_data *)priv;
- switch (data->keywordsbuf[qcache_test_arch]) {
+ switch (data->keywordsbuf[qkeyword_test_arch]) {
case stable:
case none:
case minus:
@@ -238,13 +238,13 @@ qcache_imlate(cache_pkg_ctx *pkg_ctx, void *priv)
}
static int
-qcache_not(cache_pkg_ctx *pkg_ctx, void *priv)
+qkeyword_not(cache_pkg_ctx *pkg_ctx, void *priv)
{
size_t a;
- qcache_data *data = (qcache_data *)priv;
+ qkeyword_data *data = (qkeyword_data *)priv;
- if (data->keywordsbuf[qcache_test_arch] != testing &&
- data->keywordsbuf[qcache_test_arch] != stable)
+ if (data->keywordsbuf[qkeyword_test_arch] != testing &&
+ data->keywordsbuf[qkeyword_test_arch] != stable)
{
/* match if any of the other arches have keywords */
for (a = 0; a < archlist_count; a++) {
@@ -263,12 +263,12 @@ qcache_not(cache_pkg_ctx *pkg_ctx, void *priv)
}
static int
-qcache_all(cache_pkg_ctx *pkg_ctx, void *priv)
+qkeyword_all(cache_pkg_ctx *pkg_ctx, void *priv)
{
- qcache_data *data = (qcache_data *)priv;
+ qkeyword_data *data = (qkeyword_data *)priv;
- if (data->keywordsbuf[qcache_test_arch] == stable ||
- data->keywordsbuf[qcache_test_arch] == testing)
+ if (data->keywordsbuf[qkeyword_test_arch] == stable ||
+ data->keywordsbuf[qkeyword_test_arch] == testing)
{
print_keywords(pkg_ctx->cat_ctx->name, pkg_ctx->name,
data->keywordsbuf);
@@ -279,7 +279,7 @@ qcache_all(cache_pkg_ctx *pkg_ctx, void *priv)
}
static int
-qcache_dropped(cache_pkg_ctx *pkg_ctx, void *priv)
+qkeyword_dropped(cache_pkg_ctx *pkg_ctx, void *priv)
{
static bool candidate = false;
static char pkg1[_Q_PATH_MAX];
@@ -290,7 +290,7 @@ qcache_dropped(cache_pkg_ctx *pkg_ctx, void *priv)
static int *candkwds = NULL;
static size_t candkwdslen = 0;
- qcache_data *data = (qcache_data *)priv;
+ qkeyword_data *data = (qkeyword_data *)priv;
size_t i;
char *p;
@@ -333,12 +333,12 @@ qcache_dropped(cache_pkg_ctx *pkg_ctx, void *priv)
}
/* explicitly removed? */
- if (data->keywordsbuf[qcache_test_arch] == minus)
+ if (data->keywordsbuf[qkeyword_test_arch] == minus)
return EXIT_FAILURE;
/* got a keyword? */
- if (data->keywordsbuf[qcache_test_arch] == testing ||
- data->keywordsbuf[qcache_test_arch] == stable)
+ if (data->keywordsbuf[qkeyword_test_arch] == testing ||
+ data->keywordsbuf[qkeyword_test_arch] == stable)
{
if (candidate) {
p = strchr(candpkg, '/');
@@ -390,7 +390,7 @@ print_seconds_for_earthlings(const unsigned long t)
}
static int
-qcache_stats(cache_pkg_ctx *pkg_ctx, void *priv)
+qkeyword_stats(cache_pkg_ctx *pkg_ctx, void *priv)
{
static time_t runtime;
static int numpkg = 0;
@@ -404,7 +404,7 @@ qcache_stats(cache_pkg_ctx *pkg_ctx, void *priv)
size_t a;
depend_atom *atom;
- qcache_data *data = (qcache_data *)priv;
+ qkeyword_data *data = (qkeyword_data *)priv;
/* Is this the last time we'll be called? */
if (!data) {
@@ -527,7 +527,7 @@ qcache_stats(cache_pkg_ctx *pkg_ctx, void *priv)
}
static int
-qcache_testing_only(cache_pkg_ctx *pkg_ctx, void *priv)
+qkeyword_testing_only(cache_pkg_ctx *pkg_ctx, void *priv)
{
static bool candidate = false;
static char pkg1[_Q_PATH_MAX];
@@ -538,7 +538,7 @@ qcache_testing_only(cache_pkg_ctx *pkg_ctx, void *priv)
static int *candkwds = NULL;
static size_t candkwdslen = 0;
- qcache_data *data = (qcache_data *)priv;
+ qkeyword_data *data = (qkeyword_data *)priv;
char *p;
p = lastpkg;
@@ -576,12 +576,12 @@ qcache_testing_only(cache_pkg_ctx *pkg_ctx, void *priv)
}
/* explicitly removed or unkeyworded? */
- if (data->keywordsbuf[qcache_test_arch] == minus ||
- data->keywordsbuf[qcache_test_arch] == none)
+ if (data->keywordsbuf[qkeyword_test_arch] == minus ||
+ data->keywordsbuf[qkeyword_test_arch] == none)
return EXIT_FAILURE;
/* got a stable keyword? */
- if (data->keywordsbuf[qcache_test_arch] == stable)
+ if (data->keywordsbuf[qkeyword_test_arch] == stable)
return EXIT_SUCCESS; /* suppress further hits for this package */
/* must be testing at this point */
@@ -597,10 +597,10 @@ qcache_testing_only(cache_pkg_ctx *pkg_ctx, void *priv)
}
static int
-qcache_results_cb(cache_pkg_ctx *pkg_ctx, void *priv)
+qkeyword_results_cb(cache_pkg_ctx *pkg_ctx, void *priv)
{
int *keywords;
- qcache_data *data = (qcache_data *)priv;
+ qkeyword_data *data = (qkeyword_data *)priv;
char buf[_Q_PATH_MAX];
depend_atom *patom = NULL;
cache_pkg_meta *meta;
@@ -658,7 +658,7 @@ qcache_results_cb(cache_pkg_ctx *pkg_ctx, void *priv)
}
static void
-qcache_load_arches(const char *overlay)
+qkeyword_load_arches(const char *overlay)
{
FILE *fp;
char *filename, *s;
@@ -705,17 +705,17 @@ qcache_load_arches(const char *overlay)
}
static int
-qcache_traverse(cache_pkg_cb func, void *priv)
+qkeyword_traverse(cache_pkg_cb func, void *priv)
{
int ret;
size_t n;
const char *overlay;
- qcache_data *data = (qcache_data *)priv;
+ qkeyword_data *data = (qkeyword_data *)priv;
/* Preload all the arches. Not entirely correctly (as arches are bound
* to overlays if set), but oh well. */
array_for_each(overlays, n, overlay)
- qcache_load_arches(overlay);
+ qkeyword_load_arches(overlay);
/* allocate memory (once) for the list used by various funcs */
if (archlist_count > data->keywordsbuflen) {
@@ -724,28 +724,28 @@ qcache_traverse(cache_pkg_cb func, void *priv)
data->keywordsbuflen = archlist_count;
}
- qcache_test_arch = decode_arch(data->arch);
- if (qcache_test_arch == -1)
+ qkeyword_test_arch = decode_arch(data->arch);
+ if (qkeyword_test_arch == -1)
return EXIT_FAILURE;
data->runfunc = func;
ret = 0;
array_for_each(overlays, n, overlay)
ret |= cache_foreach_pkg_sorted(portroot, overlay,
- qcache_results_cb, priv, NULL, qcache_vercmp);
+ qkeyword_results_cb, priv, NULL, qkeyword_vercmp);
return ret;
}
-int qcache_main(int argc, char **argv)
+int qkeyword_main(int argc, char **argv)
{
int i;
char action = '\0';
- qcache_data data;
+ qkeyword_data data;
char *pkg = NULL;
char *cat = NULL;
- while ((i = GETOPT_LONG(QCACHE, qcache, "")) != -1) {
+ while ((i = GETOPT_LONG(QKEYWORD, qkeyword, "")) != -1) {
switch (i) {
case 'p': pkg = optarg; break;
case 'c': cat = optarg; break;
@@ -756,12 +756,12 @@ int qcache_main(int argc, char **argv)
case 'a':
case 'n':
if (action)
- qcache_usage(EXIT_FAILURE);
+ qkeyword_usage(EXIT_FAILURE);
/* trying to use more than 1 action */
action = i;
break;
- COMMON_GETOPTS_CASES(qcache)
+ COMMON_GETOPTS_CASES(qkeyword)
}
}
@@ -770,7 +770,7 @@ int qcache_main(int argc, char **argv)
data.arch = argv[optind];
if ((data.arch == NULL && action != 's') || optind + 1 < argc)
- qcache_usage(EXIT_FAILURE);
+ qkeyword_usage(EXIT_FAILURE);
if (cat != NULL) {
char buf[_Q_PATH_MAX];
@@ -797,17 +797,17 @@ int qcache_main(int argc, char **argv)
data.keywordsbuflen = 0;
switch (action) {
- case 'i': i = qcache_traverse(qcache_imlate, &data); break;
- case 'd': i = qcache_traverse(qcache_dropped, &data);
- i = qcache_dropped(NULL, NULL); break;
- case 't': i = qcache_traverse(qcache_testing_only, &data);
- i = qcache_testing_only(NULL, NULL); break;
+ case 'i': i = qkeyword_traverse(qkeyword_imlate, &data); break;
+ case 'd': i = qkeyword_traverse(qkeyword_dropped, &data);
+ i = qkeyword_dropped(NULL, NULL); break;
+ case 't': i = qkeyword_traverse(qkeyword_testing_only, &data);
+ i = qkeyword_testing_only(NULL, NULL); break;
case 's': data.arch = "amd64"; /* doesn't matter, need to be set */
- i = qcache_traverse(qcache_stats, &data);
- i = qcache_stats(NULL, NULL); break;
- case 'a': i = qcache_traverse(qcache_all, &data); break;
- case 'n': i = qcache_traverse(qcache_not, &data); break;
- default: i = -2; break;
+ i = qkeyword_traverse(qkeyword_stats, &data);
+ i = qkeyword_stats(NULL, NULL); break;
+ case 'a': i = qkeyword_traverse(qkeyword_all, &data); break;
+ case 'n': i = qkeyword_traverse(qkeyword_not, &data); break;
+ default: i = -2; break;
}
if (data.qatom != NULL)
@@ -815,6 +815,6 @@ int qcache_main(int argc, char **argv)
free(archlist);
free_set(archs);
if (i == -2)
- qcache_usage(EXIT_FAILURE);
+ qkeyword_usage(EXIT_FAILURE);
return i;
}