aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2020-01-02 11:32:27 +0100
committerFabian Groffen <grobian@gentoo.org>2020-01-02 11:32:27 +0100
commitf177ab6944e899a8444640ed125ee7f4e1f6589d (patch)
tree0bae6597f9167831a89209cd7b435f58560f523e
parentman: update qpkg manpage (diff)
downloadportage-utils-f177ab69.tar.gz
portage-utils-f177ab69.tar.bz2
portage-utils-f177ab69.zip
libq/atom: also strip/ignore .tbz2 suffix (like .ebuild)
Signed-off-by: Fabian Groffen <grobian@gentoo.org>
-rw-r--r--libq/atom.c3
1 files changed, 2 insertions, 1 deletions
diff --git a/libq/atom.c b/libq/atom.c
index 946e821c..e79c30af 100644
--- a/libq/atom.c
+++ b/libq/atom.c
@@ -118,7 +118,8 @@ atom_explode(const char *atom)
strcpy(ret->CATEGORY, atom);
/* eat file name crap when given an (autocompleted) path */
- if ((ptr = strstr(ret->CATEGORY, ".ebuild")) != NULL)
+ if ((ptr = strstr(ret->CATEGORY, ".ebuild")) != NULL ||
+ (ptr = strstr(ret->CATEGORY, ".tbz2")) != NULL)
*ptr = '\0';
/* chip off the trailing ::REPO as needed */