aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2022-07-19 20:19:44 -0700
committerBrian Dolbec <dolsen@gentoo.org>2022-07-19 20:19:44 -0700
commit0ffb754d244871b21f0ccb52087fc7aca64bea85 (patch)
tree67e3bd6304ab99562d5dc42a99de9ec32d484d58
parentsetup.py: update for 3.0.34 (diff)
downloadportage-0ffb754d244871b21f0ccb52087fc7aca64bea85.tar.gz
portage-0ffb754d244871b21f0ccb52087fc7aca64bea85.tar.bz2
portage-0ffb754d244871b21f0ccb52087fc7aca64bea85.zip
xml/metadata.py: Fix intermittent duplicate use descriptions in equery uses
Fix commit b67c57cc2e0a17b8e6454dc316c59e8736582894 which incorrectly used node.iter() which is sometimes returning duplicate descriptions. Bug: https://bugs.gentoo.org/858791 Signed-off-by: Brian Dolbec <dolsen@gentoo.org>
-rw-r--r--lib/portage/xml/metadata.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/lib/portage/xml/metadata.py b/lib/portage/xml/metadata.py
index 672f64358..8eaa37a3f 100644
--- a/lib/portage/xml/metadata.py
+++ b/lib/portage/xml/metadata.py
@@ -106,7 +106,7 @@ class _Useflag:
_desc = ""
if node.text:
_desc = node.text
- for child in node.iter():
+ for child in node:
_desc += child.text if child.text else ""
_desc += child.tail if child.tail else ""
# This takes care of tabs and newlines left from the file