aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2010-10-26 12:45:30 -0700
committerZac Medico <zmedico@gentoo.org>2010-10-26 12:45:30 -0700
commit4825a9b5cbc2e3173c4b9dcf2b6444811cca959c (patch)
treedc469a6883202be36f2c674da6b2d1a54272dbde
parentRaise StopIteration from _poll() if needed. (diff)
downloadportage-4825a9b5cbc2e3173c4b9dcf2b6444811cca959c.tar.gz
portage-4825a9b5cbc2e3173c4b9dcf2b6444811cca959c.tar.bz2
portage-4825a9b5cbc2e3173c4b9dcf2b6444811cca959c.zip
ebuild(1): fix breakage for /var/db/pkg ebuilds
-rwxr-xr-xbin/ebuild8
-rw-r--r--pym/portage/dbapi/vartree.py2
2 files changed, 6 insertions, 4 deletions
diff --git a/bin/ebuild b/bin/ebuild
index ae793ac4d..93859327d 100755
--- a/bin/ebuild
+++ b/bin/ebuild
@@ -153,9 +153,11 @@ if ebuild_portdir != vdb_path and \
# Constrain eclass resolution to the master(s)
# that are specified in layout.conf (using an
# approach similar to repoman's).
-myrepo = portage.portdb.getRepositoryName(ebuild_portdir)
-repo_info = portage.portdb._repo_info[ebuild_portdir]
-portage.portdb.porttrees = list(repo_info.eclass_db.porttrees)
+myrepo = None
+if ebuild_portdir != vdb_path:
+ myrepo = portage.portdb.getRepositoryName(ebuild_portdir)
+ repo_info = portage.portdb._repo_info[ebuild_portdir]
+ portage.portdb.porttrees = list(repo_info.eclass_db.porttrees)
if not os.path.exists(ebuild):
print("'%s' does not exist." % ebuild)
diff --git a/pym/portage/dbapi/vartree.py b/pym/portage/dbapi/vartree.py
index 571b344f3..4b0b47ba0 100644
--- a/pym/portage/dbapi/vartree.py
+++ b/pym/portage/dbapi/vartree.py
@@ -421,7 +421,7 @@ class vardbapi(dbapi):
self.matchcache[mycat][mydep] = mymatch
return self.matchcache[mycat][mydep][:]
- def findname(self, mycpv):
+ def findname(self, mycpv, myrepo=None):
return self.getpath(str(mycpv), filename=catsplit(mycpv)[1]+".ebuild")
def flush_cache(self):