aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Berntsen <alexander@plaimi.net>2013-07-30 20:47:24 +0200
committerZac Medico <zmedico@gentoo.org>2013-07-30 12:10:27 -0700
commit5660b2a3c71acad4bcb6135ac41ce9fd315c32a8 (patch)
treece23d5c8c162ec07524d53e93c3b8f6fa8a75e03
parentdep_zapdeps: skip want_update_pkg if pkg in graph (diff)
downloadportage-5660b2a3c71acad4bcb6135ac41ce9fd315c32a8.tar.gz
portage-5660b2a3c71acad4bcb6135ac41ce9fd315c32a8.tar.bz2
portage-5660b2a3c71acad4bcb6135ac41ce9fd315c32a8.zip
man: Cap lines at 80 chars
-rw-r--r--man/color.map.512
-rw-r--r--man/ebuild.574
-rw-r--r--man/egencache.13
-rw-r--r--man/emaint.113
-rw-r--r--man/emerge.144
-rw-r--r--man/env-update.13
-rw-r--r--man/make.conf.538
-rw-r--r--man/portage.539
-rw-r--r--man/repoman.143
-rw-r--r--man/xpak.53
10 files changed, 163 insertions, 109 deletions
diff --git a/man/color.map.5 b/man/color.map.5
index 175729aaa..5543628f8 100644
--- a/man/color.map.5
+++ b/man/color.map.5
@@ -9,9 +9,11 @@ Portage will check this file first for color classes settings. If no setting
of given color class is found in /etc/portage/color.map, Portage uses default
value defined internally.
.SH "SYNTAX"
-\fBVARIABLE\fR = \fI[space delimited list of attributes or ansi code pattern]\fR
+\fBVARIABLE\fR = \fI[space delimited list of attributes or ansi code
+pattern]\fR
.TP
-\fBATTRIBUTE\fR = \fI[space delimited list of attributes or ansi code pattern]\fR
+\fBATTRIBUTE\fR = \fI[space delimited list of attributes or ansi code \
+pattern]\fR
.SH "VARIABLES"
.TP
\fBNORMAL\fR = \fI"normal"\fR
@@ -54,10 +56,12 @@ Defines color used for world packages planned to be merged.
Defines color used for packages planned to be merged using a binary package.
.TP
\fBPKG_BINARY_MERGE_SYSTEM\fR = \fI"purple"\fR
-Defines color used for system packages planned to be merged using a binary package.
+Defines color used for system packages planned to be merged using a binary
+package.
.TP
\fBPKG_BINARY_MERGE_WORLD\fR = \fI"fuchsia"\fR
-Defines color used for world packages planned to be merged using a binary package.
+Defines color used for world packages planned to be merged using a binary
+package.
.TP
\fBPKG_NOMERGE\fR = \fI"darkblue"\fR
Defines color used for packages not planned to be merged.
diff --git a/man/ebuild.5 b/man/ebuild.5
index cca87e8ba..10ef4eee0 100644
--- a/man/ebuild.5
+++ b/man/ebuild.5
@@ -12,9 +12,9 @@ contain pre/post install/remove commands, as required. All ebuild scripts are
written in bash.
.SS "Dependencies"
-A \fIdepend atom\fR is simply a dependency that is used by portage when calculating
-relationships between packages. Please note that if the atom has not already
-been emerged, then the latest version available is matched.
+A \fIdepend atom\fR is simply a dependency that is used by portage when
+calculating relationships between packages. Please note that if the atom has
+not already been emerged, then the latest version available is matched.
.TP
.B Atom Bases
The base atom is just a full category/packagename.
@@ -38,17 +38,18 @@ Examples:
net\-misc/dhcp\fI\-3.0_p2\fR
.fi
-Versions are normally made up of two or three numbers separated by periods, such
-as 1.2 or 4.5.2. This string may be followed by a character such as 1.2a or
-4.5.2z. Note that this letter is \fInot\fR meant to indicate alpha, beta,
+Versions are normally made up of two or three numbers separated by periods,
+such as 1.2 or 4.5.2. This string may be followed by a character such as 1.2a
+or 4.5.2z. Note that this letter is \fInot\fR meant to indicate alpha, beta,
etc... status. For that, use the optional suffix; either _alpha, _beta, _pre
(pre\-release), _rc (release candidate), or _p (patch). This means for the
3rd pre\-release of a package, you would use something like 1.2_pre3. The
suffixes here can be arbitrarily chained without limitation.
.TP
.B Atom Prefix Operators [> >= = <= <]
-Sometimes you want to be able to depend on general versions rather than specifying
-exact versions all the time. Hence we provide standard boolean operators:
+Sometimes you want to be able to depend on general versions rather than
+specifying exact versions all the time. Hence we provide standard boolean
+operators:
Examples:
.nf
@@ -261,13 +262,13 @@ following syntax:
jpeg? ( media\-libs/jpeg )
.TP
.B !usevar? ( Atom )
-If you want to include a package only if the user does not have a certain option
-in their \fBUSE\fR variable, then use the following syntax:
+If you want to include a package only if the user does not have a certain
+option in their \fBUSE\fR variable, then use the following syntax:
!nophysfs? ( dev\-games/physfs )
-This is often useful for those times when you want to want to add optional support
-for a feature and have it enabled by default.
+This is often useful for those times when you want to want to add optional
+support for a feature and have it enabled by default.
.TP
.B usevar? ( Atom if true ) !usevar? ( Atom if false )
For functionality like the tertiary operator found in C you must use
@@ -769,7 +770,8 @@ The paths may contain fnmatch patterns.
.B QA_FLAGS_IGNORED
This should contain a list of file paths, relative to the image directory, of
files that do not contain .GCC.command.line sections or contain .hash sections.
-The paths may contain regular expressions with escape\-quoted special characters.
+The paths may contain regular expressions with escape\-quoted special
+characters.
This variable is intended to be used on files of binary packages which ignore
CFLAGS, CXXFLAGS, FFLAGS, FCFLAGS, and LDFLAGS variables.
@@ -777,7 +779,8 @@ CFLAGS, CXXFLAGS, FFLAGS, FCFLAGS, and LDFLAGS variables.
.B QA_MULTILIB_PATHS
This should contain a list of file paths, relative to the image directory, of
files that should be ignored for the multilib\-strict checks.
-The paths may contain regular expressions with escape\-quoted special characters.
+The paths may contain regular expressions with escape\-quoted special
+characters.
.TP
.B QA_PRESTRIPPED
This should contain a list of file paths, relative to the image directory, of
@@ -999,7 +1002,8 @@ fi
.fi
.RE
.TP
-.B usex\fR \fI<USE flag>\fR \fI[true output]\fR \fI[false output]\fR \fI[true suffix]\fR \fI[false suffix]
+.B usex\fR \fI<USE flag>\fR \fI[true output]\fR \fI[false output]\fR \fI[true \
+suffix]\fR \fI[false suffix]
If USE flag is set, echo [true output][true suffix] (defaults to
"yes"), otherwise echo [false output][false suffix] (defaults to
"no"). The usex helper is available beginning with \fBEAPI 5\fR.
@@ -1007,14 +1011,14 @@ If USE flag is set, echo [true output][true suffix] (defaults to
.B use_with\fR \fI<USE item>\fR \fI[configure name]\fR \fI[configure opt]
Useful for creating custom options to pass to a configure script. If \fIUSE
item\fR is in the \fBUSE\fR variable and a \fIconfigure opt\fR is specified,
-then the string \fI\-\-with\-[configure name]=[configure opt]\fR will be echoed.
-If \fIconfigure opt\fR is not specified, then just \fI\-\-with\-[configure
-name]\fR will be echoed. If \fIUSE item\fR is not in the \fBUSE\fR variable,
-then the string \fI\-\-without\-[configure name]\fR will be echoed. If
-\fIconfigure name\fR is not specified, then \fIUSE item\fR will be used in
-its place. Beginning with \fBEAPI 4\fR, an empty \fIconfigure opt\fR argument
-is recognized. In \fBEAPI 3\fR and earlier, an empty \fIconfigure opt\fR
-argument is treated as if it weren't provided.
+then the string \fI\-\-with\-[configure name]=[configure opt]\fR will be
+echoed. If \fIconfigure opt\fR is not specified, then just
+\fI\-\-with\-[configure name]\fR will be echoed. If \fIUSE item\fR is not in
+the \fBUSE\fR variable, then the string \fI\-\-without\-[configure name]\fR
+will be echoed. If \fIconfigure name\fR is not specified, then \fIUSE item\fR
+will be used in its place. Beginning with \fBEAPI 4\fR, an empty \fIconfigure
+opt\fR argument is recognized. In \fBEAPI 3\fR and earlier, an empty
+\fIconfigure opt\fR argument is treated as if it weren't provided.
.RS
.TP
.I Examples:
@@ -1039,9 +1043,9 @@ myconf=$(use_with sdl SDL all\-plugins)
.TP
.B use_enable\fR \fI<USE item>\fR \fI[configure name]\fR \fI[configure opt]
Same as \fBuse_with\fR above, except that the configure options are
-\fI\-\-enable\-\fR instead of \fI\-\-with\-\fR and \fI\-\-disable\-\fR instead of
-\fI\-\-without\-\fR. Beginning with \fBEAPI 4\fR, an empty \fIconfigure opt\fR
-argument is recognized. In \fBEAPI 3\fR and earlier, an empty
+\fI\-\-enable\-\fR instead of \fI\-\-with\-\fR and \fI\-\-disable\-\fR instead
+of \fI\-\-without\-\fR. Beginning with \fBEAPI 4\fR, an empty \fIconfigure
+opt\fR argument is recognized. In \fBEAPI 3\fR and earlier, an empty
\fIconfigure opt\fR argument is treated as if it weren't provided.
.TP
.B hasv\fR \fI<item>\fR \fI<item list>
@@ -1071,7 +1075,8 @@ to apply to the host root instead of ${ROOT}.
Example:
.nf
VERINS="$(best_version net\-ftp/glftpd)"
- (VERINS now has the value "net\-ftp/glftpd\-1.27" if glftpd\-1.27 is installed)
+ (VERINS now has the value "net\-ftp/glftpd\-1.27" if glftpd\-1.27 is \
+ installed)
.fi
.SS "Hooks:"
@@ -1391,12 +1396,15 @@ with file mode \fI0644\fR (this can be overridden with the
\fBinsopts\fR function). Setting \-r sets recursive. The
\fBdoheader\fR helper is available beginning with \fBEAPI 5\fR.
.TP
-.B dohtml\fR \fI [\-a filetypes] [\-r] [\-x list\-of\-dirs\-to\-ignore] [list\-of\-files\-and\-dirs]
+.B dohtml\fR \fI [\-a filetypes] [\-r] [\-x list\-of\-dirs\-to\-ignore] \
+[list\-of\-files\-and\-dirs]
Installs the files in the list of files (space\-separated list) into
-/usr/share/doc/${PF}/html provided the file ends in .htm, .html, .css, .js, .gif, .jpeg, .jpg, or .png.
+/usr/share/doc/${PF}/html provided the file ends in .htm, .html, .css, .js, \
+.gif, .jpeg, .jpg, or .png.
Setting \fI\-a\fR limits what types of files will be included,
\fI\-A\fR appends to the default list, setting \fI\-x\fR sets which dirs to
-exclude (CVS excluded by default), \fI\-p\fR sets a document prefix, \fI\-r\fR sets recursive.
+exclude (CVS excluded by default), \fI\-p\fR sets a document prefix,
+\fI\-r\fR sets recursive.
.TP
.B doinfo\fR \fI<info\-file> [list of more info\-files]
Installs info\-pages into \fIDESTDIR\fR/info. Files are automatically
@@ -1450,7 +1458,8 @@ when installing into the document tree
(based in /usr/share/doc/${PF}/). Default is no subdir, or just "".
.TP
.B dodoc\fR \fI[-r] <document> [list of more documents]
-Installs a document or a list of documents into /usr/share/doc/${PF}/\fI<docinto path>\fR.
+Installs a document or a list of documents into
+/usr/share/doc/${PF}/\fI<docinto path>\fR.
Documents are marked for compression. Creates all necessary dirs.
Beginning with \fBEAPI 4\fR, there is support for recursion, enabled by the
new \fI\-r\fR option.
@@ -1528,7 +1537,8 @@ The \fI/usr/lib/portage/bin/ebuild.sh\fR script.
The helper apps in \fI/usr/lib/portage/bin\fR.
.TP
.B /etc/portage/make.conf
-Contains variables for the build\-process and overwrites those in make.defaults.
+Contains variables for the build\-process and overwrites those in
+make.defaults.
.TP
.B /usr/share/portage/config/make.globals
Contains the default variables for the build\-process, you should edit
diff --git a/man/egencache.1 b/man/egencache.1
index 92af34784..f71feb371 100644
--- a/man/egencache.1
+++ b/man/egencache.1
@@ -11,7 +11,8 @@ itself, for distribution.
.SH ACTIONS
.TP
.BR "\-\-update [ATOM] ... "
-Update the \fImetadata/md5\-cache/\fR directory (generate metadata as necessary).
+Update the \fImetadata/md5\-cache/\fR directory (generate metadata as
+necessary).
If no package atoms are specified then all will be updated. See ebuild(5)
for the details on package atom syntax.
.TP
diff --git a/man/emaint.1 b/man/emaint.1
index c588a0bfe..3fae5c215 100644
--- a/man/emaint.1
+++ b/man/emaint.1
@@ -26,9 +26,10 @@ Discard no longer installed config tracker entries.
Discard merge lists saved for the \fBemerge\fR(1) \fB--resume\fR action.
.TP
.BR logs
-Clean out old logs from the \fBPORT_LOGDIR\fR using the command \fBPORT_LOGDIR_CLEAN\fR
-See the \fBmake.conf\fR(5) man page for additional information as well as enabling the
-\fB'clean-logs'\fR feature in emerge to do this automatically.
+Clean out old logs from the \fBPORT_LOGDIR\fR using the command
+\fBPORT_LOGDIR_CLEAN\fR
+See the \fBmake.conf\fR(5) man page for additional information as well as
+enabling the \fB'clean-logs'\fR feature in emerge to do this automatically.
.TP
.BR movebin
Perform package move updates for binary packages located in \fBPKGDIR\fR.
@@ -51,10 +52,12 @@ Fix any problems that may exist. (not all commands)
Cleans the logs from \fBPORT_LOGDIR\fR (logs command only)
.TP
.B \-p, \-\-pretend
-Sets pretend mode (same as \-c, \-\-check) for use with the \-C, \-\-clean OPTION (logs command only)
+Sets pretend mode (same as \-c, \-\-check) for use with the \-C, \-\-clean
+OPTION (logs command only)
.TP
.B \-t NUM, \-\-time NUM
-Changes the minimum age \fBNUM\fR (in days) of the logs to be listed or deleted. (logs command only)
+Changes the minimum age \fBNUM\fR (in days) of the logs to be listed or
+deleted. (logs command only)
.SH "REPORTING BUGS"
Please report bugs via http://bugs.gentoo.org/
.SH AUTHORS
diff --git a/man/emerge.1 b/man/emerge.1
index ac4651f24..66f4360fd 100644
--- a/man/emerge.1
+++ b/man/emerge.1
@@ -4,7 +4,8 @@ emerge \- Command\-line interface to the Portage system
.SH "SYNOPSIS"
.TP
.BR emerge
-[\fIoptions\fR] [\fIaction\fR] [\fIebuild\fR | \fItbz2file\fR | \fIfile\fR | \fI@set\fR | \fIatom\fR] ...
+[\fIoptions\fR] [\fIaction\fR] [\fIebuild\fR | \fItbz2file\fR | \fIfile\fR |
+\fI@set\fR | \fIatom\fR] ...
.TP
.BR emerge
\fB\-\-sync\fR | \fB\-\-version\fR
@@ -100,14 +101,16 @@ later updating.
.TP
.BR \-\-check\-news
Scan all repositories for relevant unread GLEP 42 news items, and display
-how many are found. See \fIhttp://www.gentoo.org/proj/en/glep/glep-0042.html\fR.
+how many are found. See
+\fIhttp://www.gentoo.org/proj/en/glep/glep-0042.html\fR.
.TP
.BR \-\-clean
Cleans up the system by examining the installed packages and removing older
-packages. This is accomplished by looking at each installed package and separating
-the installed versions by \fBslot\fR. Clean will \fBremove all but the most recently
-installed version in each \fbslot\fR. Clean should not remove unslotted packages.
-Note: Most recently installed means most \fBrecent\fR, not highest version.
+packages. This is accomplished by looking at each installed package and
+separating the installed versions by \fBslot\fR. Clean will \fBremove all but
+the most recently installed version in each \fbslot\fR. Clean should not
+remove unslotted packages. Note: Most recently installed means most
+\fBrecent\fR, not highest version.
.TP
.BR "\-\-config "
Run package specific actions needed to be executed after the emerge process
@@ -301,9 +304,10 @@ Before performing the action, display what will take place (server info for
\fB\-\-sync\fR, \fB\-\-pretend\fR output for merge, and so forth), then ask
whether to proceed with the action or abort. Using \fB\-\-ask\fR is more
efficient than using \fB\-\-pretend\fR and then executing the same command
-without \fB\-\-pretend\fR, as dependencies will only need to be calculated once.
-\fBWARNING: If the "Enter" key is pressed at the prompt (with no other input),
-it is interpreted as acceptance of the first choice. Note that the input
+without \fB\-\-pretend\fR, as dependencies will only need to be calculated
+once. \fBWARNING: If the "Enter" key is pressed at the prompt (with no other
+input), it is interpreted as acceptance of the first choice. Note that the
+input
buffer is not cleared prior to the prompt, so an accidental press of the
"Enter" key at any time prior to the prompt will be interpreted as a choice!
Use the \-\-ask\-enter\-invalid option if you want a single "Enter" key
@@ -811,7 +815,8 @@ matching binary packages over newer unbuilt packages.
Tells emerge to use binary packages (from $PKGDIR) if they are available, thus
possibly avoiding some time\-consuming compiles. This option is useful for CD
installs; you can export PKGDIR=/mnt/cdrom/packages and then use this option to
-have emerge "pull" binary packages from the CD in order to satisfy dependencies.
+have emerge "pull" binary packages from the CD in order to satisfy
+dependencies.
.TP
.BR "\-\-usepkgonly [ y | n ] (\-K short option)"
Tells emerge to only use binary packages (from $PKGDIR). All the binary
@@ -877,7 +882,8 @@ When utilizing \fBemerge\fR with the \fB\-\-pretend\fR and \fB\-\-verbose\fR
flags, the output may be a little hard to understand at first. This section
explains the abbreviations.
.TP
-.B [blocks B ] app\-text/dos2unix ("app\-text/dos2unix" is blocking app\-text/hd2u\-0.8.0)
+.B [blocks B ] app\-text/dos2unix ("app\-text/dos2unix" is blocking \
+app\-text/hd2u\-0.8.0)
Dos2unix is Blocking hd2u from being emerged. Blockers are defined when
two packages will clobber each others files, or otherwise cause some form
of breakage in your system. However, blockers usually do not need to be
@@ -1087,8 +1093,8 @@ and the KDE configuration dirs; more may be added in the future.
.LP
When Portage installs a file into a protected directory tree like /etc, any
existing files will not be overwritten. If a file of the same name already
-exists, Portage will change the name of the to\-be\-installed file from 'foo' to
-\'._cfg0000_foo\'. If \'._cfg0000_foo\' already exists, this name becomes
+exists, Portage will change the name of the to\-be\-installed file from 'foo'
+to \'._cfg0000_foo\'. If \'._cfg0000_foo\' already exists, this name becomes
\'._cfg0001_foo\', etc. In this way, existing files are not overwritten,
allowing the administrator to manually merge the new config files and avoid any
unexpected changes.
@@ -1100,10 +1106,12 @@ deleted, which is of paramount importance.
.LP
Protected directories are set using the \fICONFIG_PROTECT\fR variable, normally
defined in make.globals. Directory exceptions to the CONFIG_PROTECTed
-directories can be specified using the \fICONFIG_PROTECT_MASK\fR variable. To find
-files that need to be updated in /etc, type \fBfind /etc \-iname \'._cfg????_*\'\fR.
+directories can be specified using the \fICONFIG_PROTECT_MASK\fR variable.
+To find files that need to be updated in /etc, type \fBfind /etc \-iname \'.
+cfg????_*\'\fR.
.LP
-You can disable this feature by setting \fICONFIG_PROTECT="\-*"\fR in \fBmake.conf\fR(5).
+You can disable this feature by setting \fICONFIG_PROTECT="\-*"\fR in
+\fBmake.conf\fR(5).
Then, Portage will mercilessly auto\-update your config files. Alternatively,
you can leave Config File Protection on but tell Portage that it can overwrite
files in certain specific /etc subdirectories. For example, if you wanted
@@ -1113,8 +1121,8 @@ add this to \fBmake.conf\fR(5):
.LP
.I CONFIG_PROTECT_MASK="/etc/wget /etc/rc.d"
.LP
-Tools such as dispatch\-conf, cfg\-update, and etc\-update are also available to
-aid in the merging of these files. They provide interactive merging and can
+Tools such as dispatch\-conf, cfg\-update, and etc\-update are also available
+to aid in the merging of these files. They provide interactive merging and can
auto\-merge trivial changes.
.SH "REPORTING BUGS"
Please report any bugs you encounter through our website:
diff --git a/man/env-update.1 b/man/env-update.1
index c0503ceb0..505152443 100644
--- a/man/env-update.1
+++ b/man/env-update.1
@@ -17,7 +17,8 @@ first.
.SH "OPTIONS"
.TP
.B \-\-no\-ldconfig
-Do not run \fBldconfig\fR (and thus skip rebuilding the \fIld.so.cache\fR, etc...).
+Do not run \fBldconfig\fR (and thus skip rebuilding the \fIld.so.cache\fR,
+etc...).
.SH "REPORTING BUGS"
Please report bugs via http://bugs.gentoo.org/
.SH "AUTHORS"
diff --git a/man/make.conf.5 b/man/make.conf.5
index 451dba917..f75e27754 100644
--- a/man/make.conf.5
+++ b/man/make.conf.5
@@ -154,13 +154,14 @@ automatically have /* appended to them.
Defaults to "/lib/modules/* *.py[co]".
.TP
\fBCONFIG_PROTECT\fR = \fI[space delimited list of files and/or directories]\fR
-All files and/or directories that are defined here will have "config file protection"
-enabled for them. See the \fBCONFIGURATION FILES\fR section
+All files and/or directories that are defined here will have "config file
+protection" enabled for them. See the \fBCONFIGURATION FILES\fR section
of \fBemerge\fR(1) for more information.
.TP
-\fBCONFIG_PROTECT_MASK\fR = \fI[space delimited list of files and/or directories]\fR
-All files and/or directories that are defined here will have "config file protection"
-disabled for them. See the \fBCONFIGURATION FILES\fR section
+\fBCONFIG_PROTECT_MASK\fR = \fI[space delimited list of files and/or \
+directories]\fR
+All files and/or directories that are defined here will have "config file
+protection" disabled for them. See the \fBCONFIGURATION FILES\fR section
of \fBemerge\fR(1) for more information.
.TP
.B CTARGET
@@ -196,9 +197,9 @@ Defines whether or not to ignore audible beeps when displaying important
informational messages. This variable is unset by default.
.TP
.B EMERGE_DEFAULT_OPTS
-Options to append to the end of the \fBemerge\fR(1) command line on every invocation.
-These options will not be appended to the command line if \-\-ignore\-default\-opts
-is specified.
+Options to append to the end of the \fBemerge\fR(1) command line on every
+invocation. These options will not be appended to the command line if
+\-\-ignore\-default\-opts is specified.
.TP
.B EMERGE_LOG_DIR
Controls the location of emerge.log and emerge-fetch.log.
@@ -495,7 +496,8 @@ See also \fIsuidctl\fR below.
.TP
.B sign
When commiting work to cvs with \fBrepoman\fR(1), sign the Manifest with
-a GPG key. Read about the \fIPORTAGE_GPG_KEY\fR variable in \fBmake.conf\fR(5).
+a GPG key. Read about the \fIPORTAGE_GPG_KEY\fR variable in
+\fBmake.conf\fR(5).
.TP
.B skiprocheck
Skip write access checks on \fBDISTDIR\fR when fetching files. This is
@@ -579,7 +581,8 @@ Allow portage to drop root privileges and compile packages as
portage:portage without a sandbox (unless \fIusersandbox\fR is also used).
.TP
.B usersandbox
-Enable the sandbox in the compile phase, when running without root privs (\fIuserpriv\fR).
+Enable the sandbox in the compile phase, when running without root privs
+(\fIuserpriv\fR).
.TP
.B usersync
Drop privileges to the owner of \fBPORTDIR\fR for \fBemerge(1) --sync\fR
@@ -679,9 +682,9 @@ Defaults to /usr/portage/packages.
This variable defines the directory in which per\-ebuild logs are kept.
Logs are created only when this is set. They are stored as
${CATEGORY}:${PF}:YYYYMMDD\-HHMMSS.log in the directory specified. If the
-directory does not exist, it will be created automatically and group permissions
-will be applied to it. If the directory already exists, portage will not
-modify it's permissions.
+directory does not exist, it will be created automatically and group
+permissions will be applied to it. If the directory already exists, portage
+will not modify it's permissions.
.TP
.B PORT_LOGDIR_CLEAN
This variable should contain a command for portage to call in order
@@ -698,7 +701,8 @@ file). This is only used when running with
the get binary pkg options are given to \fBemerge\fR. Review \fBemerge\fR(1)
for more information.
.TP
-\fBPORTAGE_BINHOST_HEADER_URI\fR = \fI"ftp://login:pass@grp.mirror.site/pub/grp/i686/athlon\-xp/"\fR
+\fBPORTAGE_BINHOST_HEADER_URI\fR = \
+\fI"ftp://login:pass@grp.mirror.site/pub/grp/i686/athlon\-xp/"\fR
This variable only makes sense on a system that will serve as a binhost and
build packages for clients. It defines the URI header field for the package
index file which is located at ${PKGDIR}/Packages. Clients that have
@@ -1060,10 +1064,12 @@ Arfrever Frehtes Taifersar Arahesis <arfrever@apache.org>
.SH "FILES"
.TP
\fB/etc/make.conf\fR and \fB/etc/portage/make.conf\fR
-Contains variables for the build\-process and overwrites those in make.defaults.
+Contains variables for the build\-process and overwrites those in
+make.defaults.
.TP
.B /usr/share/portage/config/make.globals
-Contains the default variables for the build\-process, you should edit \fI/etc/portage/make.conf\fR instead.
+Contains the default variables for the build\-process, you should edit
+\fI/etc/portage/make.conf\fR instead.
.TP
.B /etc/portage/color.map
Contains variables customizing colors.
diff --git a/man/portage.5 b/man/portage.5
index 796047f45..827c50402 100644
--- a/man/portage.5
+++ b/man/portage.5
@@ -240,7 +240,8 @@ explaining how they can upgrade.
default-linux/x86/2005.0
# emerge -n '>=sys-apps/portage-2.0.51'
# rm -f /etc/portage/make.profile
-# ln -s /usr/portage/profiles/default-linux/alpha/2005.0 /etc/portage/make.profile
+# ln -s /usr/portage/profiles/default-linux/alpha/2005.0 \
+/etc/portage/make.profile
.fi
.TP
.BR eapi
@@ -281,8 +282,8 @@ for every value in that variable, so USE_EXPAND="FOO" and FOO="bar bla" results
in USE="foo_bar foo_bla".
.TP
\fBUSE_EXPAND_HIDDEN\fR = \fI[space delimited list of variable names]\fR
-Names of \fBUSE_EXPAND\fR variables that should not be shown in the verbose merge
-list output of the \fBemerge\fR(1) command.
+Names of \fBUSE_EXPAND\fR variables that should not be shown in the verbose
+merge list output of the \fBemerge\fR(1) command.
.TP
\fBUSE_EXPAND_IMPLICIT\fR = \fI[space delimited list of variable names]\fR
Defines \fBUSE_EXPAND\fR and \fBUSE_EXPAND_UNPREFIXED\fR
@@ -307,7 +308,8 @@ Defines ELIBC values used to generate implicit
Defines KERNEL values used to generate implicit
\fBIUSE\fR for ebuilds using \fBEAPI 5\fR or later.
.TP
-\fBUSE_EXPAND_VALUES_USERLAND\fR = \fI[space delimited list of USERLAND values]\fR
+\fBUSE_EXPAND_VALUES_USERLAND\fR = \fI[space delimited list of USERLAND \
+values]\fR
Defines USERLAND values used to generate implicit
\fBIUSE\fR for ebuilds using \fBEAPI 5\fR or later.
.TP
@@ -615,9 +617,9 @@ to keep all metadata in that format alone (useful for querying), enable
FEATURES="metadata-transfer" in \fBmake.conf\fR(5).
.TP
\fBpackage.accept_keywords\fR and \fBpackage.keywords\fR
-Per\-package ACCEPT_KEYWORDS. Useful for mixing unstable packages in with a normally
-stable system or vice versa. This will allow ACCEPT_KEYWORDS to be augmented
-for a single package. If both \fBpackage.accept_keywords\fR and
+Per\-package ACCEPT_KEYWORDS. Useful for mixing unstable packages in with a
+normally stable system or vice versa. This will allow ACCEPT_KEYWORDS to be
+augmented for a single package. If both \fBpackage.accept_keywords\fR and
\fBpackage.keywords\fR are present, both of them will be used, and values
from \fBpackage.accept_keywords\fR will override values from
\fBpackage.keywords\fR. The \fBpackage.accept_keywords\fR file is
@@ -658,8 +660,8 @@ example, a binary only package which is built for x86 will look like:
games-fps/quake3-demo-1.11.ebuild:KEYWORDS="-* x86"
-If you wish to accept this package anyways, then use one of the other keywords in your
-package.accept_keywords like this:
+If you wish to accept this package anyways, then use one of the other keywords
+in your package.accept_keywords like this:
games-fps/quake3-demo x86
@@ -687,7 +689,8 @@ directory and have the same format as \fBmake.conf\fR(5).
.I Example:
.nf
-# use environment variables from /etc/portage/env/glibc.conf for the glibc package
+# use environment variables from /etc/portage/env/glibc.conf for the glibc \
+package
sys\-libs/glibc glibc.conf
.fi
@@ -722,8 +725,8 @@ versions earlier than 1.0.4496. No problem!
.fi
.TP
.BR package.properties
-This will allow ACCEPT_PROPERTIES (see \fBmake.conf\fR(5)) to be augmented for a
-single package.
+This will allow ACCEPT_PROPERTIES (see \fBmake.conf\fR(5)) to be augmented for
+a single package.
.I Format:
.nf
@@ -763,7 +766,8 @@ Specifies \fIsite\-specific\fR repository configuration information.
.I Format:
.nf
\- comments begin with # (no inline comments)
-\- configuration of each repository is specified in a section starting with "[${repository_name}]"
+\- configuration of each repository is specified in a section starting with \
+"[${repository_name}]"
\- attributes are specified in "${attribute} = ${value}" format
.fi
@@ -853,7 +857,8 @@ Specifies type of synchronization.
Valid values: cvs, git, rsync
.TP
.B sync\-uri
-Specifies URI of repository used for synchronization performed by `emerge \-\-sync`.
+Specifies URI of repository used for synchronization performed by `emerge
+\-\-sync`.
.RS
.TP
Syntax:
@@ -1185,9 +1190,11 @@ mirrors. Keeps us from overloading a single server.
.I Example:
.nf
-sourceforge http://aleron.dl.sourceforge.net/sourceforge http://unc.dl.sourceforge.net/sourceforge
+sourceforge http://aleron.dl.sourceforge.net/sourceforge \
+http://unc.dl.sourceforge.net/sourceforge
-gentoo http://distro.ibiblio.org/pub/linux/distributions/gentoo/distfiles/ ftp://ftp.gtlib.cc.gatech.edu/pub/gentoo/distfiles
+gentoo http://distro.ibiblio.org/pub/linux/distributions/gentoo/distfiles/ \
+ftp://ftp.gtlib.cc.gatech.edu/pub/gentoo/distfiles
kernel http://www.kernel.org/pub http://www.us.kernel.org/pub
.fi
diff --git a/man/repoman.1 b/man/repoman.1
index bf498d4bd..a025350db 100644
--- a/man/repoman.1
+++ b/man/repoman.1
@@ -1,6 +1,7 @@
.TH "REPOMAN" "1" "May 2013" "Portage VERSION" "Portage"
.SH NAME
-repoman \- Gentoo's program to enforce a minimal level of quality assurance in packages added to the portage tree
+repoman \- Gentoo's program to enforce a minimal level of quality assurance in
+packages added to the portage tree
.SH SYNOPSIS
\fBrepoman\fR [\fIoption\fR] [\fImode\fR]
.SH DESCRIPTION
@@ -9,7 +10,8 @@ repoman \- Gentoo's program to enforce a minimal level of quality assurance in p
.BR repoman
checks the quality of ebuild repositories.
-Note: \fBrepoman commit\fR only works \fIinside local\fR cvs, git, or subversion repositories.
+Note: \fBrepoman commit\fR only works \fIinside local\fR cvs, git, or
+subversion repositories.
.SH OPTIONS
.TP
\fB-a\fR, \fB--ask\fR
@@ -151,16 +153,19 @@ Ebuilds that have a missing or empty HOMEPAGE variable
Virtuals that have a non-empty HOMEPAGE variable
.TP
.B IUSE.invalid
-This ebuild has a variable in IUSE that is not in the use.desc or its metadata.xml file
+This ebuild has a variable in IUSE that is not in the use.desc or its
+metadata.xml file
.TP
.B IUSE.missing
-This ebuild has a USE conditional which references a flag that is not listed in IUSE
+This ebuild has a USE conditional which references a flag that is not listed in
+IUSE
.TP
.B KEYWORDS.dropped
Ebuilds that appear to have dropped KEYWORDS for some arch
.TP
.B KEYWORDS.invalid
-This ebuild contains KEYWORDS that are not listed in profiles/arch.list or for which no valid profile was found
+This ebuild contains KEYWORDS that are not listed in profiles/arch.list or for
+which no valid profile was found
.TP
.B KEYWORDS.missing
Ebuilds that have a missing or empty KEYWORDS variable
@@ -187,7 +192,8 @@ Syntax error in LICENSE (usually an extra/missing space/parenthesis)
Virtuals that have a non-empty LICENSE variable
.TP
.B LIVEVCS.stable
-Ebuild is a live ebuild (cvs, git, darcs, svn, etc) checkout with stable keywords.
+Ebuild is a live ebuild (cvs, git, darcs, svn, etc) checkout with stable
+keywords.
.TP
.B LIVEVCS.unmasked
Ebuild is a live ebuild (cvs, git, darcs, svn, etc) checkout but has keywords
@@ -227,19 +233,23 @@ Missing ChangeLog files
ChangeLogs that exist but have not been added to cvs
.TP
.B dependency.bad
-User-visible ebuilds with unsatisfied dependencies (matched against *visible* ebuilds)
+User-visible ebuilds with unsatisfied dependencies (matched against *visible*
+ebuilds)
.TP
.B dependency.badindev
-User-visible ebuilds with unsatisfied dependencies (matched against *visible* ebuilds) in developing arch
+User-visible ebuilds with unsatisfied dependencies (matched against *visible*
+ebuilds) in developing arch
.TP
.B dependency.badmasked
Masked ebuilds with unsatisfied dependencies (matched against *all* ebuilds)
.TP
.B dependency.badmaskedindev
-Masked ebuilds with unsatisfied dependencies (matched against *all* ebuilds) in developing arch
+Masked ebuilds with unsatisfied dependencies (matched against *all* ebuilds) in
+developing arch
.TP
.B dependency.badtilde
-Uses the ~ dep operator with a non-zero revision part, which is useless (the revision is ignored)
+Uses the ~ dep operator with a non-zero revision part, which is useless (the
+revision is ignored)
.TP
.B dependency.syntax
Syntax error in dependency string (usually an extra/missing space/parenthesis)
@@ -262,10 +272,12 @@ Some files listed in the Manifest aren't referenced in SRC_URI
This ebuild has a malformed header
.TP
.B ebuild.invalidname
-Ebuild files with a non-parseable or syntactically incorrect name (or using 2.1 versioning extensions)
+Ebuild files with a non-parseable or syntactically incorrect name (or using 2.1
+versioning extensions)
.TP
.B ebuild.majorsyn
-This ebuild has a major syntax error that may cause the ebuild to fail partially or fully
+This ebuild has a major syntax error that may cause the ebuild to fail
+partially or fully
.TP
.B ebuild.minorsyn
This ebuild has a minor syntax error that contravenes gentoo coding style
@@ -286,14 +298,15 @@ A simple sourcing of the ebuild produces output; this breaks ebuild policy.
PATCHES variable should be a bash array to ensure white space safety
.TP
.B ebuild.syntax
-Error generating cache entry for ebuild; typically caused by ebuild syntax error
-or digest verification failure.
+Error generating cache entry for ebuild; typically caused by ebuild syntax
+error or digest verification failure.
.TP
.B file.UTF8
File is not UTF8 compliant
.TP
.B file.executable
-Ebuilds, digests, metadata.xml, Manifest, and ChangeLog do not need the executable bit
+Ebuilds, digests, metadata.xml, Manifest, and ChangeLog do not need the
+executable bit
.TP
.B file.name
File/dir name must be composed of only the following chars: a-zA-Z0-9._-+:
diff --git a/man/xpak.5 b/man/xpak.5
index 0b5b87495..6e3d03d13 100644
--- a/man/xpak.5
+++ b/man/xpak.5
@@ -11,7 +11,8 @@ The following conventions cover all occurrences in this documentation
.IP Integer
All offsets/lengths are big endian unsigned 32bit integers
.IP String
-All strings are ASCII encoded, and not NUL terminated (quotes are for illustration only)
+All strings are ASCII encoded, and not NUL terminated (quotes are for
+illustration only)
.IP Values
The actual values of the individual xpak entries are stored as Strings
.P