aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2018-08-05 17:07:35 -0700
committerZac Medico <zmedico@gentoo.org>2019-04-18 10:52:54 -0700
commita859556ffaa4b3f55123215a269228f2ef89ee21 (patch)
treec5f6a807cc60d482a498d3c5ba7722dc07f64488
parentChange /usr/portage council approved locations (bug 378603) (diff)
downloadportage-a859556ffaa4b3f55123215a269228f2ef89ee21.tar.gz
portage-a859556ffaa4b3f55123215a269228f2ef89ee21.tar.bz2
portage-a859556ffaa4b3f55123215a269228f2ef89ee21.zip
Update /usr/portage references (bug 378603)
Update all relevant references in docs, messages, and comments to refer to /var/db/repos/gentoo instead of /usr/portage. Also update DISTDIR and PKGDIR references to refer to the new /var/cache/{distfiles,binpkgs} locations. Bug: https://bugs.gentoo.org/378603 Signed-off-by: Zac Medico <zmedico@gentoo.org>
-rw-r--r--cnf/make.conf.example16
-rw-r--r--lib/portage/__init__.py6
-rw-r--r--lib/portage/cache/flat_hash.py4
-rw-r--r--lib/portage/tests/news/test_NewsItem.py4
-rw-r--r--lib/portage/tests/resolver/ResolverPlayground.py4
-rw-r--r--lib/portage/xml/metadata.py6
-rw-r--r--man/ebuild.59
-rw-r--r--man/emerge.18
-rw-r--r--man/make.conf.526
-rw-r--r--man/portage.532
-rw-r--r--man/quickpkg.14
-rw-r--r--repoman/lib/repoman/__init__.py4
12 files changed, 57 insertions, 66 deletions
diff --git a/cnf/make.conf.example b/cnf/make.conf.example
index 70cb8b19b..94210faa9 100644
--- a/cnf/make.conf.example
+++ b/cnf/make.conf.example
@@ -14,7 +14,7 @@
# https://wiki.gentoo.org/wiki/Handbook:X86/Working/USE
#
# The available list of use flags with descriptions is in the ebuild repository.
-# Use 'less' to view them: --> less /usr/portage/profiles/use.desc <--
+# Use 'less' to view them: --> less /var/db/repos/gentoo/profiles/use.desc <--
#
# 'ufed' is an ncurses/dialog interface available in portage to make handling
# useflags for you. 'emerge app-portage/ufed'
@@ -111,24 +111,20 @@
# will protect the default locations of DISTDIR and PKGDIR, but users are
# warned that any other locations inside PORTDIR are not necessarily safe
# for data storage.
-#PORTDIR=/usr/portage
+#PORTDIR=/var/db/repos/gentoo
#
# DISTDIR is where all of the source code tarballs will be placed for
# emerges. After packages are built, it is safe to remove any and
# all files from this directory since they will be automatically
# fetched on demand for a given build. If you would like to
# selectively prune obsolete files from this directory, see
-# eclean from the gentoolkit package. Note that locations under
-# /usr/portage are not necessarily safe for data storage. See the
-# PORTDIR documentation for more information.
-#DISTDIR=/usr/portage/distfiles
+# eclean from the gentoolkit package.
+#DISTDIR=/var/cache/distfiles
#
# PKGDIR is the location of binary packages that you can have created
# with '--buildpkg' or '-b' while emerging a package. This can get
-# up to several hundred megs, or even a few gigs. Note that
-# locations under /usr/portage are not necessarily safe for data
-# storage. See the PORTDIR documentation for more information.
-#PKGDIR=/usr/portage/packages
+# up to several hundred megs, or even a few gigs.
+#PKGDIR=/var/cache/binpkgs
#
# PORTAGE_LOGDIR is the location where portage will store all the logs it
# creates from each individual merge. They are stored as
diff --git a/lib/portage/__init__.py b/lib/portage/__init__.py
index 053d197b5..b108ca3e5 100644
--- a/lib/portage/__init__.py
+++ b/lib/portage/__init__.py
@@ -1,4 +1,4 @@
-# Copyright 1998-2018 Gentoo Foundation
+# Copyright 1998-2019 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
from __future__ import unicode_literals
@@ -132,8 +132,8 @@ except ImportError as e:
sys.stderr.write("\n\n")
sys.stderr.write("!!! Failed to complete portage imports. There are internal modules for\n")
sys.stderr.write("!!! portage and failure here indicates that you have a problem with your\n")
- sys.stderr.write("!!! installation of portage. Please try a rescue portage located in the\n")
- sys.stderr.write("!!! ebuild repository under '/usr/portage/sys-apps/portage/files/' (default).\n")
+ sys.stderr.write("!!! installation of portage. Please try a rescue portage located in the ebuild\n")
+ sys.stderr.write("!!! repository under '/var/db/repos/gentoo/sys-apps/portage/files/' (default).\n")
sys.stderr.write("!!! There is a README.RESCUE file that details the steps required to perform\n")
sys.stderr.write("!!! a recovery of portage.\n")
sys.stderr.write(" "+str(e)+"\n\n")
diff --git a/lib/portage/cache/flat_hash.py b/lib/portage/cache/flat_hash.py
index 79783245b..451ea9e51 100644
--- a/lib/portage/cache/flat_hash.py
+++ b/lib/portage/cache/flat_hash.py
@@ -1,4 +1,4 @@
-# Copyright 2005-2016 Gentoo Foundation
+# Copyright 2005-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# Author(s): Brian Harring (ferringb@gentoo.org)
@@ -144,7 +144,7 @@ class database(fs_template.FsBased):
# Only recurse 1 deep, in order to avoid iteration over
# entries from another nested cache instance. This can
# happen if the user nests an overlay inside
- # /usr/portage/local as in bug #302764.
+ # /var/db/repos/gentoo/local as in bug #302764.
if depth < 1:
dirs.append((depth+1, p))
continue
diff --git a/lib/portage/tests/news/test_NewsItem.py b/lib/portage/tests/news/test_NewsItem.py
index 2f183a7e0..22c7fc7dc 100644
--- a/lib/portage/tests/news/test_NewsItem.py
+++ b/lib/portage/tests/news/test_NewsItem.py
@@ -1,5 +1,5 @@
# test_NewsItem.py -- Portage Unit Testing Functionality
-# Copyright 2007 Gentoo Foundation
+# Copyright 2007-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
from portage import os
@@ -43,7 +43,7 @@ against YourSQL:
The revdep-rebuild tool is provided by app-portage/gentoolkit.
"""
def setUp(self):
- self.profile = "/usr/portage/profiles/default-linux/x86/2007.0/"
+ self.profile = "/var/db/repos/gentoo/profiles/default-linux/x86/2007.0/"
self.keywords = "x86"
# Use fake/test dbapi to avoid slow tests
self.vardb = testdbapi()
diff --git a/lib/portage/tests/resolver/ResolverPlayground.py b/lib/portage/tests/resolver/ResolverPlayground.py
index fc754fb42..22d54e251 100644
--- a/lib/portage/tests/resolver/ResolverPlayground.py
+++ b/lib/portage/tests/resolver/ResolverPlayground.py
@@ -1,4 +1,4 @@
-# Copyright 2010-2015 Gentoo Foundation
+# Copyright 2010-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
from itertools import permutations
@@ -399,7 +399,7 @@ class ResolverPlayground(object):
f.write("masters =\n")
if repo == "test_repo":
- #Create a minimal profile in /usr/portage
+ #Create a minimal profile in /var/db/repos/gentoo
sub_profile_dir = os.path.join(profile_dir, "default", "linux", "x86", "test_profile")
os.makedirs(sub_profile_dir)
diff --git a/lib/portage/xml/metadata.py b/lib/portage/xml/metadata.py
index 9e48dddde..24888bb47 100644
--- a/lib/portage/xml/metadata.py
+++ b/lib/portage/xml/metadata.py
@@ -1,13 +1,13 @@
-# Copyright 2010-2017 Gentoo Foundation
+# Copyright 2010-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
"""Provides an easy-to-use python interface to Gentoo's metadata.xml file.
Example usage:
>>> from portage.xml.metadata import MetaDataXML
- >>> pkg_md = MetaDataXML('/usr/portage/app-misc/gourmet/metadata.xml')
+ >>> pkg_md = MetaDataXML('/var/db/repos/gentoo/app-misc/gourmet/metadata.xml')
>>> pkg_md
- <MetaDataXML '/usr/portage/app-misc/gourmet/metadata.xml'>
+ <MetaDataXML '/var/db/repos/gentoo/app-misc/gourmet/metadata.xml'>
>>> pkg_md.herds()
['no-herd']
>>> for maint in pkg_md.maintainers():
diff --git a/man/ebuild.5 b/man/ebuild.5
index 27f47d2b1..20684d8f4 100644
--- a/man/ebuild.5
+++ b/man/ebuild.5
@@ -1,4 +1,4 @@
-.TH "EBUILD" "5" "Oct 2017" "Portage VERSION" "Portage"
+.TH "EBUILD" "5" "Apr 2019" "Portage VERSION" "Portage"
.SH "NAME"
ebuild \- the internal format, variables, and functions in an ebuild script
@@ -530,7 +530,8 @@ being submitted for inclusion, it must have ~arch set for architectures
where it has been PROVEN TO WORK. (Packages KEYWORDed this way may be
unmasked for testing by setting ACCEPT_KEYWORDS="~arch" on the command
line, or in \fBmake.conf\fR(5)) For an authoritative list please review
-/usr/portage/profiles/arch.list. Please keep this list in alphabetical order.
+/var/db/repos/gentoo/profiles/arch.list. Please keep this list in
+alphabetical order.
.TP
.B SLOT
This sets the SLOT for packages that may need to have multiple versions
@@ -553,8 +554,8 @@ usage.
.B LICENSE
This should be a space delimited list of licenses that the package falls
under. This \fB_must_\fR be set to a matching license in
-/usr/portage/licenses/. If the license does not exist in portage yet, you
-must add it first.
+/var/db/repos/gentoo/licenses/. If the license does not exist in the repository
+yet, you must add it first.
.TP
.B IUSE
This should be a list of any and all USE flags that are leveraged within
diff --git a/man/emerge.1 b/man/emerge.1
index afac83e76..78ac55e25 100644
--- a/man/emerge.1
+++ b/man/emerge.1
@@ -1,4 +1,4 @@
-.TH "EMERGE" "1" "Mar 2018" "Portage VERSION" "Portage"
+.TH "EMERGE" "1" "Apr 2019" "Portage VERSION" "Portage"
.SH "NAME"
emerge \- Command\-line interface to the Portage system
.SH "SYNOPSIS"
@@ -43,7 +43,7 @@ as \fBsys\-apps/portage\fR or \fB=python\-2.2.1\-r2\fR.
\fBemerge\fR
ignores a trailing slash so that filename completion can be used.
The \fIebuild\fR may also be an actual filename, such as
-\fB/usr/portage/app\-admin/python/python\-2.2.1\-r2.ebuild\fR.
+\fB/var/db/repos/gentoo/app\-admin/python/python\-2.2.1\-r2.ebuild\fR.
\fBWARNING:\fR The implementation of \fBemerge /path/to/ebuild\fR is broken and
so this syntax shouldn't be used.
.TP
@@ -1280,7 +1280,7 @@ avoid dependency conflicts and/or unsatisfied dependencies.
.BR package.mask
The \fBpackage.mask\fR file primarily blocks the use of packages that cause
problems or are known to have issues on different systems. It resides in
-\fI/usr/portage/profiles\fR.
+\fI/var/db/repos/gentoo/profiles\fR.
.TP
.BR CHOST
Use the \fBACCEPT_CHOSTS\fR variable in \fBmake.conf\fR(5) to control
@@ -1426,7 +1426,7 @@ files.
Contains profile\-specific variables for the build process. \fBDo not
edit this file\fR.
.TP
-.B /usr/portage/profiles/use.desc
+.B /var/db/repos/gentoo/profiles/use.desc
Contains the master list of USE flags with descriptions of their
functions. \fBDo not edit this file\fR.
.TP
diff --git a/man/make.conf.5 b/man/make.conf.5
index adbd6dc85..0ad3e2f7d 100644
--- a/man/make.conf.5
+++ b/man/make.conf.5
@@ -1,4 +1,4 @@
-.TH "MAKE.CONF" "5" "Feb 2019" "Portage VERSION" "Portage"
+.TH "MAKE.CONF" "5" "Apr 2019" "Portage VERSION" "Portage"
.SH "NAME"
make.conf \- custom settings for Portage
.SH "SYNOPSIS"
@@ -217,12 +217,8 @@ like to selectively prune obsolete files from this directory, see
Use the \fBPORTAGE_RO_DISTDIRS\fR variable to specify one or
more read-only directories containing distfiles.
-
-Note
-that locations under /usr/portage are not necessarily safe for data storage.
-See the \fBPORTDIR\fR documentation for more information.
.br
-Defaults to /usr/portage/distfiles.
+Defaults to /var/cache/distfiles.
.TP
.B DOC_SYMLINKS_DIR
If this variable contains a directory then symlinks to html documentation will
@@ -826,11 +822,9 @@ By default, a given package is stored in a subdirectory corresponding
to it's category. However, for backward compatibility with the layout
used by older versions of portage, if the \fI${PKGDIR}/All\fR directory
exists then all packages will be stored inside of it and symlinks to
-the packages will be created in the category subdirectories. Note
-that locations under /usr/portage are not necessarily safe for data storage.
-See the \fBPORTDIR\fR documentation for more information.
+the packages will be created in the category subdirectories.
.br
-Defaults to /usr/portage/packages.
+Defaults to /var/cache/binpkgs.
.TP
.B PORT_LOGDIR
See \fIPORTAGE_LOGDIR\fR below. Deprecated.
@@ -1066,7 +1060,7 @@ Defines the location of main repository. This variable is deprecated in favor of
settings in \fBrepos.conf\fR. If you change this, you must update
your /etc/portage/make.profile symlink accordingly.
.br
-Defaults to /usr/portage.
+Defaults to /var/db/repos/gentoo.
.br
\fB***Warning***\fR
.br
@@ -1151,7 +1145,7 @@ rsync://private\-mirror.com/portage\-module
.br
rsync://rsync\-user@private\-mirror.com:873/gentoo\-portage
.br
-ssh://ssh\-user@192.168.0.1:22/usr/portage
+ssh://ssh\-user@192.168.0.1:22/var/db/repos/gentoo
.br
ssh://ssh\-user@192.168.0.1:22/\\${HOME}/portage\-storage
.TP
@@ -1169,7 +1163,7 @@ Defaults to "/lib/modules/*".
\fBUSE\fR = \fI[space delimited list of USE items]\fR
This variable contains options that control the build behavior of several
packages. More information in \fBebuild\fR(5). Possible USE values
-can be found in \fI/usr/portage/profiles/use.desc\fR.
+can be found in \fI/var/db/repos/gentoo/profiles/use.desc\fR.
.TP
\fBUSE_ORDER\fR = \fI"env:pkg:conf:defaults:pkginternal:features:repo:env.d"\fR
Determines the precedence of layers in the incremental stacking of the USE
@@ -1206,7 +1200,7 @@ for FEATURES=\fBtest\fR.
.TP
.B repo
USE from make.defaults and package.use in the repo's profiles/ top dir
-(e.g. /usr/portage/profiles/package.use) (see \fBportage\fR(5))
+(e.g. /var/db/repos/gentoo/profiles/package.use) (see \fBportage\fR(5))
.TP
.B env.d
USE from the environment variables, such as LINGUAS, defined by files in
@@ -1236,10 +1230,10 @@ Contains the default variables for the build\-process, you should edit
.B /etc/portage/color.map
Contains variables customizing colors.
.TP
-.B /usr/portage/profiles/use.desc
+.B /var/db/repos/gentoo/profiles/use.desc
Contains a list of all global USE flags.
.TP
-.B /usr/portage/profiles/use.local.desc
+.B /var/db/repos/gentoo/profiles/use.local.desc
Contains a list of all local USE variables.
.SH "SEE ALSO"
.BR emerge (1),
diff --git a/man/portage.5 b/man/portage.5
index caf993672..36c871123 100644
--- a/man/portage.5
+++ b/man/portage.5
@@ -1,4 +1,4 @@
-.TH "PORTAGE" "5" "Apr 2018" "Portage VERSION" "Portage"
+.TH "PORTAGE" "5" "Apr 2019" "Portage VERSION" "Portage"
.SH NAME
portage \- the heart of Gentoo
.SH "DESCRIPTION"
@@ -77,18 +77,18 @@ site-specific overrides of \fB/etc/portage/make.profile/\fR
.BR /etc/portage/sets/
user\-defined package sets
.TP
-.BR /usr/portage/
+.BR /var/db/repos/gentoo/
.nf
sets.conf
.fi
.TP
-.BR /usr/portage/metadata/
+.BR /var/db/repos/gentoo/metadata/
.nf
layout.conf
pkg_desc_index
.fi
.TP
-.BR /usr/portage/profiles/
+.BR /var/db/repos/gentoo/profiles/
.nf
arch.list
categories
@@ -214,7 +214,7 @@ More reading:
.TP
\fB/etc/portage/make.profile/\fR or \fB/etc/make.profile/\fR
This is usually just a symlink to the correct profile in
-\fB/usr/portage/profiles/\fR. Since it is part of the ebuild repository, it
+\fB/var/db/repos/gentoo/profiles/\fR. Since it is part of the ebuild repository, it
may easily be updated/regenerated by running `emerge \-\-sync`. It defines
what a profile is (usually arch specific stuff). If you need a custom
profile, then you should make your own \fBmake.profile\fR
@@ -248,10 +248,10 @@ explaining how they can upgrade.
.I Example:
.nf
-default-linux/x86/2005.0
-# emerge -n '>=sys-apps/portage-2.0.51'
+default/linux/amd64/17.0
+# emerge -n '>=sys-apps/portage-2.3.62'
# rm -f /etc/portage/make.profile
-# ln -s /usr/portage/profiles/default-linux/alpha/2005.0 \
+# ln -s /var/db/repos/gentoo/profiles/default/linux/amd64/17.0 \
/etc/portage/make.profile
.fi
.TP
@@ -644,7 +644,7 @@ The global custom settings for Portage. See \fBmake.conf\fR(5).
.BR mirrors
Whenever portage encounters a mirror:// style URI it will look up the actual
hosts here. If the mirror set is not found here, it will check the global
-mirrors file at /usr/portage/profiles/thirdpartymirrors. You may also set a
+mirrors file at /var/db/repos/gentoo/profiles/thirdpartymirrors. You may also set a
special mirror type called "local". This list of mirrors will be checked
before GENTOO_MIRRORS and will be used even if the package has
RESTRICT="mirror" or RESTRICT="fetch".
@@ -1094,7 +1094,7 @@ rsync://private\-mirror.com/portage\-module
.br
rsync://rsync\-user@private\-mirror.com:873/gentoo\-portage
.br
-ssh://ssh\-user@192.168.0.1:22/usr/portage
+ssh://ssh\-user@192.168.0.1:22/var/db/repos/gentoo
.br
ssh://ssh\-user@192.168.0.1:22/\\${HOME}/portage\-storage
.RE
@@ -1218,7 +1218,7 @@ masters =
# Repository 'gentoo' synchronized using CVS
[gentoo]
-location = /usr/portage
+location = /var/db/repos/gentoo
sync\-type = cvs
sync\-uri = :pserver:anonymous@anoncvs.gentoo.org:/var/cvsroot
sync\-cvs\-repo = gentoo\-x86
@@ -1235,7 +1235,7 @@ auto\-sync = yes
.TP
.BR sets.conf
A package set configuration file. Settings here override settings from
-\fB/usr/portage/sets.conf\fR and \fB/usr/share/portage/config/sets\fR.
+\fB/var/db/repos/gentoo/sets.conf\fR and \fB/usr/share/portage/config/sets\fR.
The format is described extensively in the
\fIPackage Set Configuration\fR section of the html documentation which
is installed with portage when the "doc" USE flag is enabled.
@@ -1296,7 +1296,7 @@ Also see \fB/var/lib/portage/world_sets\fR and the \fBemerge\fR(1)
\fB\-\-list\-sets\fR option.
.RE
.TP
-.BR /usr/portage/
+.BR /var/db/repos/gentoo/
.RS
.TP
.BR sets.conf
@@ -1305,7 +1305,7 @@ which overrides these settings, and
\fB/usr/share/portage/config/sets\fR which contains default settings.
.RE
.TP
-.BR /usr/portage/metadata/
+.BR /var/db/repos/gentoo/metadata/
.RS
.TP
.BR layout.conf
@@ -1472,7 +1472,7 @@ sys-apps/usleep 0.1: A wrapper for usleep
.fi
.RE
.TP
-.BR /usr/portage/profiles/
+.BR /var/db/repos/gentoo/profiles/
Global Gentoo settings that are controlled by the developers. To override
these settings, you can use the files in \fB/etc/portage/\fR.
.RS
@@ -1683,7 +1683,7 @@ for \fB/etc/portage/repos.conf\fR.
.TP
.BR sets
A directory containing package set configuration files. Also see
-\fB/etc/portage/sets.conf\fR and \fB/usr/portage/sets.conf\fR, both of
+\fB/etc/portage/sets.conf\fR and \fB/var/db/repos/gentoo/sets.conf\fR, both of
which override values set here. Default set configurations are installed
in \fB/usr/share/portage/config/sets/portage.conf\fR.
.RE
diff --git a/man/quickpkg.1 b/man/quickpkg.1
index 06a1f0b6e..a6aff7c50 100644
--- a/man/quickpkg.1
+++ b/man/quickpkg.1
@@ -1,4 +1,4 @@
-.TH "QUICKPKG" "1" "Dec 2012" "Portage VERSION" "Portage"
+.TH "QUICKPKG" "1" "Apr 2019" "Portage VERSION" "Portage"
.SH NAME
quickpkg \- creates portage packages
.SH SYNOPSIS
@@ -17,7 +17,7 @@ modified since they were first installed.
.br
The packages, after being created, will be placed in \fBPKGDIR\fR.
This variable is defined in \fBmake.conf\fR(5) and defaults to
-/usr/portage/packages.
+/var/cache/binpkgs.
.SH OPTIONS
.TP
.B <list of packages or package\-sets>
diff --git a/repoman/lib/repoman/__init__.py b/repoman/lib/repoman/__init__.py
index 301b34309..4f3e59e50 100644
--- a/repoman/lib/repoman/__init__.py
+++ b/repoman/lib/repoman/__init__.py
@@ -13,8 +13,8 @@ except ImportError as e:
sys.stderr.write("\n\n")
sys.stderr.write("!!! Failed to complete portage imports. There are internal modules for\n")
sys.stderr.write("!!! portage and failure here indicates that you have a problem with your\n")
- sys.stderr.write("!!! installation of portage. Please try a rescue portage located in the\n")
- sys.stderr.write("!!! ebuild repository under '/usr/portage/sys-apps/portage/files/' (default).\n")
+ sys.stderr.write("!!! installation of portage. Please try a rescue portage located in the ebuild\n")
+ sys.stderr.write("!!! repository under '/var/db/repos/gentoo/sys-apps/portage/files/' (default).\n")
sys.stderr.write("!!! There is a README.RESCUE file that details the steps required to perform\n")
sys.stderr.write("!!! a recovery of portage.\n")
sys.stderr.write(" "+str(e)+"\n\n")