aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-07-26 08:51:05 +0100
committerSam James <sam@gentoo.org>2023-07-26 08:58:30 +0100
commitedb9a6244be524ace95a48282e114d073ff37ad8 (patch)
tree2589c099221ddd365b59527adaf0e3685c53c8a5
parentdepgraph.py: fix wrong type annotations (diff)
downloadportage-edb9a6244be524ace95a48282e114d073ff37ad8.tar.gz
portage-edb9a6244be524ace95a48282e114d073ff37ad8.tar.bz2
portage-edb9a6244be524ace95a48282e114d073ff37ad8.zip
Increase minimum Python version from Python 3.6/3.7 -> Python 3.9
We don't seem to have been consistent as to whether it was 3.6 or 3.7, but we weren't testing it consistently anyway. It feels too soon to go up to 3.10 unfortunately, but 3.6/3.7 are EOL and 3.8 is EOL next year, so let's do 3.9. Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--.github/workflows/ci.yml4
-rw-r--r--.github/workflows/lint.yml2
-rw-r--r--DEVELOPING2
-rw-r--r--NEWS3
-rw-r--r--README.md2
-rwxr-xr-xsetup.py2
-rw-r--r--tox.ini4
7 files changed, 7 insertions, 12 deletions
diff --git a/.github/workflows/ci.yml b/.github/workflows/ci.yml
index c17e74e91..6bfe4847a 100644
--- a/.github/workflows/ci.yml
+++ b/.github/workflows/ci.yml
@@ -12,14 +12,10 @@ jobs:
strategy:
matrix:
python-version:
- - '3.7'
- - '3.8'
- '3.9'
- '3.10'
- '3.11'
- '3.12-dev'
- - 'pypy-3.7'
- - 'pypy-3.8'
- 'pypy-3.9'
fail-fast: false
steps:
diff --git a/.github/workflows/lint.yml b/.github/workflows/lint.yml
index 8263567a1..469cffe37 100644
--- a/.github/workflows/lint.yml
+++ b/.github/workflows/lint.yml
@@ -22,8 +22,6 @@ jobs:
strategy:
matrix:
python-version:
- - '3.7'
- - '3.8'
- '3.9'
- '3.10'
- '3.11'
diff --git a/DEVELOPING b/DEVELOPING
index 2f05d49b5..0d414c4da 100644
--- a/DEVELOPING
+++ b/DEVELOPING
@@ -9,7 +9,7 @@ bad habits that exist in the current codebase.
Python Version
--------------
-Python 3.7 is the minimum supported version.
+Python 3.9 is the minimum supported version.
Dependencies
------------
diff --git a/NEWS b/NEWS
index fe59a1ddf..fcbbdb2a5 100644
--- a/NEWS
+++ b/NEWS
@@ -1,6 +1,9 @@
portage-3.0.50 (UNRELEASED)
--------------
+Breaking changes:
+* The minimum supported Python version is now >= Python 3.9.
+
Bug fixes:
* install-qa-check.d/05prefix: Fix prefixifying shebang for >= EAPI 7 ebuilds
(bug #909147).
diff --git a/README.md b/README.md
index 08b06c10f..481d12bac 100644
--- a/README.md
+++ b/README.md
@@ -52,7 +52,7 @@ git config blame.ignoreRevsFile .git-blame-ignore-revs
Dependencies
============
-Python and Bash should be the only hard dependencies. Python 3.7 is the
+Python and Bash should be the only hard dependencies. Python 3.9 is the
minimum supported version.
Native Extensions
diff --git a/setup.py b/setup.py
index 3c343aabd..4525264c7 100755
--- a/setup.py
+++ b/setup.py
@@ -921,5 +921,5 @@ setup(
"Programming Language :: Python :: 3",
"Topic :: System :: Installation/Setup",
],
- python_requires=">=3.6",
+ python_requires=">=3.9",
)
diff --git a/tox.ini b/tox.ini
index cec7dd833..4ea388e35 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,11 +1,9 @@
[tox]
-envlist = py{37,38,39,310,311,312}-{pylint,test},pypy3-test
+envlist = py{39,310,311,312}-{pylint,test},pypy3-test
skipsdist = True
[gh-actions]
python =
- 3.7: py37
- 3.8: py38
3.9: py39
3.10: py310
3.11: py311