aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2021-02-28 21:39:01 -0800
committerZac Medico <zmedico@gentoo.org>2021-03-02 00:56:46 -0800
commit3253686e9438a918b104089b6e2f8d4e8d9eb4a7 (patch)
tree73caeed4435b8d0d875eb6211ad4b45054ac5205 /lib/portage
parentsetup.py: change default sdist format to xz (diff)
downloadportage-3253686e9438a918b104089b6e2f8d4e8d9eb4a7.tar.gz
portage-3253686e9438a918b104089b6e2f8d4e8d9eb4a7.tar.bz2
portage-3253686e9438a918b104089b6e2f8d4e8d9eb4a7.zip
emerge: make --binpkg-respect-use=y imply --autounmask-use=n
If --binpkg-respect-use=y is given explicitly, then it implies --autounmask-use=n, because these options naturally oppose eachother. Bug: https://bugs.gentoo.org/773469 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'lib/portage')
-rw-r--r--lib/portage/tests/resolver/test_useflags.py20
1 files changed, 14 insertions, 6 deletions
diff --git a/lib/portage/tests/resolver/test_useflags.py b/lib/portage/tests/resolver/test_useflags.py
index d66da0866..b799e62ff 100644
--- a/lib/portage/tests/resolver/test_useflags.py
+++ b/lib/portage/tests/resolver/test_useflags.py
@@ -46,15 +46,23 @@ class UseFlagsTestCase(TestCase):
success = True,
mergelist = ["dev-libs/A-1"]),
- # In the unit test case for bug 773469, the --autounmask-backtrack option
- # is needed in order to trigger the --binpkg-respect-use=y behavior that
- # appears confusingly similar to --binpkg-respect-use=n behavior.
+ # For bug 773469, we wanted --binpkg-respect-use=y to trigger a
+ # slot collision. Instead, a combination of default --autounmask-use
+ # combined with --autounmask-backtrack=y from EMERGE_DEFAULT_OPTS
+ # triggered this behavior which appeared confusingly similar to
+ #--binpkg-respect-use=n behavior.
+ #ResolverPlaygroundTestCase(
+ # ["dev-libs/C", "dev-libs/D"],
+ # options={"--usepkg": True, "--binpkg-respect-use": "y", "--autounmask-backtrack": "y"},
+ # success=True,
+ # use_changes={"dev-libs/C-1": {"abi_x86_32": True}},
+ # mergelist=["[binary]dev-libs/C-1", "[binary]dev-libs/D-1"],
ResolverPlaygroundTestCase(
["dev-libs/C", "dev-libs/D"],
options={"--usepkg": True, "--binpkg-respect-use": "y", "--autounmask-backtrack": "y"},
- success=True,
- use_changes={"dev-libs/C-1": {"abi_x86_32": True}},
- mergelist=["[binary]dev-libs/C-1", "[binary]dev-libs/D-1"],
+ success=False,
+ slot_collision_solutions=[{"dev-libs/C-1": {"abi_x86_32": True}}],
+ mergelist=["dev-libs/C-1", "[binary]dev-libs/D-1"],
),
#--binpkg-respect-use=n: use binpkgs with different use flags