aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2016-05-10 01:49:48 -0700
committerBrian Dolbec <dolsen@gentoo.org>2016-05-14 11:29:40 -0700
commit3c3c4cf1fd7e99995ccdfd43320cce1a97432b99 (patch)
tree7f922d910bf398f595cad9c5c98d1f567aa79943 /repoman/pym/repoman/modules/scan/options/__init__.py
parentrepoman Comment out the $ID header check for now. bug 579460 (diff)
downloadportage-3c3c4cf1fd7e99995ccdfd43320cce1a97432b99.tar.gz
portage-3c3c4cf1fd7e99995ccdfd43320cce1a97432b99.tar.bz2
portage-3c3c4cf1fd7e99995ccdfd43320cce1a97432b99.zip
Bulk move of repoman to it's own namespace for better packaging
Edit repoman calls from portage setup.py, MANIFEST.in. Copy setup.py to the new repoman pkg, begin edit for repoman. Copy TEST-NOTES to repoman
Diffstat (limited to 'repoman/pym/repoman/modules/scan/options/__init__.py')
-rw-r--r--repoman/pym/repoman/modules/scan/options/__init__.py28
1 files changed, 28 insertions, 0 deletions
diff --git a/repoman/pym/repoman/modules/scan/options/__init__.py b/repoman/pym/repoman/modules/scan/options/__init__.py
new file mode 100644
index 000000000..a5746ce67
--- /dev/null
+++ b/repoman/pym/repoman/modules/scan/options/__init__.py
@@ -0,0 +1,28 @@
+# Copyright 2015-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+doc = """Options plug-in module for repoman.
+Performs option related actions on ebuilds."""
+__doc__ = doc[:]
+
+
+module_spec = {
+ 'name': 'options',
+ 'description': doc,
+ 'provides':{
+ 'options-module': {
+ 'name': "options",
+ 'sourcefile': "options",
+ 'class': "Options",
+ 'description': doc,
+ 'functions': ['is_forced'],
+ 'func_desc': {
+ },
+ 'mod_kwargs': ['options',
+ ],
+ 'func_kwargs': {
+ },
+ },
+ }
+}
+