aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2018-05-01 19:27:12 -0700
committerZac Medico <zmedico@gentoo.org>2018-05-01 19:29:13 -0700
commit5914efcecc6821c09aa1e6a62d0da8ee3fe8b56f (patch)
tree5e8843a6a66a7b71b6bc616be106c433e3743300 /repoman
parentBINPKG_COMPRESS: allow empty setting to disable compression (bug 654456) (diff)
downloadportage-5914efcecc6821c09aa1e6a62d0da8ee3fe8b56f.tar.gz
portage-5914efcecc6821c09aa1e6a62d0da8ee3fe8b56f.tar.bz2
portage-5914efcecc6821c09aa1e6a62d0da8ee3fe8b56f.zip
setup.py: fix sdist bztar format default for python3.6
Since python3.6 defaults to gztar format unconditionally, override it.
Diffstat (limited to 'repoman')
-rwxr-xr-xrepoman/setup.py3
1 files changed, 1 insertions, 2 deletions
diff --git a/repoman/setup.py b/repoman/setup.py
index 3bb76ab8a..16ee0bc63 100755
--- a/repoman/setup.py
+++ b/repoman/setup.py
@@ -347,8 +347,7 @@ class x_sdist(sdist):
""" sdist defaulting to .tar.bz2 format, and archive files owned by root """
def finalize_options(self):
- if self.formats is None:
- self.formats = ['bztar']
+ self.formats = ['bztar']
if self.owner is None:
self.owner = 'root'
if self.group is None: