aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2020-08-04 14:13:18 -0700
committerZac Medico <zmedico@gentoo.org>2020-08-04 19:27:39 -0700
commitbbb3434b22beac53bc8514683281419bde72c9cf (patch)
tree3507f05bf219f40f0c6ec18adc9c3a59942f56c2 /setup.py
parentDEVELOPING: Update minimum python version (diff)
downloadportage-bbb3434b22beac53bc8514683281419bde72c9cf.tar.gz
portage-bbb3434b22beac53bc8514683281419bde72c9cf.tar.bz2
portage-bbb3434b22beac53bc8514683281419bde72c9cf.zip
tox: call pylint for whole repo
In addition to checking the whole repo, this fixes the import-error check. Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py16
1 files changed, 0 insertions, 16 deletions
diff --git a/setup.py b/setup.py
index 1c25b9cd7..bef5c31fa 100755
--- a/setup.py
+++ b/setup.py
@@ -606,21 +606,6 @@ class test(Command):
])
-class lint(Command):
- """ run lint """
-
- user_options = []
-
- def initialize_options(self):
- pass
-
- def finalize_options(self):
- pass
-
- def run(self):
- subprocess.check_call(['pylint', 'lib'])
-
-
def find_packages():
for dirpath, _dirnames, filenames in os.walk('lib'):
if '__init__.py' in filenames:
@@ -721,7 +706,6 @@ setup(
'install_scripts_sbin': x_install_scripts_sbin,
'sdist': x_sdist,
'test': test,
- 'lint': lint,
},
classifiers = [