aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'lib/portage/emaint/modules/binhost')
-rw-r--r--lib/portage/emaint/modules/binhost/binhost.py8
-rw-r--r--lib/portage/emaint/modules/binhost/meson.build8
2 files changed, 11 insertions, 5 deletions
diff --git a/lib/portage/emaint/modules/binhost/binhost.py b/lib/portage/emaint/modules/binhost/binhost.py
index 9d924f7e1..ece686591 100644
--- a/lib/portage/emaint/modules/binhost/binhost.py
+++ b/lib/portage/emaint/modules/binhost/binhost.py
@@ -11,7 +11,6 @@ from portage.versions import _pkg_str
class BinhostHandler:
-
short_desc = "Generate a metadata index for binary packages"
@staticmethod
@@ -26,7 +25,6 @@ class BinhostHandler:
self._pkgindex = self._bintree._load_pkgindex()
def _need_update(self, cpv, data):
-
if "MD5" not in data:
return True
@@ -86,9 +84,9 @@ class BinhostHandler:
missing.append(cpv)
if onProgress:
onProgress(maxval, i + 1)
- errors = ["'%s' is not in Packages" % cpv for cpv in missing]
+ errors = [f"'{cpv}' is not in Packages" for cpv in missing]
for cpv in stale:
- errors.append("'%s' is not in the repository" % cpv)
+ errors.append(f"'{cpv}' is not in the repository")
if errors:
return (False, errors)
return (True, None)
@@ -158,7 +156,7 @@ class BinhostHandler:
bintree._eval_use_flags(cpv, d)
except portage.exception.InvalidDependString:
writemsg(
- "!!! Invalid binary package: '%s'\n" % bintree.getname(cpv),
+ f"!!! Invalid binary package: '{bintree.getname(cpv)}'\n",
noiselevel=-1,
)
else:
diff --git a/lib/portage/emaint/modules/binhost/meson.build b/lib/portage/emaint/modules/binhost/meson.build
new file mode 100644
index 000000000..457737014
--- /dev/null
+++ b/lib/portage/emaint/modules/binhost/meson.build
@@ -0,0 +1,8 @@
+py.install_sources(
+ [
+ 'binhost.py',
+ '__init__.py',
+ ],
+ subdir : 'portage/emaint/modules/binhost',
+ pure : not native_extensions
+)