aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik (Xarthisius) <xarthisius@gentoo.org>2012-06-08 22:35:31 +0200
committerKacper Kowalik (Xarthisius) <xarthisius@gentoo.org>2012-06-08 22:35:31 +0200
commit0f606751651e6b9646778ad5b5cbd639f057490f (patch)
tree79f094e28e8ef2dbac7954320d16b8c7365ef8db /dev-python/ws4py/ws4py-0.2.1-r3.ebuild
parent[dev-python/autobahntestsuite] add missing dependency on dev-python/twisted-web (diff)
downloadpython-0f606751651e6b9646778ad5b5cbd639f057490f.tar.gz
python-0f606751651e6b9646778ad5b5cbd639f057490f.tar.bz2
python-0f606751651e6b9646778ad5b5cbd639f057490f.zip
[dev-python/ws4py] import from main tree, add missing deps, fix for vcs-snapshot-r1, enable tests - work in progress
Diffstat (limited to 'dev-python/ws4py/ws4py-0.2.1-r3.ebuild')
-rw-r--r--dev-python/ws4py/ws4py-0.2.1-r3.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/ws4py/ws4py-0.2.1-r3.ebuild b/dev-python/ws4py/ws4py-0.2.1-r3.ebuild
new file mode 100644
index 0000000..4bb8cc7
--- /dev/null
+++ b/dev-python/ws4py/ws4py-0.2.1-r3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ws4py/ws4py-0.2.1-r2.ebuild,v 1.1 2012/04/24 02:31:04 vapier Exp $
+
+# We could depend on dev-python/cherrypy when USE=server, but
+# that is an optional component ...
+# Same for www-servers/tornado and USE=client ...
+
+EAPI="4"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils eutils
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/Lawouach/WebSocket-for-Python.git"
+ inherit git-2
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/Lawouach/WebSocket-for-Python/tarball/v${PV} -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="WebSocket support for Python"
+HOMEPAGE="https://github.com/Lawouach/WebSocket-for-Python"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="+client +server +threads"
+
+RDEPEND="client? ( dev-lang/python[threads?] )
+ dev-python/gevent"
+# one-of-many for server???
+DEPEND="
+ test? (
+ dev-python/authobahntestsuite
+ dev-python/cherrypy
+ www-servers/tornado
+ ${RDEPEND}
+ )
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-process-data.patch
+ distutils_src_prepare
+}
+
+# Figure out how to run them...
+#src_test() {
+# cd test
+# python autobahn_test_servers.py --run-all
+# wstest -m fuzzingclient -s fuzzingclient.json
+#}
+
+src_install() {
+ distutils_src_install
+ use client || rm -rf "${ED}$(python_get_sitedir)"/ws4py/client
+ use server || rm -rf "${ED}$(python_get_sitedir)"/ws4py/server
+}