aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-24 18:20:34 +0100
committerSam James <sam@gentoo.org>2023-05-24 18:20:34 +0100
commit0750bcb0c088d7c81e96607ec3d6e61f80149d2f (patch)
tree7aefbaaa21c78173736383c5f13be6423097d0ba /Makefile.gpyutils
parenthtdocs: link to py3.11->py3.12 porting list (diff)
downloadqa-scripts-0750bcb0c088d7c81e96607ec3d6e61f80149d2f.tar.gz
qa-scripts-0750bcb0c088d7c81e96607ec3d6e61f80149d2f.tar.bz2
qa-scripts-0750bcb0c088d7c81e96607ec3d6e61f80149d2f.zip
Makefile.gpyutils: fix target, add instructions
... given I clearly keep getting it wrong. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'Makefile.gpyutils')
-rw-r--r--Makefile.gpyutils9
1 files changed, 7 insertions, 2 deletions
diff --git a/Makefile.gpyutils b/Makefile.gpyutils
index 906b7fa..d34f942 100644
--- a/Makefile.gpyutils
+++ b/Makefile.gpyutils
@@ -5,12 +5,17 @@ timestamp = $(PORTDIR)/metadata/timestamp.commit
# pass via make!
outdir = /dev/null
+# Adding new implementations:
+# 1. Add to upgr_all
+# 2. Later, when dot doesn't take too long for it, move to upgr_txt
+# 3. Once the impl is stable, move to upgr_base
+
# upgrades for stable impls
-upgr_base = $(outdir)/310-to-311.txt $(outdir)/311-to-312.txt
+upgr_base = $(outdir)/310-to-311.txt
# related stabilizations
upgr_streq = $(patsubst %.txt,%-stablereq.txt,$(upgr_base))
# all upgrade stuff
-upgr_txt = $(upgr_base) $(upgr_streq)
+upgr_txt = $(upgr_base) $(upgr_streq) $(outdir)/311-to-312.txt
upgr_dot = $(patsubst %.txt,%.dot,$(upgr_txt))
upgr_svg = $(patsubst %.dot,%.svg,$(upgr_dot))
# add new impls here if not stable yet, to avoid insanely huge generation times