aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-03-17 23:36:41 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-03-18 12:06:55 +0100
commit085ca84d81440d0d31296a0f99e8b72920099ac4 (patch)
tree45b1b229cee22f73054962cc18b0496b3b2016e2
parentdev-qt/qtgui: drop obsolete blockers, properly fixed by cmake patch (diff)
downloadqt-085ca84d81440d0d31296a0f99e8b72920099ac4.tar.gz
qt-085ca84d81440d0d31296a0f99e8b72920099ac4.tar.bz2
qt-085ca84d81440d0d31296a0f99e8b72920099ac4.zip
dev-qt/qtwayland: Drop USE libinput
USE -libinput is broken with dev-qt/qtgui[-libinput,X], would also need -X. Closes: https://bugs.gentoo.org/711476 Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-qt/qtwayland/qtwayland-5.14.9999.ebuild14
-rw-r--r--dev-qt/qtwayland/qtwayland-5.15.9999.ebuild14
2 files changed, 4 insertions, 24 deletions
diff --git a/dev-qt/qtwayland/qtwayland-5.14.9999.ebuild b/dev-qt/qtwayland/qtwayland-5.14.9999.ebuild
index 5fa75b67..474000fb 100644
--- a/dev-qt/qtwayland/qtwayland-5.14.9999.ebuild
+++ b/dev-qt/qtwayland/qtwayland-5.14.9999.ebuild
@@ -10,13 +10,13 @@ if [[ ${QT5_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
fi
-IUSE="+libinput vulkan xcomposite"
+IUSE="vulkan xcomposite"
DEPEND="
>=dev-libs/wayland-1.6.0
~dev-qt/qtcore-${PV}
~dev-qt/qtdeclarative-${PV}
- ~dev-qt/qtgui-${PV}[egl,libinput=,vulkan=]
+ ~dev-qt/qtgui-${PV}[egl,libinput,vulkan=]
media-libs/mesa[egl]
>=x11-libs/libxkbcommon-0.2.0
vulkan? ( dev-util/vulkan-headers )
@@ -28,16 +28,6 @@ DEPEND="
RDEPEND="${DEPEND}"
src_prepare() {
- qt_use_disable_config libinput xkbcommon \
- src/client/client.pro \
- src/compositor/wayland_wrapper/wayland_wrapper.pri \
- src/plugins/shellintegration/ivi-shell/ivi-shell.pro \
- src/plugins/shellintegration/wl-shell/wl-shell.pro \
- src/plugins/shellintegration/xdg-shell/xdg-shell.pro \
- src/plugins/shellintegration/xdg-shell-v5/xdg-shell-v5.pro \
- src/plugins/shellintegration/xdg-shell-v6/xdg-shell-v6.pro \
- tests/auto/compositor/compositor/compositor.pro
-
qt_use_disable_config vulkan wayland-vulkan-server-buffer \
src/plugins/hardwareintegration/client/client.pro \
src/plugins/hardwareintegration/compositor/compositor.pro
diff --git a/dev-qt/qtwayland/qtwayland-5.15.9999.ebuild b/dev-qt/qtwayland/qtwayland-5.15.9999.ebuild
index 0f7e93ca..52fb0bcb 100644
--- a/dev-qt/qtwayland/qtwayland-5.15.9999.ebuild
+++ b/dev-qt/qtwayland/qtwayland-5.15.9999.ebuild
@@ -10,13 +10,13 @@ if [[ ${QT5_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
fi
-IUSE="+libinput vulkan xcomposite"
+IUSE="vulkan xcomposite"
DEPEND="
>=dev-libs/wayland-1.6.0
~dev-qt/qtcore-${PV}
~dev-qt/qtdeclarative-${PV}
- ~dev-qt/qtgui-${PV}[egl,libinput=,vulkan=]
+ ~dev-qt/qtgui-${PV}[egl,libinput,vulkan=]
media-libs/mesa[egl]
>=x11-libs/libxkbcommon-0.2.0
vulkan? ( dev-util/vulkan-headers )
@@ -28,16 +28,6 @@ DEPEND="
RDEPEND="${DEPEND}"
src_prepare() {
- qt_use_disable_config libinput xkbcommon \
- src/client/client.pro \
- src/compositor/wayland_wrapper/wayland_wrapper.pri \
- src/plugins/shellintegration/ivi-shell/ivi-shell.pro \
- src/plugins/shellintegration/wl-shell/wl-shell.pro \
- src/plugins/shellintegration/xdg-shell/xdg-shell.pro \
- src/plugins/shellintegration/xdg-shell-v5/xdg-shell-v5.pro \
- src/plugins/shellintegration/xdg-shell-v6/xdg-shell-v6.pro \
- tests/auto/compositor/compositor/compositor.pro
-
qt_use_disable_config vulkan wayland-vulkan-server-buffer \
src/plugins/hardwareintegration/client/client.pro \
src/plugins/hardwareintegration/compositor/compositor.pro