aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-02-26 21:37:41 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-02-28 11:07:43 +0100
commit14ee15e92aa9df567c0e7245b4e83190fc7ebab7 (patch)
tree456fbb53b9c8153c0dd9e0013f6f86aeb21efab8
parentdev-qt/qtgui: Add USE vulkan (diff)
downloadqt-14ee15e92aa9df567c0e7245b4e83190fc7ebab7.tar.gz
qt-14ee15e92aa9df567c0e7245b4e83190fc7ebab7.tar.bz2
qt-14ee15e92aa9df567c0e7245b4e83190fc7ebab7.zip
dev-qt/qtwayland: Add USE vulkan
Closes: https://bugs.gentoo.org/703594 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-qt/qtwayland/metadata.xml1
-rw-r--r--dev-qt/qtwayland/qtwayland-5.14.9999.ebuild9
-rw-r--r--dev-qt/qtwayland/qtwayland-5.15.9999.ebuild9
3 files changed, 15 insertions, 4 deletions
diff --git a/dev-qt/qtwayland/metadata.xml b/dev-qt/qtwayland/metadata.xml
index 4fb03e67..db7a41ae 100644
--- a/dev-qt/qtwayland/metadata.xml
+++ b/dev-qt/qtwayland/metadata.xml
@@ -7,6 +7,7 @@
</maintainer>
<use>
<flag name="libinput">Enable support for input devices via <pkg>dev-libs/libinput</pkg></flag>
+ <flag name="vulkan">Enable support for Vulkan-based server buffer integration</flag>
</use>
<upstream>
<bugs-to>https://bugreports.qt.io/</bugs-to>
diff --git a/dev-qt/qtwayland/qtwayland-5.14.9999.ebuild b/dev-qt/qtwayland/qtwayland-5.14.9999.ebuild
index 0602db2f..5fa75b67 100644
--- a/dev-qt/qtwayland/qtwayland-5.14.9999.ebuild
+++ b/dev-qt/qtwayland/qtwayland-5.14.9999.ebuild
@@ -10,15 +10,16 @@ if [[ ${QT5_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
fi
-IUSE="+libinput xcomposite"
+IUSE="+libinput vulkan xcomposite"
DEPEND="
>=dev-libs/wayland-1.6.0
~dev-qt/qtcore-${PV}
~dev-qt/qtdeclarative-${PV}
- ~dev-qt/qtgui-${PV}[egl,libinput=]
+ ~dev-qt/qtgui-${PV}[egl,libinput=,vulkan=]
media-libs/mesa[egl]
>=x11-libs/libxkbcommon-0.2.0
+ vulkan? ( dev-util/vulkan-headers )
xcomposite? (
x11-libs/libX11
x11-libs/libXcomposite
@@ -37,6 +38,10 @@ src_prepare() {
src/plugins/shellintegration/xdg-shell-v6/xdg-shell-v6.pro \
tests/auto/compositor/compositor/compositor.pro
+ qt_use_disable_config vulkan wayland-vulkan-server-buffer \
+ src/plugins/hardwareintegration/client/client.pro \
+ src/plugins/hardwareintegration/compositor/compositor.pro
+
use xcomposite || rm -r config.tests/xcomposite || die
qt5-build_src_prepare
diff --git a/dev-qt/qtwayland/qtwayland-5.15.9999.ebuild b/dev-qt/qtwayland/qtwayland-5.15.9999.ebuild
index 5e2e0a8c..0f7e93ca 100644
--- a/dev-qt/qtwayland/qtwayland-5.15.9999.ebuild
+++ b/dev-qt/qtwayland/qtwayland-5.15.9999.ebuild
@@ -10,15 +10,16 @@ if [[ ${QT5_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
fi
-IUSE="+libinput xcomposite"
+IUSE="+libinput vulkan xcomposite"
DEPEND="
>=dev-libs/wayland-1.6.0
~dev-qt/qtcore-${PV}
~dev-qt/qtdeclarative-${PV}
- ~dev-qt/qtgui-${PV}[egl,libinput=]
+ ~dev-qt/qtgui-${PV}[egl,libinput=,vulkan=]
media-libs/mesa[egl]
>=x11-libs/libxkbcommon-0.2.0
+ vulkan? ( dev-util/vulkan-headers )
xcomposite? (
x11-libs/libX11
x11-libs/libXcomposite
@@ -37,5 +38,9 @@ src_prepare() {
src/plugins/shellintegration/xdg-shell-v6/xdg-shell-v6.pro \
tests/auto/compositor/compositor/compositor.pro
+ qt_use_disable_config vulkan wayland-vulkan-server-buffer \
+ src/plugins/hardwareintegration/client/client.pro \
+ src/plugins/hardwareintegration/compositor/compositor.pro
+
qt5-build_src_prepare
}