aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-11-22 10:03:11 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-12-27 02:32:25 +0100
commit3c8326395824d21435cec3a09b56b6c93fafce47 (patch)
treefbc4f0afb0c23f11092259f1957979d52b384cf7
parentqt5-build.eclass: Limit RDEPEND on qtchooser to Qt versions <5.15.2 (diff)
downloadqt-3c832639.tar.gz
qt-3c832639.tar.bz2
qt-3c832639.zip
dev-qt/qtchooser: Move config file install from qt5-build.eclass
Package-Manager: Portage-3.0.10, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-qt/qtchooser/qtchooser-9999.ebuild35
1 files changed, 28 insertions, 7 deletions
diff --git a/dev-qt/qtchooser/qtchooser-9999.ebuild b/dev-qt/qtchooser/qtchooser-9999.ebuild
index c15146a3..aacf7457 100644
--- a/dev-qt/qtchooser/qtchooser-9999.ebuild
+++ b/dev-qt/qtchooser/qtchooser-9999.ebuild
@@ -1,26 +1,33 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit qmake-utils toolchain-funcs git-r3
+inherit qmake-utils toolchain-funcs
DESCRIPTION="Tool to quickly switch between multiple Qt installations"
HOMEPAGE="https://code.qt.io/cgit/qtsdk/qtchooser.git/"
-EGIT_REPO_URI="https://code.qt.io/qtsdk/qtchooser.git"
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://code.qt.io/qtsdk/qtchooser.git"
+ inherit git-r3
+else
+ SRC_URI="http://download.qt.io/official_releases/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+fi
LICENSE="|| ( LGPL-2.1 GPL-3 )"
SLOT="0"
-KEYWORDS=""
IUSE="test"
-
RESTRICT="!test? ( test )"
DEPEND="test? (
dev-qt/qtcore:5
dev-qt/qttest:5
)"
-RDEPEND=""
+RDEPEND="
+ !<dev-qt/qtcore-5.15.2-r2:5
+"
qtchooser_make() {
emake \
@@ -45,7 +52,21 @@ src_test() {
src_install() {
qtchooser_make INSTALL_ROOT="${D}" install
- keepdir /etc/xdg/qtchooser
+ # install configuration file
+ cat > "${T}/qt5-${CHOST}.conf" <<-_EOF_ || die
+ $(qt5_get_bindir)
+ $(qt5_get_libdir)
+ _EOF_
+
+ (
+ insinto /etc/xdg/qtchooser
+ doins "${T}/qt5-${CHOST}.conf"
+ )
+
+ # convenience symlinks
+ dosym qt5-"${CHOST}".conf /etc/xdg/qtchooser/5.conf
+ dosym qt5-"${CHOST}".conf /etc/xdg/qtchooser/qt5.conf
+ dosym qt5.conf /etc/xdg/qtchooser/default.conf
# TODO: bash and zsh completion
# newbashcomp scripts/${PN}.bash ${PN}