aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-09-22 20:53:27 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-09-22 21:14:51 +0200
commit40e613e0db84c619958f9d4881d85d4fde952b6e (patch)
treedffcebf607dde478c4d9155a39077fd494da72d9
parentapp-arch/lxqt-archiver: Sync with Gentoo ebuild repo (diff)
downloadqt-40e613e0db84c619958f9d4881d85d4fde952b6e.tar.gz
qt-40e613e0db84c619958f9d4881d85d4fde952b6e.tar.bz2
qt-40e613e0db84c619958f9d4881d85d4fde952b6e.zip
dev-libs/libqtxdg: Sync with Gentoo ebuild repo
Package-Manager: Portage-3.0.23, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-libs/libqtxdg/libqtxdg-9999.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/dev-libs/libqtxdg/libqtxdg-9999.ebuild b/dev-libs/libqtxdg/libqtxdg-9999.ebuild
index 492cb837..b507de05 100644
--- a/dev-libs/libqtxdg/libqtxdg-9999.ebuild
+++ b/dev-libs/libqtxdg/libqtxdg-9999.ebuild
@@ -3,9 +3,9 @@
EAPI=7
-inherit cmake virtualx
+inherit cmake optfeature virtualx
-DESCRIPTION="A Qt implementation of XDG standards"
+DESCRIPTION="Qt implementation of XDG standards"
HOMEPAGE="https://lxqt.github.io/"
if [[ ${PV} == *9999 ]]; then
@@ -20,8 +20,10 @@ LICENSE="LGPL-2.1+ Nokia-Qt-LGPL-Exception-1.1"
SLOT="0"
IUSE="test"
+RESTRICT="!test? ( test )"
+
BDEPEND="
- >=dev-util/lxqt-build-tools-0.6.0
+ >=dev-util/lxqt-build-tools-0.9.0
virtual/pkgconfig
"
RDEPEND="
@@ -48,3 +50,7 @@ src_test() {
# Tests don't work with C
LC_ALL=en_US.utf8 virtx cmake_src_test
}
+
+pkg_postinst() {
+ ! has_version lxqt-base/lxqt-meta && optfeature "features that require a terminal emulator" x11-terms/xterm
+}