aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-06 17:14:26 +0100
committerSam James <sam@gentoo.org>2022-10-06 17:20:01 +0100
commit4e846acf550c7c510a2ccbd04f546c3baa225789 (patch)
tree9ed791e0b6e90595cea3bd712101f8a30d9d0451
parentdev-qt/*: add version 6.4.0 (diff)
downloadqt-4e846acf.tar.gz
qt-4e846acf.tar.bz2
qt-4e846acf.zip
dev-qt/qtwebengine: fix has_version default-libcxx test for Clang
We moved the flag to sys-devel/clang-common to prepare for proper config file support (which is backported to 15.0.2, although it's going to be better in 16.x). Go for the hack for now, but keep the bug open as we want to switch to the proper link test from the LLVM ebuilds. Bug: https://bugs.gentoo.org/875641 Bug: https://bugs.gentoo.org/875563 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-qt/qtwebengine/qtwebengine-5.15.6.9999.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-qt/qtwebengine/qtwebengine-5.15.6.9999.ebuild b/dev-qt/qtwebengine/qtwebengine-5.15.6.9999.ebuild
index d817b83e..6a89caec 100644
--- a/dev-qt/qtwebengine/qtwebengine-5.15.6.9999.ebuild
+++ b/dev-qt/qtwebengine/qtwebengine-5.15.6.9999.ebuild
@@ -199,8 +199,10 @@ src_prepare() {
fi
# src/3rdparty/gn fails with libc++ due to passing of `-static-libstdc++`
- if tc-is-clang && has_version 'sys-devel/clang[default-libcxx]'; then
- eapply "${FILESDIR}/${PN}-5.15.2_p20210521-clang-libc++.patch"
+ if tc-is-clang ; then
+ if has_version 'sys-devel/clang[default-libcxx(-)]' || has_version 'sys-devel/clang-common[default-libcxx(-)]' ; then
+ eapply "${FILESDIR}/${PN}-5.15.2_p20210521-clang-libc++.patch"
+ fi
fi
if use system-ffmpeg && has_version '>=media-video/ffmpeg-5'; then