aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2018-02-15 00:24:38 +1100
committerMichael Palimaka <kensington@gentoo.org>2018-02-15 00:26:37 +1100
commit5896d778d5f984ebb4ead74440020f84f4174b6d (patch)
tree8f7c2675b22e8fbe441a91472840b3f3a89ac382
parentdev-qt/qtcanvas3d: new package (diff)
downloadqt-5896d778.tar.gz
qt-5896d778.tar.bz2
qt-5896d778.zip
dev-qt/qtgamepad: add missing 5.9999
Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--dev-qt/qtgamepad/qtgamepad-5.9999.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-qt/qtgamepad/qtgamepad-5.9999.ebuild b/dev-qt/qtgamepad/qtgamepad-5.9999.ebuild
new file mode 100644
index 00000000..a7c4b576
--- /dev/null
+++ b/dev-qt/qtgamepad/qtgamepad-5.9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit qt5-build
+
+DESCRIPTION="Qt module to support gamepad hardware"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+IUSE="evdev qml sdl"
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtgui-${PV}[evdev?]
+ evdev? ( virtual/libudev:= )
+ sdl? ( media-libs/libsdl )
+ qml? ( ~dev-qt/qtdeclarative-${PV} )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ qt_use_disable_mod qml quick \
+ src/src.pro
+
+ qt_use_disable_config evdev evdev \
+ src/plugins/gamepads/gamepads.pro
+
+ qt_use_disable_config sdl sdl2 \
+ src/plugins/gamepads/gamepads.pro
+
+ qt5-build_src_prepare
+}