aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-02-05 20:55:12 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-02-05 21:52:56 +0100
commit5ec681f9ee0adb25951dcff4f1155f8853edb77d (patch)
treeef7c0d7aa7e8ba3d8a356306a57c6934ead021f6
parentapp-crypt/qca: app-doc/doxygen -> app-text/doxygen (diff)
downloadqt-5ec681f9ee0adb25951dcff4f1155f8853edb77d.tar.gz
qt-5ec681f9ee0adb25951dcff4f1155f8853edb77d.tar.bz2
qt-5ec681f9ee0adb25951dcff4f1155f8853edb77d.zip
dev-qt/qtwayland: Re-add IUSE=vulkan to 5.15.12
Bug: https://bugs.gentoo.org/923722 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-qt/qtwayland/metadata.xml1
-rw-r--r--dev-qt/qtwayland/qtwayland-5.15.12.9999.ebuild19
2 files changed, 11 insertions, 9 deletions
diff --git a/dev-qt/qtwayland/metadata.xml b/dev-qt/qtwayland/metadata.xml
index 9f58d4b4..835e5da0 100644
--- a/dev-qt/qtwayland/metadata.xml
+++ b/dev-qt/qtwayland/metadata.xml
@@ -7,6 +7,7 @@
</maintainer>
<use>
<flag name="compositor">Enable support for the wayland compositor / server APIs</flag>
+ <flag name="vulkan">Enable support for Vulkan-based server buffer integration</flag>
</use>
<upstream>
<bugs-to>https://bugreports.qt.io/</bugs-to>
diff --git a/dev-qt/qtwayland/qtwayland-5.15.12.9999.ebuild b/dev-qt/qtwayland/qtwayland-5.15.12.9999.ebuild
index 57fced44..c9d27b00 100644
--- a/dev-qt/qtwayland/qtwayland-5.15.12.9999.ebuild
+++ b/dev-qt/qtwayland/qtwayland-5.15.12.9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -13,21 +13,18 @@ inherit qt5-build
DESCRIPTION="Wayland platform plugin for Qt"
SLOT=5/${QT5_PV} # bug 815646
-IUSE="compositor"
+IUSE="compositor vulkan"
RDEPEND="
dev-libs/wayland
=dev-qt/qtcore-${QT5_PV}*:5=
- =dev-qt/qtgui-${QT5_PV}*:5=[egl,libinput]
+ =dev-qt/qtgui-${QT5_PV}*:5=[egl,libinput,vulkan=]
media-libs/libglvnd
x11-libs/libxkbcommon
- compositor? (
- =dev-qt/qtdeclarative-${QT5_PV}*:5=
- =dev-qt/qtgui-${QT5_PV}*:5=[vulkan]
- )
+ compositor? ( =dev-qt/qtdeclarative-${QT5_PV}*:5= )
"
DEPEND="${RDEPEND}
- compositor? ( dev-util/vulkan-headers )
+ vulkan? ( dev-util/vulkan-headers )
"
BDEPEND="dev-util/wayland-scanner"
@@ -40,8 +37,12 @@ src_configure() {
$(qt_use compositor feature-wayland-dmabuf-server-buffer)
$(qt_use compositor feature-wayland-drm-egl-server-buffer)
$(qt_use compositor feature-wayland-shm-emulation-server-buffer)
- $(qt_use compositor feature-wayland-vulkan-server-buffer)
)
+
+ use compositor && myqmakeargs+=(
+ $(qt_use vulkan feature-wayland-vulkan-server-buffer)
+ )
+
qt5-build_src_configure
}