aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-12-18 19:36:01 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-12-18 19:36:01 +0100
commit8044dd90e226c6cf7deddf540bd08b13dc55234a (patch)
treef45a48844048c2b0636f3240785b3c4c6099a24b
parentdev-qt/qtwebengine: switch USE="jumbo-build" default state (diff)
downloadqt-8044dd90e226c6cf7deddf540bd08b13dc55234a.tar.gz
qt-8044dd90e226c6cf7deddf540bd08b13dc55234a.tar.bz2
qt-8044dd90e226c6cf7deddf540bd08b13dc55234a.zip
dev-qt/qtwebengine: Fix nouveau-disable-gpu patch
Closes: https://bugs.gentoo.org/673398 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-qt/qtwebengine/files/qtwebengine-5.12.0-nouveau-disable-gpu.patch (renamed from dev-qt/qtwebengine/files/qtwebengine-5.11.1-nouveau-disable-gpu.patch)16
-rw-r--r--dev-qt/qtwebengine/qtwebengine-5.12.0.ebuild2
-rw-r--r--dev-qt/qtwebengine/qtwebengine-5.12.9999.ebuild2
3 files changed, 10 insertions, 10 deletions
diff --git a/dev-qt/qtwebengine/files/qtwebengine-5.11.1-nouveau-disable-gpu.patch b/dev-qt/qtwebengine/files/qtwebengine-5.12.0-nouveau-disable-gpu.patch
index aaf3aae4..ec315ca2 100644
--- a/dev-qt/qtwebengine/files/qtwebengine-5.11.1-nouveau-disable-gpu.patch
+++ b/dev-qt/qtwebengine/files/qtwebengine-5.12.0-nouveau-disable-gpu.patch
@@ -7,11 +7,11 @@ It also crashes when running on wayland, the cause is not yet known.
Work around these issues by not doing GPU-accelerated rendering in such
cases.
-Index: qtwebengine-everywhere-src-5.11.0/src/core/web_engine_context.cpp
+Index: qtwebengine-everywhere-src-5.12.0-alpha/src/core/web_engine_context.cpp
===================================================================
---- qtwebengine-everywhere-src-5.11.0.orig/src/core/web_engine_context.cpp
-+++ qtwebengine-everywhere-src-5.11.0/src/core/web_engine_context.cpp
-@@ -100,6 +100,7 @@
+--- qtwebengine-everywhere-src-5.12.0-alpha.orig/src/core/web_engine_context.cpp
++++ qtwebengine-everywhere-src-5.12.0-alpha/src/core/web_engine_context.cpp
+@@ -101,6 +101,7 @@
#include <QOffscreenSurface>
#ifndef QT_NO_OPENGL
# include <QOpenGLContext>
@@ -19,7 +19,7 @@ Index: qtwebengine-everywhere-src-5.11.0/src/core/web_engine_context.cpp
#endif
#include <QQuickWindow>
#include <QStringList>
-@@ -178,6 +179,39 @@ void dummyGetPluginCallback(const std::v
+@@ -162,6 +163,39 @@ void dummyGetPluginCallback(const std::v
}
#endif
@@ -59,13 +59,13 @@ Index: qtwebengine-everywhere-src-5.11.0/src/core/web_engine_context.cpp
} // namespace
namespace QtWebEngineCore {
-@@ -414,6 +448,27 @@ WebEngineContext::WebEngineContext()
+@@ -440,6 +474,27 @@ WebEngineContext::WebEngineContext()
const char *glType = 0;
#ifndef QT_NO_OPENGL
+ bool disableGpu = qEnvironmentVariableIsSet("QT_WEBENGINE_DISABLE_GPU");
+
-+ if (!qEnvironmentVariableIsSet("QT_WEBENGINE_DISABLE_WAYLAND_WORKAROUND") && platform.startsWith("wayland", Qt::CaseInsensitive))
++ if (!qEnvironmentVariableIsSet("QT_WEBENGINE_DISABLE_WAYLAND_WORKAROUND") && qApp->platformName().startsWith("wayland", Qt::CaseInsensitive))
+ {
+ qWarning() << "Running on wayland. Qt WebEngine will disable usage of the GPU.\n"
+ "Note: you can set the QT_WEBENGINE_DISABLE_WAYLAND_WORKAROUND\n"
@@ -87,7 +87,7 @@ Index: qtwebengine-everywhere-src-5.11.0/src/core/web_engine_context.cpp
bool tryGL =
!usingANGLE()
&& (!usingSoftwareDynamicGL()
-@@ -424,7 +479,7 @@ WebEngineContext::WebEngineContext()
+@@ -450,7 +505,7 @@ WebEngineContext::WebEngineContext()
|| enableWebGLSoftwareRendering
#endif
)
diff --git a/dev-qt/qtwebengine/qtwebengine-5.12.0.ebuild b/dev-qt/qtwebengine/qtwebengine-5.12.0.ebuild
index 3210a151..232f3195 100644
--- a/dev-qt/qtwebengine/qtwebengine-5.12.0.ebuild
+++ b/dev-qt/qtwebengine/qtwebengine-5.12.0.ebuild
@@ -81,7 +81,7 @@ DEPEND="${RDEPEND}
PATCHES+=(
"${FILESDIR}/${PN}-5.9.6-gcc8.patch" # bug 657124
- "${FILESDIR}/${PN}-5.11.1-nouveau-disable-gpu.patch" # bug 609752
+ "${FILESDIR}/${PN}-5.12.0-nouveau-disable-gpu.patch" # bug 609752
)
src_prepare() {
diff --git a/dev-qt/qtwebengine/qtwebengine-5.12.9999.ebuild b/dev-qt/qtwebengine/qtwebengine-5.12.9999.ebuild
index 3210a151..232f3195 100644
--- a/dev-qt/qtwebengine/qtwebengine-5.12.9999.ebuild
+++ b/dev-qt/qtwebengine/qtwebengine-5.12.9999.ebuild
@@ -81,7 +81,7 @@ DEPEND="${RDEPEND}
PATCHES+=(
"${FILESDIR}/${PN}-5.9.6-gcc8.patch" # bug 657124
- "${FILESDIR}/${PN}-5.11.1-nouveau-disable-gpu.patch" # bug 609752
+ "${FILESDIR}/${PN}-5.12.0-nouveau-disable-gpu.patch" # bug 609752
)
src_prepare() {