aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-10-29 02:34:23 +1100
committerMichael Palimaka <kensington@gentoo.org>2016-10-29 03:12:44 +1100
commit973bc57a485ec814e52f83476e88ea507661c1b0 (patch)
tree55b77d9640028688405a62358f435289afbba315
parentnet-misc/kontrolpack: requires qt4, dead upstream (diff)
downloadqt-973bc57a.tar.gz
qt-973bc57a.tar.bz2
qt-973bc57a.zip
net-libs/telepathy-qt: sync with kde
Package-Manager: portage-2.3.2
-rw-r--r--net-libs/telepathy-qt/telepathy-qt-9999.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/net-libs/telepathy-qt/telepathy-qt-9999.ebuild b/net-libs/telepathy-qt/telepathy-qt-9999.ebuild
index 6cc904c6..cdbb11a9 100644
--- a/net-libs/telepathy-qt/telepathy-qt-9999.ebuild
+++ b/net-libs/telepathy-qt/telepathy-qt-9999.ebuild
@@ -2,14 +2,14 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python2_7 )
-inherit python-any-r1 cmake-utils virtualx multibuild git-r3
+EGIT_REPO_URI=( "git://anongit.freedesktop.org/telepathy/${PN}" )
+inherit python-any-r1 cmake-utils virtualx git-r3 multibuild
DESCRIPTION="Qt bindings for the Telepathy D-Bus protocol"
HOMEPAGE="http://telepathy.freedesktop.org/"
-EGIT_REPO_URI=( "git://anongit.freedesktop.org/telepathy/${PN}" )
LICENSE="LGPL-2.1"
SLOT="0"
@@ -58,9 +58,9 @@ pkg_setup() {
src_configure() {
myconfigure() {
local mycmakeargs=(
- $(cmake-utils_use_enable debug DEBUG_OUTPUT)
- $(cmake-utils_use_enable farstream)
- $(cmake-utils_use_enable test TESTS)
+ -DENABLE_DEBUG_OUTPUT=$(usex debug)
+ -DENABLE_FARSTREAM=$(usex farstream)
+ -DENABLE_TESTS=$(usex test)
-DENABLE_EXAMPLES=OFF
-ENABLE_SERVICE_SUPPORT=ON
)