aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2024-04-21 20:21:20 +0300
committerJimi Huotari <chiitoo@gentoo.org>2024-04-21 22:49:28 +0300
commitb553321c500d470594b1cc44203f52d1b7d4c7ab (patch)
tree9ff6963a359c33de1377f063d95d5f34fa58c091
parentlxqt-base/lxqt-session: add 2.0.0 (diff)
downloadqt-b553321c500d470594b1cc44203f52d1b7d4c7ab.tar.gz
qt-b553321c500d470594b1cc44203f52d1b7d4c7ab.tar.bz2
qt-b553321c500d470594b1cc44203f52d1b7d4c7ab.zip
lxqt-base/lxqt-sudo: add 2.0.0
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
-rw-r--r--lxqt-base/lxqt-sudo/Manifest1
-rw-r--r--lxqt-base/lxqt-sudo/lxqt-sudo-2.0.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-sudo/Manifest b/lxqt-base/lxqt-sudo/Manifest
new file mode 100644
index 00000000..a031c296
--- /dev/null
+++ b/lxqt-base/lxqt-sudo/Manifest
@@ -0,0 +1 @@
+DIST lxqt-sudo-2.0.0.tar.xz 39164 BLAKE2B ab17745ced9d41fb63af7dc3646939578b79ba16a8f17739a2306114581f0c81517ad47430615fc043960638d25b062f38b4f1b1884247a8b5507723185383fc SHA512 8c79e782293f496c4e3a7d0bfbee06fb73fd682332b9bd4efa94b0ffd132e9980c64d4aa9d2719b805a7a209432595527231b9088e829b4638cc086c674f70a6
diff --git a/lxqt-base/lxqt-sudo/lxqt-sudo-2.0.0.ebuild b/lxqt-base/lxqt-sudo/lxqt-sudo-2.0.0.ebuild
new file mode 100644
index 00000000..b7bc5e0c
--- /dev/null
+++ b/lxqt-base/lxqt-sudo/lxqt-sudo-2.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="LXQt GUI frontend for sudo"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+
+BDEPEND=">=dev-util/lxqt-build-tools-2.0.0"
+DEPEND="
+ app-admin/sudo
+ >=dev-qt/qtbase-6.6:6[gui,widgets]
+ ~lxqt-base/liblxqt-${PV}:=
+"
+RDEPEND="${DEPEND}"