aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <davidepesa@gmail.com>2016-04-28 15:24:45 +0200
committerDavide Pesavento <davidepesa@gmail.com>2016-04-28 15:24:45 +0200
commitb77b1efe830cc9bfdd2c99bbd808afaab3cf2347 (patch)
treea23035b8954c93ecad8b18cf7bd73ad94204be27
parentqt5-build.eclass: stop passing -largefile to configure (diff)
parentwww-client/qupzilla: Update description. (diff)
downloadqt-b77b1efe.tar.gz
qt-b77b1efe.tar.bz2
qt-b77b1efe.zip
Merge pull request #123 from Chiitoo/qupzilla
www-client/qupzilla: Bump EAPI, description, and more.
-rw-r--r--www-client/qupzilla/files/qtsingleapplication-QDataStream.patch10
-rw-r--r--www-client/qupzilla/qupzilla-9999.ebuild13
2 files changed, 5 insertions, 18 deletions
diff --git a/www-client/qupzilla/files/qtsingleapplication-QDataStream.patch b/www-client/qupzilla/files/qtsingleapplication-QDataStream.patch
deleted file mode 100644
index 25694afc..00000000
--- a/www-client/qupzilla/files/qtsingleapplication-QDataStream.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/lib/3rdparty/qtsingleapplication/qtlocalpeer.cpp.ORIG 2015-05-07 18:29:35.045402873 +0200
-+++ src/lib/3rdparty/qtsingleapplication/qtlocalpeer.cpp 2015-05-07 18:33:04.942404927 +0200
-@@ -39,6 +39,7 @@
- ****************************************************************************/
-
-
-+#include <QDataStream>
- #include "qtlocalpeer.h"
- #include <QCoreApplication>
- #include <QTime>
diff --git a/www-client/qupzilla/qupzilla-9999.ebuild b/www-client/qupzilla/qupzilla-9999.ebuild
index 43e272e5..388d3085 100644
--- a/www-client/qupzilla/qupzilla-9999.ebuild
+++ b/www-client/qupzilla/qupzilla-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
MY_PN="QupZilla"
MY_P=${MY_PN}-${PV}
@@ -17,13 +17,13 @@ else
S=${WORKDIR}/${MY_P}
fi
-PLOCALES="ar_SA bg_BG ca_ES cs_CZ de_DE el_GR es_ES es_MX es_VE eu_ES fa_IR fi_FI fr_FR gl_ES he_IL hr_HR hu_HU id_ID it_IT ja_JP ka_GE lg lv_LV nl_NL nqo pl_PL pt_BR pt_PT ro_RO ru_RU sk_SK sr sr@ijekavian sr@ijekavianlatin sr@latin sv_SE tr_TR uk_UA uz@Latn zh_CN zh_TW"
+PLOCALES="ar_SA bg_BG ca_ES cs_CZ da_DK de_DE el_GR es_ES es_MX es_VE eu_ES fa_IR fi_FI fr_FR gl_ES he_IL hr_HR hu_HU id_ID it_IT ja_JP ka_GE lg lt lv_LV nl_NL nqo pl_PL pt_BR pt_PT ro_RO ru_RU sk_SK sr sr@ijekavian sr@ijekavianlatin sr@latin sv_SE tr_TR uk_UA uz@Latn zh_CN zh_TW"
PLUGINS_HASH='7b037cc326921cefbfc6b5e54e2091eb4191e73f'
PLUGINS_VERSION='2015.10.02' # if there are no updates, we can use the older archive
inherit eutils l10n multilib qmake-utils ${VCS_ECLASS}
-DESCRIPTION="Qt WebKit web browser"
+DESCRIPTION="A cross-platform web browser using Qt WebEngine"
HOMEPAGE="http://www.qupzilla.com/"
SRC_URI+="https://github.com/${MY_PN}/${PN}-plugins/archive/${PLUGINS_HASH}.tar.gz -> ${PN}-plugins-${PLUGINS_VERSION}.tar.gz"
@@ -65,11 +65,6 @@ src_prepare() {
rm translations/${1}.ts || die
}
- # patch bundled but changed QTSA for Qt-5.5, see bugs 548470 and 489142
- epatch "${FILESDIR}"/qtsingleapplication-QDataStream.patch
-
- epatch_user
-
# remove outdated prebuilt localizations
rm -rf bin/locale || die
@@ -81,6 +76,8 @@ src_prepare() {
l10n_find_plocales_changes "translations" "" ".ts"
l10n_for_each_disabled_locale_do rm_loc
+
+ default
}
src_configure() {