aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2017-05-04 16:14:27 +0200
committerDavide Pesavento <pesa@gentoo.org>2017-05-04 16:14:27 +0200
commitc4ab11d8c0f3469148e6d3db11633d459e8be7a5 (patch)
tree28336c496562adf429ff4ae98fb0a5991d051ba0
parentsets: update qt5-addons (diff)
downloadqt-c4ab11d8.tar.gz
qt-c4ab11d8.tar.bz2
qt-c4ab11d8.zip
dev-python/shiboken: simplify
Package-Manager: Portage-2.3.5, Repoman-2.3.2
-rw-r--r--dev-python/shiboken/shiboken-9999.ebuild16
1 files changed, 2 insertions, 14 deletions
diff --git a/dev-python/shiboken/shiboken-9999.ebuild b/dev-python/shiboken/shiboken-9999.ebuild
index a0b130fe..6eb6cdd8 100644
--- a/dev-python/shiboken/shiboken-9999.ebuild
+++ b/dev-python/shiboken/shiboken-9999.ebuild
@@ -26,7 +26,7 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
QT_PV="5.6*:5"
#FIXME: Add "sys-devel/clang:*" after switching to the "dev" branch.
-RDEPEND="
+DEPEND="
${PYTHON_DEPS}
dev-libs/libxml2
dev-libs/libxslt
@@ -34,12 +34,7 @@ RDEPEND="
=dev-qt/qtxml-${QT_PV}
=dev-qt/qtxmlpatterns-${QT_PV}
"
-DEPEND="${RDEPEND}
- test? (
- =dev-qt/qtgui-${QT_PV}
- =dev-qt/qttest-${QT_PV}
- )
-"
+RDEPEND="${DEPEND}"
DOCS=( AUTHORS )
@@ -60,15 +55,8 @@ src_configure() {
local mycmakeargs=(
-DBUILD_TESTS=$(usex test)
-DPYTHON_EXECUTABLE="${PYTHON}"
- -DPYTHON_SITE_PACKAGES="$(python_get_sitedir)"
)
- if [[ ${EPYTHON} == python3* ]]; then
- mycmakeargs+=(
- -DUSE_PYTHON_VERSION=3
- )
- fi
-
#FIXME: Uncomment after switching to the "dev" branch.
#FIXME: "CMakeLists.txt" currently requires that callers manually set
#this environment variable to the absolute path of the directory