aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-04-02 02:25:23 +1100
committerMichael Palimaka <kensington@gentoo.org>2016-04-02 02:25:51 +1100
commite9c83fdc1a992d599593e963f44ef44dccfa4090 (patch)
tree575cb35768de866ed932f4ecb8d13e92a6fa9912
parentmedia-video/prismatik: fails to build (diff)
downloadqt-e9c83fdc1a992d599593e963f44ef44dccfa4090.tar.gz
qt-e9c83fdc1a992d599593e963f44ef44dccfa4090.tar.bz2
qt-e9c83fdc1a992d599593e963f44ef44dccfa4090.zip
dev-qt/qtwebkit: manually run syncqt.pl to solve build failure
This is normally done by upstream before creating the release tarball, but they forgot. Gentoo-bug: 577574 Package-Manager: portage-2.2.28
-rw-r--r--dev-qt/qtwebkit/qtwebkit-5.6.0.ebuild5
-rw-r--r--dev-qt/qtwebkit/qtwebkit-5.7.0_alpha.ebuild5
2 files changed, 8 insertions, 2 deletions
diff --git a/dev-qt/qtwebkit/qtwebkit-5.6.0.ebuild b/dev-qt/qtwebkit/qtwebkit-5.6.0.ebuild
index 58876f11..a3a0f0fa 100644
--- a/dev-qt/qtwebkit/qtwebkit-5.6.0.ebuild
+++ b/dev-qt/qtwebkit/qtwebkit-5.6.0.ebuild
@@ -4,7 +4,7 @@
EAPI=6
PYTHON_COMPAT=( python2_7 )
-inherit python-any-r1 qt5-build
+inherit python-any-r1 qmake-utils qt5-build
DESCRIPTION="WebKit rendering library for the Qt5 framework (deprecated)"
SRC_URI="https://download.qt.io/community_releases/${PV%.*}/${PV}/${PN}-opensource-src-${PV}.tar.xz"
@@ -105,5 +105,8 @@ src_prepare() {
# bug 458222
sed -i -e '/SUBDIRS += examples/d' Source/QtWebKit.pro || die
+ # bug 577574
+ "$(qt5_get_bindir)"/syncqt.pl -version ${PV} Source/sync.profile
+
qt5-build_src_prepare
}
diff --git a/dev-qt/qtwebkit/qtwebkit-5.7.0_alpha.ebuild b/dev-qt/qtwebkit/qtwebkit-5.7.0_alpha.ebuild
index 6f84eba5..8a1ac2e8 100644
--- a/dev-qt/qtwebkit/qtwebkit-5.7.0_alpha.ebuild
+++ b/dev-qt/qtwebkit/qtwebkit-5.7.0_alpha.ebuild
@@ -4,7 +4,7 @@
EAPI=6
PYTHON_COMPAT=( python2_7 )
-inherit python-any-r1 qt5-build
+inherit python-any-r1 qmake-utils qt5-build
DESCRIPTION="WebKit rendering library for the Qt5 framework (deprecated)"
@@ -104,5 +104,8 @@ src_prepare() {
# bug 458222
sed -i -e '/SUBDIRS += examples/d' Source/QtWebKit.pro || die
+ # bug 577574
+ "$(qt5_get_bindir)"/syncqt.pl -version ${PV} Source/sync.profile
+
qt5-build_src_prepare
}