aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2022-03-09 21:07:48 +0200
committerJimi Huotari <chiitoo@gentoo.org>2022-03-09 21:07:48 +0200
commit62083d0d30f84b2b493451da73f9b2083d08993c (patch)
tree34f534eace93dde134bfb22270bc8c44dd85b325 /app-arch
parentmedia-gfx/lximage-qt: sync with the latest release ebuild (diff)
downloadqt-62083d0d30f84b2b493451da73f9b2083d08993c.tar.gz
qt-62083d0d30f84b2b493451da73f9b2083d08993c.tar.bz2
qt-62083d0d30f84b2b493451da73f9b2083d08993c.zip
app-arch/lxqt-archiver: sync with the latest release ebuild
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/lxqt-archiver/lxqt-archiver-9999.ebuild24
1 files changed, 14 insertions, 10 deletions
diff --git a/app-arch/lxqt-archiver/lxqt-archiver-9999.ebuild b/app-arch/lxqt-archiver/lxqt-archiver-9999.ebuild
index 1cec1b43..8cb639ee 100644
--- a/app-arch/lxqt-archiver/lxqt-archiver-9999.ebuild
+++ b/app-arch/lxqt-archiver/lxqt-archiver-9999.ebuild
@@ -1,12 +1,14 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+MY_PV="$(ver_cut 1-2)"
inherit cmake xdg-utils
DESCRIPTION="Qt GUI File Archiver"
-HOMEPAGE="https://lxqt.github.io/"
+HOMEPAGE="https://lxqt-project.org/"
if [[ ${PV} == *9999* ]]; then
inherit git-r3
@@ -20,21 +22,23 @@ LICENSE="GPL-2 GPL-2+"
SLOT="0"
BDEPEND="
- dev-qt/linguist-tools:5
- >=dev-util/lxqt-build-tools-0.9.0
+ >=dev-qt/linguist-tools-5.15:5
+ >=dev-util/lxqt-build-tools-0.10.0
"
DEPEND="
+ dev-libs/glib:2
dev-libs/json-glib
- dev-qt/qtcore:5
- dev-qt/qtgui:5
- dev-qt/qtwidgets:5
- dev-qt/qtx11extras:5
- >=x11-libs/libfm-qt-0.17.0
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtgui-5.15:5
+ >=dev-qt/qtwidgets-5.15:5
+ >=dev-qt/qtx11extras-5.15:5
+ >=x11-libs/libfm-qt-1:=
"
RDEPEND="${DEPEND}"
pkg_postinst() {
xdg_desktop_database_update
+ xdg_icon_cache_update
elog "Please note that this is only a graphical front-end, and additional"
elog "packages are needed to have support for specific file formats."