aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-31 17:39:50 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-31 17:39:58 +0100
commitd2c703851941eb94c809b43c51f0f0628ba84044 (patch)
tree543e6aba5c941eddf850ea7265852067b30184a8 /app-crypt
parentx11-misc/sddm: Switch to cmake.eclass (diff)
downloadqt-d2c703851941eb94c809b43c51f0f0628ba84044.tar.gz
qt-d2c703851941eb94c809b43c51f0f0628ba84044.tar.bz2
qt-d2c703851941eb94c809b43c51f0f0628ba84044.zip
app-crypt/qca: Switch to cmake.eclass and kde.org.eclass
Add missing RESTRICT="!test? ( test )" Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/qca/qca-9999.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/app-crypt/qca/qca-9999.ebuild b/app-crypt/qca/qca-9999.ebuild
index 3c88d034..be322031 100644
--- a/app-crypt/qca/qca-9999.ebuild
+++ b/app-crypt/qca/qca-9999.ebuild
@@ -3,11 +3,10 @@
EAPI=7
-inherit cmake-utils git-r3 qmake-utils
+inherit kde.org cmake git-r3 qmake-utils
DESCRIPTION="Qt Cryptographic Architecture (QCA)"
HOMEPAGE="https://userbase.kde.org/QCA"
-EGIT_REPO_URI="https://anongit.kde.org/${PN}.git"
LICENSE="LGPL-2.1"
SLOT="2"
@@ -15,6 +14,8 @@ KEYWORDS=""
IUSE="botan debug doc examples gcrypt gpg libressl logger nss pkcs11 sasl softstore +ssl test"
+RESTRICT="!test? ( test )"
+
BDEPEND="
doc? ( app-doc/doxygen )
"
@@ -63,16 +64,16 @@ src_configure() {
$(qca_plugin_use ssl ossl)
-DBUILD_TESTS=$(usex test)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_test() {
local -x QCA_PLUGIN_PATH="${BUILD_DIR}/lib/qca"
- cmake-utils_src_test
+ cmake_src_test
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
if use doc; then
pushd "${BUILD_DIR}" >/dev/null || die