aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <davidepesa@gmail.com>2013-10-23 16:28:13 +0200
committerDavide Pesavento <davidepesa@gmail.com>2013-10-23 16:28:13 +0200
commit5f9585d585720188883ffe0bd38d63b99528a9c2 (patch)
treec88c61001645010b0cba0b7913af898fe3bcfb15 /dev-python
parent[dev-qt/qt-creator] Sync with portage. (diff)
downloadqt-5f9585d585720188883ffe0bd38d63b99528a9c2.tar.gz
qt-5f9585d585720188883ffe0bd38d63b99528a9c2.tar.bz2
qt-5f9585d585720188883ffe0bd38d63b99528a9c2.zip
[sip,PyQt4] Sync with portage.
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/PyQt4/PyQt4-4.10.2_pre20130505.ebuild9
-rw-r--r--dev-python/sip/sip-4.15.2_pre20130825.ebuild4
2 files changed, 7 insertions, 6 deletions
diff --git a/dev-python/PyQt4/PyQt4-4.10.2_pre20130505.ebuild b/dev-python/PyQt4/PyQt4-4.10.2_pre20130505.ebuild
index 941291e5..cf572aaa 100644
--- a/dev-python/PyQt4/PyQt4-4.10.2_pre20130505.ebuild
+++ b/dev-python/PyQt4/PyQt4-4.10.2_pre20130505.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.10.3.ebuild,v 1.3 2013/09/19 11:23:03 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.10.3-r1.ebuild,v 1.1 2013/10/23 10:14:55 mgorny Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
@@ -42,7 +42,7 @@ QT_PV="4.8.0:4"
RDEPEND="
${PYTHON_DEPS}
- dev-python/python-exec:0[${PYTHON_USEDEP}]
+ dev-python/python-exec:2[${PYTHON_USEDEP}]
>=dev-python/sip-4.15.0:=[${PYTHON_USEDEP}]
>=dev-qt/qtcore-${QT_PV}
X? (
@@ -188,12 +188,13 @@ src_install() {
installation() {
# INSTALL_ROOT is used by designer/Makefile, other Makefiles use DESTDIR.
emake DESTDIR="${D}" INSTALL_ROOT="${D}" install
- mv "${ED}"/usr/bin/pyuic4{,-${EPYTHON}} || die
+ mkdir -p "${ED}"/usr/lib/python-exec/${EPYTHON} || die
+ mv "${ED}"/usr/bin/pyuic4 "${ED}"/usr/lib/python-exec/${EPYTHON}/ || die
python_optimize
}
python_foreach_impl run_in_build_dir installation
- dosym python-exec /usr/bin/pyuic4
+ dosym ../lib/python-exec/python-exec2 /usr/bin/pyuic4
dodoc NEWS THANKS
if use doc; then
diff --git a/dev-python/sip/sip-4.15.2_pre20130825.ebuild b/dev-python/sip/sip-4.15.2_pre20130825.ebuild
index 3dedd056..7a70860f 100644
--- a/dev-python/sip/sip-4.15.2_pre20130825.ebuild
+++ b/dev-python/sip/sip-4.15.2_pre20130825.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sip/sip-4.15.2.ebuild,v 1.2 2013/10/22 14:25:55 grobian Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
@@ -28,7 +28,7 @@ fi
# Sub-slot based on SIP_API_MAJOR_NR from siplib/sip.h.in
SLOT="0/10"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="debug doc"
DEPEND="${PYTHON_DEPS}"