aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2019-01-07 21:15:15 +0100
committerDavide Pesavento <pesa@gentoo.org>2019-01-07 21:15:15 +0100
commitffd4863f2536e76a6c855c7b6d82346299d4bd17 (patch)
tree5060634b3b964ec988bf452913dffad9ffbbb9c1 /dev-qt/qtcore
parentdev-qt/qtvirtualkeyboard: tweak DESCRIPTION (diff)
downloadqt-ffd4863f2536e76a6c855c7b6d82346299d4bd17.tar.gz
qt-ffd4863f2536e76a6c855c7b6d82346299d4bd17.tar.bz2
qt-ffd4863f2536e76a6c855c7b6d82346299d4bd17.zip
dev-qt/qtcore: sync with 5.11.3-r2 in gentoo.git
Package-Manager: Portage-2.3.53, Repoman-2.3.12 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Diffstat (limited to 'dev-qt/qtcore')
-rw-r--r--dev-qt/qtcore/qtcore-5.12.0.ebuild10
-rw-r--r--dev-qt/qtcore/qtcore-5.12.9999.ebuild10
-rw-r--r--dev-qt/qtcore/qtcore-5.9999.ebuild10
3 files changed, 27 insertions, 3 deletions
diff --git a/dev-qt/qtcore/qtcore-5.12.0.ebuild b/dev-qt/qtcore/qtcore-5.12.0.ebuild
index f6a45867..a77edf08 100644
--- a/dev-qt/qtcore/qtcore-5.12.0.ebuild
+++ b/dev-qt/qtcore/qtcore-5.12.0.ebuild
@@ -8,7 +8,7 @@ inherit qt5-build
DESCRIPTION="Cross-platform application development framework"
if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
fi
IUSE="icu systemd"
@@ -43,8 +43,16 @@ QT5_GENTOO_PRIVATE_CONFIG=(
!:xml
)
+src_prepare() {
+ # fix missing qt_version_tag symbol w/ LTO, bug 674382
+ sed -i -e 's/^gcc:ltcg/gcc/' src/corelib/global/global.pri || die
+
+ qt5-build_src_prepare
+}
+
src_configure() {
local myconf=(
+ -no-feature-statx # bug 672856
$(qt_use icu)
$(qt_use !icu iconv)
$(qt_use systemd journald)
diff --git a/dev-qt/qtcore/qtcore-5.12.9999.ebuild b/dev-qt/qtcore/qtcore-5.12.9999.ebuild
index f6a45867..a77edf08 100644
--- a/dev-qt/qtcore/qtcore-5.12.9999.ebuild
+++ b/dev-qt/qtcore/qtcore-5.12.9999.ebuild
@@ -8,7 +8,7 @@ inherit qt5-build
DESCRIPTION="Cross-platform application development framework"
if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
fi
IUSE="icu systemd"
@@ -43,8 +43,16 @@ QT5_GENTOO_PRIVATE_CONFIG=(
!:xml
)
+src_prepare() {
+ # fix missing qt_version_tag symbol w/ LTO, bug 674382
+ sed -i -e 's/^gcc:ltcg/gcc/' src/corelib/global/global.pri || die
+
+ qt5-build_src_prepare
+}
+
src_configure() {
local myconf=(
+ -no-feature-statx # bug 672856
$(qt_use icu)
$(qt_use !icu iconv)
$(qt_use systemd journald)
diff --git a/dev-qt/qtcore/qtcore-5.9999.ebuild b/dev-qt/qtcore/qtcore-5.9999.ebuild
index f6a45867..a77edf08 100644
--- a/dev-qt/qtcore/qtcore-5.9999.ebuild
+++ b/dev-qt/qtcore/qtcore-5.9999.ebuild
@@ -8,7 +8,7 @@ inherit qt5-build
DESCRIPTION="Cross-platform application development framework"
if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
fi
IUSE="icu systemd"
@@ -43,8 +43,16 @@ QT5_GENTOO_PRIVATE_CONFIG=(
!:xml
)
+src_prepare() {
+ # fix missing qt_version_tag symbol w/ LTO, bug 674382
+ sed -i -e 's/^gcc:ltcg/gcc/' src/corelib/global/global.pri || die
+
+ qt5-build_src_prepare
+}
+
src_configure() {
local myconf=(
+ -no-feature-statx # bug 672856
$(qt_use icu)
$(qt_use !icu iconv)
$(qt_use systemd journald)