aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2017-09-13 22:09:34 +1000
committerMichael Palimaka <kensington@gentoo.org>2017-09-13 22:11:57 +1000
commit3171e9dadc5ff17ca8568f525eb6fe1581787b68 (patch)
treec077434e6b5a2eddc07513027e5f19df854246dc /dev-qt/qtdeclarative
parentdev-qt/qtdeclarative: apply forgotten changes to 5.10.9999 (diff)
downloadqt-3171e9dadc5ff17ca8568f525eb6fe1581787b68.tar.gz
qt-3171e9dadc5ff17ca8568f525eb6fe1581787b68.tar.bz2
qt-3171e9dadc5ff17ca8568f525eb6fe1581787b68.zip
dev-qt/qtdeclarative: revert workaround
The workaround is actually not required beginning with 5.8. This reverts commit 4512a456df71b4e9efb59b9952cc74ea565d9a03. This reverts commit f743270fbbe4e084be0f1496cbbcc6cb2fcaed85.
Diffstat (limited to 'dev-qt/qtdeclarative')
-rw-r--r--dev-qt/qtdeclarative/qtdeclarative-5.10.9999.ebuild8
-rw-r--r--dev-qt/qtdeclarative/qtdeclarative-5.9.1.ebuild8
-rw-r--r--dev-qt/qtdeclarative/qtdeclarative-5.9.9999.ebuild8
-rw-r--r--dev-qt/qtdeclarative/qtdeclarative-5.9999.ebuild8
4 files changed, 4 insertions, 28 deletions
diff --git a/dev-qt/qtdeclarative/qtdeclarative-5.10.9999.ebuild b/dev-qt/qtdeclarative/qtdeclarative-5.10.9999.ebuild
index c6957999..23c47148 100644
--- a/dev-qt/qtdeclarative/qtdeclarative-5.10.9999.ebuild
+++ b/dev-qt/qtdeclarative/qtdeclarative-5.10.9999.ebuild
@@ -3,7 +3,7 @@
EAPI=6
PYTHON_COMPAT=( python2_7 python3_{4,5} )
-inherit flag-o-matic python-any-r1 qt5-build
+inherit python-any-r1 qt5-build
DESCRIPTION="The QML and Quick modules for the Qt5 framework"
@@ -34,12 +34,6 @@ RDEPEND="${COMMON_DEPEND}
"
src_prepare() {
- # this is supposed to be handled by the build system (src/qml/qml.pro),
- # fails because we override QMAKE_CXXFLAGS. bug 626070
- if tc-is-gcc && [[ $(gcc-major-version) -ge 6 ]]; then
- append-cxxflags -fno-delete-null-pointer-checks -fno-lifetime-dse
- fi
-
use jit || PATCHES+=("${FILESDIR}/${PN}-5.4.2-disable-jit.patch")
qt_use_disable_mod localstorage sql \
diff --git a/dev-qt/qtdeclarative/qtdeclarative-5.9.1.ebuild b/dev-qt/qtdeclarative/qtdeclarative-5.9.1.ebuild
index c6957999..23c47148 100644
--- a/dev-qt/qtdeclarative/qtdeclarative-5.9.1.ebuild
+++ b/dev-qt/qtdeclarative/qtdeclarative-5.9.1.ebuild
@@ -3,7 +3,7 @@
EAPI=6
PYTHON_COMPAT=( python2_7 python3_{4,5} )
-inherit flag-o-matic python-any-r1 qt5-build
+inherit python-any-r1 qt5-build
DESCRIPTION="The QML and Quick modules for the Qt5 framework"
@@ -34,12 +34,6 @@ RDEPEND="${COMMON_DEPEND}
"
src_prepare() {
- # this is supposed to be handled by the build system (src/qml/qml.pro),
- # fails because we override QMAKE_CXXFLAGS. bug 626070
- if tc-is-gcc && [[ $(gcc-major-version) -ge 6 ]]; then
- append-cxxflags -fno-delete-null-pointer-checks -fno-lifetime-dse
- fi
-
use jit || PATCHES+=("${FILESDIR}/${PN}-5.4.2-disable-jit.patch")
qt_use_disable_mod localstorage sql \
diff --git a/dev-qt/qtdeclarative/qtdeclarative-5.9.9999.ebuild b/dev-qt/qtdeclarative/qtdeclarative-5.9.9999.ebuild
index c6957999..23c47148 100644
--- a/dev-qt/qtdeclarative/qtdeclarative-5.9.9999.ebuild
+++ b/dev-qt/qtdeclarative/qtdeclarative-5.9.9999.ebuild
@@ -3,7 +3,7 @@
EAPI=6
PYTHON_COMPAT=( python2_7 python3_{4,5} )
-inherit flag-o-matic python-any-r1 qt5-build
+inherit python-any-r1 qt5-build
DESCRIPTION="The QML and Quick modules for the Qt5 framework"
@@ -34,12 +34,6 @@ RDEPEND="${COMMON_DEPEND}
"
src_prepare() {
- # this is supposed to be handled by the build system (src/qml/qml.pro),
- # fails because we override QMAKE_CXXFLAGS. bug 626070
- if tc-is-gcc && [[ $(gcc-major-version) -ge 6 ]]; then
- append-cxxflags -fno-delete-null-pointer-checks -fno-lifetime-dse
- fi
-
use jit || PATCHES+=("${FILESDIR}/${PN}-5.4.2-disable-jit.patch")
qt_use_disable_mod localstorage sql \
diff --git a/dev-qt/qtdeclarative/qtdeclarative-5.9999.ebuild b/dev-qt/qtdeclarative/qtdeclarative-5.9999.ebuild
index c6957999..23c47148 100644
--- a/dev-qt/qtdeclarative/qtdeclarative-5.9999.ebuild
+++ b/dev-qt/qtdeclarative/qtdeclarative-5.9999.ebuild
@@ -3,7 +3,7 @@
EAPI=6
PYTHON_COMPAT=( python2_7 python3_{4,5} )
-inherit flag-o-matic python-any-r1 qt5-build
+inherit python-any-r1 qt5-build
DESCRIPTION="The QML and Quick modules for the Qt5 framework"
@@ -34,12 +34,6 @@ RDEPEND="${COMMON_DEPEND}
"
src_prepare() {
- # this is supposed to be handled by the build system (src/qml/qml.pro),
- # fails because we override QMAKE_CXXFLAGS. bug 626070
- if tc-is-gcc && [[ $(gcc-major-version) -ge 6 ]]; then
- append-cxxflags -fno-delete-null-pointer-checks -fno-lifetime-dse
- fi
-
use jit || PATCHES+=("${FILESDIR}/${PN}-5.4.2-disable-jit.patch")
qt_use_disable_mod localstorage sql \