aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2019-01-30 00:54:33 +0200
committerJimi Huotari <chiitoo@gentoo.org>2019-01-30 00:54:48 +0200
commitc85571101047ca5a01d2775bf4e8b2c4418b3099 (patch)
treed993cd49ac785185561140856f05945674ccc8d0 /dev-qt/qthelp/qthelp-5.13.9999.ebuild
parentlxqt-base: bump required versions on dependencies (diff)
downloadqt-c85571101047ca5a01d2775bf4e8b2c4418b3099.tar.gz
qt-c85571101047ca5a01d2775bf4e8b2c4418b3099.tar.bz2
qt-c85571101047ca5a01d2775bf4e8b2c4418b3099.zip
dev-qt: add 5.13.9999
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'dev-qt/qthelp/qthelp-5.13.9999.ebuild')
-rw-r--r--dev-qt/qthelp/qthelp-5.13.9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-qt/qthelp/qthelp-5.13.9999.ebuild b/dev-qt/qthelp/qthelp-5.13.9999.ebuild
new file mode 100644
index 00000000..01861748
--- /dev/null
+++ b/dev-qt/qthelp/qthelp-5.13.9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+QT5_MODULE="qttools"
+inherit qt5-build
+
+DESCRIPTION="Qt5 module for integrating online documentation into applications"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+fi
+
+IUSE=""
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtgui-${PV}
+ ~dev-qt/qtnetwork-${PV}
+ ~dev-qt/qtsql-${PV}[sqlite]
+ ~dev-qt/qtwidgets-${PV}
+"
+RDEPEND="${DEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/assistant/help
+ src/assistant/qhelpgenerator
+)