aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-05 21:35:03 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-05 21:35:03 +0100
commit432d597c23e5d60a5da351f906955672ff233819 (patch)
tree1f2cea0dc40a7f4b99c0eea3dca0a3b1a4087cc8 /dev-qt/qtopengl/qtopengl-5.12.1.ebuild
parentdev-qt/qtwebengine: fix build with USE="system-icu" (diff)
downloadqt-432d597c23e5d60a5da351f906955672ff233819.tar.gz
qt-432d597c23e5d60a5da351f906955672ff233819.tar.bz2
qt-432d597c23e5d60a5da351f906955672ff233819.zip
dev-qt: Add Qt 5.12.1
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-qt/qtopengl/qtopengl-5.12.1.ebuild')
-rw-r--r--dev-qt/qtopengl/qtopengl-5.12.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-qt/qtopengl/qtopengl-5.12.1.ebuild b/dev-qt/qtopengl/qtopengl-5.12.1.ebuild
new file mode 100644
index 00000000..c1ee20ac
--- /dev/null
+++ b/dev-qt/qtopengl/qtopengl-5.12.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+QT5_MODULE="qtbase"
+VIRTUALX_REQUIRED="test"
+inherit qt5-build
+
+DESCRIPTION="OpenGL support library for the Qt5 framework (deprecated)"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+fi
+
+IUSE="gles2"
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtgui-${PV}[gles2=]
+ ~dev-qt/qtwidgets-${PV}[gles2=]
+ virtual/opengl
+"
+RDEPEND="${DEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/opengl
+)
+
+src_configure() {
+ local myconf=(
+ -opengl $(usex gles2 es2 desktop)
+ )
+ qt5-build_src_configure
+}