aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2018-01-26 11:32:44 +0200
committerJimi Huotari <chiitoo@gentoo.org>2018-01-26 11:32:44 +0200
commit1aab573c609dfe41d406542c1e23df26873b5e08 (patch)
tree3d20360feed97c4df57407b437d72d553a45e46f /dev-qt/qtopengl
parentqt5-build.eclass: relax qconfig-qtcore.pri insertion to all 5.9 and later (diff)
downloadqt-1aab573c609dfe41d406542c1e23df26873b5e08.tar.gz
qt-1aab573c609dfe41d406542c1e23df26873b5e08.tar.bz2
qt-1aab573c609dfe41d406542c1e23df26873b5e08.zip
dev-qt: add 5.11.9999
Package-Manager: Portage-2.3.20, Repoman-2.3.6
Diffstat (limited to 'dev-qt/qtopengl')
-rw-r--r--dev-qt/qtopengl/qtopengl-5.11.9999.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-qt/qtopengl/qtopengl-5.11.9999.ebuild b/dev-qt/qtopengl/qtopengl-5.11.9999.ebuild
new file mode 100644
index 00000000..be8a1bf7
--- /dev/null
+++ b/dev-qt/qtopengl/qtopengl-5.11.9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+QT5_MODULE="qtbase"
+VIRTUALX_REQUIRED="test"
+inherit qt5-build
+
+DESCRIPTION="OpenGL support library for the Qt5 framework (deprecated)"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+fi
+
+IUSE="gles2"
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtgui-${PV}[gles2=]
+ ~dev-qt/qtwidgets-${PV}[gles2=]
+ virtual/opengl
+"
+RDEPEND="${DEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/opengl
+)
+
+src_configure() {
+ local myconf=(
+ -opengl $(usex gles2 es2 desktop)
+ )
+ qt5-build_src_configure
+}