aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-11-13 22:20:35 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-11-13 23:44:20 +0100
commitea20e7419bd1212625ae9f0a489ad61cb37f0c70 (patch)
treebef8e7781f587358428e9be419b14f01b1561727 /dev-qt/qtscript
parentprofiles: Mask Qt 5.12.0_beta4 (diff)
downloadqt-ea20e7419bd1212625ae9f0a489ad61cb37f0c70.tar.gz
qt-ea20e7419bd1212625ae9f0a489ad61cb37f0c70.tar.bz2
qt-ea20e7419bd1212625ae9f0a489ad61cb37f0c70.zip
dev-qt: Add Qt 5.12.0_beta4
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtscript')
-rw-r--r--dev-qt/qtscript/Manifest1
-rw-r--r--dev-qt/qtscript/qtscript-5.12.0_beta4.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-qt/qtscript/Manifest b/dev-qt/qtscript/Manifest
new file mode 100644
index 00000000..f43def67
--- /dev/null
+++ b/dev-qt/qtscript/Manifest
@@ -0,0 +1 @@
+DIST qtscript-everywhere-src-5.12.0-beta4.tar.xz 2667232 BLAKE2B adeb8851626cc112d7f4309ff20cf9140a1fdb761bf3d6874db513567f27e7669e60317ce2a5d4212be6ef484d524b290a2c39818e395fef545474a210e3e41b SHA512 b35934f295dab19dbf86fe1f85c5639977741e43a4ca959c27670f05194fd9a3afc33e156c6e23e463cf81c5d73a9159c98440e7deb7ed8a8acb86a0b7283c8c
diff --git a/dev-qt/qtscript/qtscript-5.12.0_beta4.ebuild b/dev-qt/qtscript/qtscript-5.12.0_beta4.ebuild
new file mode 100644
index 00000000..70066980
--- /dev/null
+++ b/dev-qt/qtscript/qtscript-5.12.0_beta4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit qt5-build
+
+DESCRIPTION="Application scripting library for the Qt5 framework (deprecated)"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd"
+fi
+
+IUSE="+jit scripttools"
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}
+ scripttools? (
+ ~dev-qt/qtgui-${PV}
+ ~dev-qt/qtwidgets-${PV}
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ qt_use_disable_mod scripttools widgets \
+ src/src.pro
+
+ qt5-build_src_prepare
+}
+
+src_configure() {
+ local myqmakeargs=(
+ JAVASCRIPTCORE_JIT=$(usex jit 'yes' 'no')
+ )
+ qt5-build_src_configure
+}