aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-03-16 23:26:42 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-03-16 23:33:55 +0100
commit3349fcb0657678d47b3266ae11042af44a1cfce7 (patch)
tree6642cf3eb6a6d857c1a52c7f081b9f15792208cb /dev-qt/qtsql
parentdev-qt/qtxmlpatterns: Add USE qml (diff)
downloadqt-3349fcb0657678d47b3266ae11042af44a1cfce7.tar.gz
qt-3349fcb0657678d47b3266ae11042af44a1cfce7.tar.bz2
qt-3349fcb0657678d47b3266ae11042af44a1cfce7.zip
dev-qt: Add Qt 5.12.2
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtsql')
-rw-r--r--dev-qt/qtsql/Manifest1
-rw-r--r--dev-qt/qtsql/qtsql-5.12.2.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-qt/qtsql/Manifest b/dev-qt/qtsql/Manifest
new file mode 100644
index 00000000..9f36a4b8
--- /dev/null
+++ b/dev-qt/qtsql/Manifest
@@ -0,0 +1 @@
+DIST qtbase-everywhere-src-5.12.2.tar.xz 48364464 BLAKE2B 1743fc3e233ab5c204c4c88db61ede946fbb967ed69c47709ee071bf1b911ef79a6581ff9db6e6bdabb15202196614fbdce32521750e41898906100ae5259960 SHA512 6752ecc096f8baf8e14e56f0d1f139e8a0d75967ab61bf1734ad5f4f4609a7cc707ab080f5f85f2230bbbb1454a0669be60a14d57d9a93aef553ce6f85f71613
diff --git a/dev-qt/qtsql/qtsql-5.12.2.ebuild b/dev-qt/qtsql/qtsql-5.12.2.ebuild
new file mode 100644
index 00000000..92ce286d
--- /dev/null
+++ b/dev-qt/qtsql/qtsql-5.12.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+QT5_MODULE="qtbase"
+inherit qt5-build
+
+DESCRIPTION="SQL abstraction library for the Qt5 framework"
+SLOT=5/$(ver_cut 1-3) # bug 639140
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+fi
+
+IUSE="freetds mysql oci8 odbc postgres +sqlite"
+
+REQUIRED_USE="
+ || ( freetds mysql oci8 odbc postgres sqlite )
+"
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}
+ freetds? ( dev-db/freetds )
+ mysql? ( dev-db/mysql-connector-c:= )
+ oci8? ( dev-db/oracle-instantclient:=[sdk] )
+ odbc? ( dev-db/unixODBC )
+ postgres? ( dev-db/postgresql:* )
+ sqlite? ( dev-db/sqlite:3 )
+"
+RDEPEND="${DEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/sql
+ src/plugins/sqldrivers
+)
+
+QT5_GENTOO_PRIVATE_CONFIG=(
+ :sql
+)
+
+src_configure() {
+ local myconf=(
+ $(qt_use freetds sql-tds plugin)
+ $(qt_use mysql sql-mysql plugin)
+ $(qt_use oci8 sql-oci plugin)
+ $(qt_use odbc sql-odbc plugin)
+ $(qt_use postgres sql-psql plugin)
+ $(qt_use sqlite sql-sqlite plugin)
+ $(usex sqlite -system-sqlite '')
+ )
+
+ use oci8 && myconf+=("-I${ORACLE_HOME}/include" "-L${ORACLE_HOME}/$(get_libdir)")
+
+ qt5-build_src_configure
+}