aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2017-12-10 00:51:25 +0200
committerJimi Huotari <chiitoo@gentoo.org>2017-12-10 01:04:10 +0200
commit045231f9f1e5ded0c225d4f8a8df4d9c0f5d6147 (patch)
tree18852d9498c8e1d1d3841b3f098554463d75d9ac /dev-qt/qtwayland
parentdev-qt/qtwebengine: remove unneeded patch (diff)
downloadqt-045231f9f1e5ded0c225d4f8a8df4d9c0f5d6147.tar.gz
qt-045231f9f1e5ded0c225d4f8a8df4d9c0f5d6147.tar.bz2
qt-045231f9f1e5ded0c225d4f8a8df4d9c0f5d6147.zip
dev-qt: add 5.10.0
Package-Manager: Portage-2.3.17, Repoman-2.3.6
Diffstat (limited to 'dev-qt/qtwayland')
-rw-r--r--dev-qt/qtwayland/Manifest1
-rw-r--r--dev-qt/qtwayland/qtwayland-5.10.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-qt/qtwayland/Manifest b/dev-qt/qtwayland/Manifest
new file mode 100644
index 00000000..df231bb9
--- /dev/null
+++ b/dev-qt/qtwayland/Manifest
@@ -0,0 +1 @@
+DIST qtwayland-everywhere-src-5.10.0.tar.xz 378276 BLAKE2B a1edb8c841add008d2d63edb14b1e4f2fd488a218a693d31c0e311b0cbc06ff7af5cec05c8449df34b52532cb5f1d6a3869465784bae11f09c8bf76babc5de1c SHA512 56c97f437fe01bf975cea06aaaeebe62053e8fc3d3d8227a0c9a7582c4cadf801d3806df349887fff513a60c5ffee302777010bc342b22a0fc0170ea7138e821
diff --git a/dev-qt/qtwayland/qtwayland-5.10.0.ebuild b/dev-qt/qtwayland/qtwayland-5.10.0.ebuild
new file mode 100644
index 00000000..0629d749
--- /dev/null
+++ b/dev-qt/qtwayland/qtwayland-5.10.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit qt5-build
+
+DESCRIPTION="Wayland platform plugin for Qt"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+fi
+
+IUSE="+libinput xcomposite"
+
+DEPEND="
+ >=dev-libs/wayland-1.6.0
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtdeclarative-${PV}
+ ~dev-qt/qtgui-${PV}[egl,libinput?]
+ media-libs/mesa[egl]
+ >=x11-libs/libxkbcommon-0.2.0
+ xcomposite? (
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ qt_use_disable_config libinput xkbcommon-evdev \
+ src/client/client.pro \
+ src/compositor/wayland_wrapper/wayland_wrapper.pri \
+ src/plugins/shellintegration/ivi-shell/ivi-shell.pro \
+ tests/auto/compositor/compositor/compositor.pro
+
+ use xcomposite || rm -r config.tests/xcomposite || die
+
+ qt5-build_src_prepare
+}