aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-11-22 20:49:26 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-11-22 20:49:32 +0100
commitd58c9e3e71cb7fc0a6ca96b41f1762efc133bf57 (patch)
treee4c93b2736d029fc7c2b237d9832f905f00e922e /dev-qt/qtwayland
parentdev-qt/qtxmlpatterns: Block <dev-qt/qtdeclarative-5.12.0_beta4:5 (diff)
downloadqt-d58c9e3e71cb7fc0a6ca96b41f1762efc133bf57.tar.gz
qt-d58c9e3e71cb7fc0a6ca96b41f1762efc133bf57.tar.bz2
qt-d58c9e3e71cb7fc0a6ca96b41f1762efc133bf57.zip
dev-qt: Add Qt 5.12.0 RC
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtwayland')
-rw-r--r--dev-qt/qtwayland/Manifest1
-rw-r--r--dev-qt/qtwayland/qtwayland-5.12.0_rc.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-qt/qtwayland/Manifest b/dev-qt/qtwayland/Manifest
index ef9d9fa8..f9aac3c7 100644
--- a/dev-qt/qtwayland/Manifest
+++ b/dev-qt/qtwayland/Manifest
@@ -1 +1,2 @@
DIST qtwayland-everywhere-src-5.12.0-beta4.tar.xz 424728 BLAKE2B 399c9cf542ccee082b6388c85dd7d94aea63bda2f629d390c2098d644916bb5d43844e625fdac06264f3bfbcd1523b21a7c13ce8e132bab8f9df98798b9479ec SHA512 00d11fd00bd5d002bd5151efd64ccef0317b994d4b593b8e5a1cea4e9d46ba0da950bfdb46dadd6b3baf4d83797ef315883178d0eb4b4c4f2cf99ccfad5f6327
+DIST qtwayland-everywhere-src-5.12.0-rc.tar.xz 424592 BLAKE2B d97279ffa65670fc4e8f4fb7dd9db97abce6e208ccfcf79b2e4126869ce4f6d5c7419e4cf5a71e45a4a98205c9e6a80a437a89a69296237cc819ada48fccd128 SHA512 5a251ded0e1383dace85f75434646e6878320442be3505cc6ad83099270e20c8dc56193f8ea2e91f366b822518bc817869cee038e582a5e07067b54194422022
diff --git a/dev-qt/qtwayland/qtwayland-5.12.0_rc.ebuild b/dev-qt/qtwayland/qtwayland-5.12.0_rc.ebuild
new file mode 100644
index 00000000..ff62f71d
--- /dev/null
+++ b/dev-qt/qtwayland/qtwayland-5.12.0_rc.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit qt5-build
+
+DESCRIPTION="Wayland platform plugin for Qt"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+fi
+
+IUSE="+libinput xcomposite"
+
+DEPEND="
+ >=dev-libs/wayland-1.6.0
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtdeclarative-${PV}
+ ~dev-qt/qtgui-${PV}[egl,libinput?]
+ media-libs/mesa[egl]
+ >=x11-libs/libxkbcommon-0.2.0
+ xcomposite? (
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ qt_use_disable_config libinput xkbcommon-evdev \
+ src/client/client.pro \
+ src/compositor/wayland_wrapper/wayland_wrapper.pri \
+ src/plugins/shellintegration/ivi-shell/ivi-shell.pro \
+ tests/auto/compositor/compositor/compositor.pro
+
+ use xcomposite || rm -r config.tests/xcomposite || die
+
+ qt5-build_src_prepare
+}