aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-12-06 14:05:14 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-12-06 14:31:22 +0100
commit986677551662bdb1d2bb287a7a311021071b626d (patch)
treed83d3d82b621d6ea0387007055b56d8f1b97bffa /dev-qt/qtxml
parentdev-qt/qtdeclarative: add python3_7 (diff)
downloadqt-986677551662bdb1d2bb287a7a311021071b626d.tar.gz
qt-986677551662bdb1d2bb287a7a311021071b626d.tar.bz2
qt-986677551662bdb1d2bb287a7a311021071b626d.zip
dev-qt: Add Qt 5.12.0
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtxml')
-rw-r--r--dev-qt/qtxml/Manifest1
-rw-r--r--dev-qt/qtxml/qtxml-5.12.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-qt/qtxml/Manifest b/dev-qt/qtxml/Manifest
index e5f9ec23..6e603bf0 100644
--- a/dev-qt/qtxml/Manifest
+++ b/dev-qt/qtxml/Manifest
@@ -1 +1,2 @@
DIST qtbase-everywhere-src-5.12.0-rc.tar.xz 48286368 BLAKE2B 7c67515e17c27ca10a78a94965d1d8b46deee4035de9dcbfda23dddb2cea95d8ea698d7f7cc4fc71265bdbd861a09423cf59a214fa65253b29b9a1f04898aa34 SHA512 f144f1d7e134b43131743a010ef652e6e19ed99a8af167d7c98d81ed07ad40fd9968fda2182e018b475201060c1fa890ca9eedc7c903e06c102e3cb6834db90f
+DIST qtbase-everywhere-src-5.12.0.tar.xz 48288896 BLAKE2B cd7c3e6c7470cde27db3866b97579a851f60e82243bbba1bbaa4bea53943a3c695ab7a7015dfa86e0bf5653646c0bc6ad48ba186191af8f39400fac24f125feb SHA512 8e6c51b754840d17e694b5b4a0d732afe04ebe48d166bca429db01ce3ac9014bb0ed35fe99ad165973889d96919f6b6774429585bae9a7fdba6b07f4c1eb3570
diff --git a/dev-qt/qtxml/qtxml-5.12.0.ebuild b/dev-qt/qtxml/qtxml-5.12.0.ebuild
new file mode 100644
index 00000000..04e56a6a
--- /dev/null
+++ b/dev-qt/qtxml/qtxml-5.12.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+QT5_MODULE="qtbase"
+inherit qt5-build
+
+DESCRIPTION="Implementation of SAX and DOM for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd"
+fi
+
+IUSE=""
+
+RDEPEND="
+ ~dev-qt/qtcore-${PV}
+"
+DEPEND="${RDEPEND}
+ test? ( ~dev-qt/qtnetwork-${PV} )
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/xml
+)
+
+QT5_GENTOO_PRIVATE_CONFIG=(
+ :xml
+)