aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2017-06-02 00:02:47 +1000
committerMichael Palimaka <kensington@gentoo.org>2017-06-02 00:03:54 +1000
commitb896b780a85d9283b85c475e9677021395304255 (patch)
tree992e38bf44f911e851c7551a6296c1cd8f18fc32 /dev-qt/qtxml
parentdev-qt: bump to 5.9.0_rc (diff)
downloadqt-b896b780a85d9283b85c475e9677021395304255.tar.gz
qt-b896b780a85d9283b85c475e9677021395304255.tar.bz2
qt-b896b780a85d9283b85c475e9677021395304255.zip
dev-qt: version bump 5.9.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-qt/qtxml')
-rw-r--r--dev-qt/qtxml/Manifest1
-rw-r--r--dev-qt/qtxml/qtxml-5.9.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-qt/qtxml/Manifest b/dev-qt/qtxml/Manifest
index 95fe3176..e11ecca7 100644
--- a/dev-qt/qtxml/Manifest
+++ b/dev-qt/qtxml/Manifest
@@ -1 +1,2 @@
DIST qtbase-opensource-src-5.9.0-rc.tar.xz 44902708 SHA256 da1be310a4a7a0526174c4fde5702fc5b4043f05e1dd425da64d6f2c23bbcbfc SHA512 e3dbe38b109dcd4e96d27cc159a5a4df8c6474db43771b58a62a7242dbf4185fa3e89cc64a6524bf87bf698abed129e50cf3dcf5f110c8d78535dd735a8d99a1 WHIRLPOOL c126f8d70ab2254a2f37957d5aafba7c63353dd02b1ae47504de65844cce10c71115405c4aac347ff0b279caefb2879f9800511a7288b4cd59b6e0c4d79b527e
+DIST qtbase-opensource-src-5.9.0.tar.xz 44893232 SHA256 267eb2af1a203c087f2113f43b08014d0e2d2cb269295b8602d869a2fad5296c SHA512 15b921c26dbedc7c339a5e1a235255a18b66fa53ac8af6f2d1ad64d939f1fee9817c8f115eac9a417ed0d2f832fb895b29acc61e393c97415447a067ea031be7 WHIRLPOOL 6cf9ffeb0ac3247a071cc0bd77e520175c643f46c385d7572e59e480853465817a56cbd9a744393cb3390c871bae59b717ab9a85595d2be3033d699653fcd61a
diff --git a/dev-qt/qtxml/qtxml-5.9.0.ebuild b/dev-qt/qtxml/qtxml-5.9.0.ebuild
new file mode 100644
index 00000000..d19aa52b
--- /dev/null
+++ b/dev-qt/qtxml/qtxml-5.9.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+QT5_MODULE="qtbase"
+inherit qt5-build
+
+DESCRIPTION="Implementation of SAX and DOM for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+fi
+
+IUSE=""
+
+RDEPEND="
+ ~dev-qt/qtcore-${PV}
+"
+DEPEND="${RDEPEND}
+ test? ( ~dev-qt/qtnetwork-${PV} )
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/xml
+)