aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarvey Mittens <teknocratdefunct@riseup.net>2014-05-12 03:02:59 +0200
committerDavide Pesavento <pesa@gentoo.org>2014-05-12 03:15:58 +0200
commitb77ad6dfef466c3af3ea1a9537a50992ce60e79a (patch)
tree9894adff86fde2e8b463f33e081b76bc3622a30f /lxqt-base/lxqt-meta/lxqt-meta-9999.ebuild
parent[dev-qt/qtnetwork] Update dependencies. (diff)
downloadqt-b77ad6dfef466c3af3ea1a9537a50992ce60e79a.tar.gz
qt-b77ad6dfef466c3af3ea1a9537a50992ce60e79a.tar.bz2
qt-b77ad6dfef466c3af3ea1a9537a50992ce60e79a.zip
New ebuilds for LXQT.
* New category lxqt-base * New repositories located at git.lxde.org (bug #501606) * New release of LXDE-QT 0.7.0 (bug #509946) * Updated dependencies for various packages * lxinput-qt has been merged with lxqt-config * Various new LXQT packages * New ebuild for lximage-qt 0.2.0 * Updates to sddm ebuilds, with one for the released version
Diffstat (limited to 'lxqt-base/lxqt-meta/lxqt-meta-9999.ebuild')
-rw-r--r--lxqt-base/lxqt-meta/lxqt-meta-9999.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/lxqt-base/lxqt-meta/lxqt-meta-9999.ebuild b/lxqt-base/lxqt-meta/lxqt-meta-9999.ebuild
new file mode 100644
index 00000000..36b8c247
--- /dev/null
+++ b/lxqt-base/lxqt-meta/lxqt-meta-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/lxqt-base/lxde-meta/lxde-meta-0.5.5-r4.ebuild,v 1.2 2014/03/16 13:20:58 hwoarang Exp $
+
+EAPI=5
+
+inherit readme.gentoo
+
+DESCRIPTION="Meta ebuild for LXQT, the Lightweight X11 Desktop Environment"
+HOMEPAGE="http://lxde.org/"
+
+LICENSE="metapackage"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal sddm upower"
+
+DOC_CONTENTS="
+ For your convenience you can review the LXDE Configuration HOWTO at
+ http://www.gentoo.org/proj/en/desktop/lxde/lxde-howto.xml"
+
+RDEPEND="
+ sddm? ( x11-misc/sddm )
+ ~lxqt-base/lxqt-qtplugin-${PV}
+ ~lxqt-base/lxqt-openssh-askpass-${PV}
+ !minimal? (
+ x11-wm/openbox
+ >=x11-misc/obconf-qt-0.1.0 )
+ ~lxqt-base/lxqt-notificationd-${PV}
+ upower? (
+ ~lxqt-base/lxqt-runner-${PV}
+ ~lxqt-base/lxqt-policykit-${PV}
+ ~lxqt-base/lxqt-powermanagement-${PV} )
+ ~lxqt-base/lxqt-about-${PV}
+ ~lxqt-base/lxqt-config-${PV}
+ ~lxqt-base/lxqt-config-randr-${PV}
+ >=lxde-base/lxde-icon-theme-0.5
+ ~lxqt-base/lxqt-common-${PV}
+ >=lxde-base/lxmenu-data-0.5.1
+ ~lxqt-base/lxqt-panel-${PV}
+ ~lxqt-base/lxqt-session-${PV}
+ ~x11-misc/pcmanfm-qt-${PV}"
+
+pkg_postinst() {
+ readme.gentoo_pkg_postinst
+}