aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2018-09-26 00:13:50 +0300
committerJimi Huotari <chiitoo@gentoo.org>2018-09-26 00:13:50 +0300
commit16e31fc56c83f2f3f2156101956f8f98af146868 (patch)
tree626ca49cf8497e601fa8f3c67685dd542282e5ac /x11-misc
parentlxqt-base/lxqt-meta: remove USE="nls" for now (diff)
downloadqt-16e31fc56c83f2f3f2156101956f8f98af146868.tar.gz
qt-16e31fc56c83f2f3f2156101956f8f98af146868.tar.bz2
qt-16e31fc56c83f2f3f2156101956f8f98af146868.zip
x11-misc/pcmanfm-qt: sync with the main Gentoo repo tree
Call 'xdg_desktop_database_update' during 'pkg_postinst' and 'pkg_postrm'. Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/pcmanfm-qt/pcmanfm-qt-9999.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/x11-misc/pcmanfm-qt/pcmanfm-qt-9999.ebuild b/x11-misc/pcmanfm-qt/pcmanfm-qt-9999.ebuild
index e3344d87..3a307e99 100644
--- a/x11-misc/pcmanfm-qt/pcmanfm-qt-9999.ebuild
+++ b/x11-misc/pcmanfm-qt/pcmanfm-qt-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit cmake-utils eapi7-ver
+inherit cmake-utils eapi7-ver xdg-utils
if [[ "${PV}" == "9999" ]]; then
inherit git-r3
@@ -45,3 +45,11 @@ src_configure() {
)
cmake-utils_src_configure
}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}