aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2016-04-26 22:35:19 +0000
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2016-04-26 22:35:19 +0000
commit11c84ac57d237be3aeccc69fe0d9d92b655618ce (patch)
tree51c65827ee084445b587dc7f8aa198c3a763ab04
parentStop using hardcoded paths for the releng repo. (diff)
downloadreleng-11c84ac5.tar.gz
releng-11c84ac5.tar.bz2
releng-11c84ac5.zip
Whitespace. Stop hardcoding the bz2 extension and sync updates to the scripts to the experimental scripts.
Signed-off-by: Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
-rw-r--r--tools/catalyst-auto-amd64-experimental.conf22
-rw-r--r--tools/catalyst-auto-amd64.conf4
-rw-r--r--tools/catalyst-auto-ia64.conf1
-rw-r--r--tools/catalyst-auto-s390.conf1
-rw-r--r--tools/catalyst-auto-s390x.conf1
-rw-r--r--tools/catalyst-auto-sparc64.conf2
-rw-r--r--tools/catalyst-auto-x86-experimental.conf11
7 files changed, 28 insertions, 14 deletions
diff --git a/tools/catalyst-auto-amd64-experimental.conf b/tools/catalyst-auto-amd64-experimental.conf
index 3f2bd168..817c9535 100644
--- a/tools/catalyst-auto-amd64-experimental.conf
+++ b/tools/catalyst-auto-amd64-experimental.conf
@@ -9,18 +9,28 @@ source /etc/catalyst/release/build.env
SPECS_DIR=${REPO_DIR}/releases/weekly/specs/${ARCH}
-#SETS="multilib nomultilib x32 hardened_multilib hardened_nomultilib hardened_multilib_selinux hardened_nomultilib_selinux"
-SETS="multilib nomultilib x32 hardened_multilib hardened_nomultilib"
+SETS="
+ multilib cloud_multilib
+ nomultilib cloud_nomultilib
+ x32
+ hardened_multilib cloud_hardened_multilib
+ hardened_nomultilib cloud_hardened_nomultilib
+ hardened_multilib_selinux hardened_nomultilib_selinux
+"
SET_multilib_SPECS="stage1.spec stage2.spec stage3.spec"
SET_multilib_OPTIONAL_SPECS="installcd-stage1.spec installcd-stage2-minimal.spec"
+SET_cloud_multilib_SPECS="stage4-cloud.spec"
SET_nomultilib_SPECS="stage1-nomultilib.spec stage2-nomultilib.spec stage3-nomultilib.spec"
+SET_cloud_nomultilib_SPECS="stage4-nomultilib-cloud.spec"
SET_x32_SPECS="stage1-x32.spec stage2-x32.spec stage3-x32.spec"
SET_hardened_multilib_SPECS="hardened/stage1.spec hardened/stage2.spec hardened/stage3.spec"
SET_hardened_multilib_OPTIONAL_SPECS="hardened/admincd-stage1.spec hardened/admincd-stage2.spec"
+SET_cloud_hardened_multilib_SPECS="hardened/stage4-cloud.spec"
SET_hardened_nomultilib_SPECS="hardened/stage1-nomultilib.spec hardened/stage2-nomultilib.spec hardened/stage3-nomultilib.spec"
+SET_cloud_hardened_nomultilib_SPECS="hardened/stage4-nomultilib-cloud.spec"
SET_hardened_multilib_selinux_SPECS="hardened/stage1-selinux.spec hardened/stage2-selinux.spec hardened/stage3-selinux.spec"
SET_hardened_multilib_selinux_OPTIONAL_SPECS="hardened/admincd-stage1-selinux.spec hardened/admincd-stage2-selinux.spec"
@@ -28,12 +38,14 @@ SET_hardened_nomultilib_selinux_SPECS="hardened/stage1-selinux-nomultilib.spec h
KCONFIG_DIR=${REPO_DIR}/releases/weekly/kconfig/${ARCH}
+EXTENSIONS="[.tar.xz,.tar.bz2,.tar.gz,.tar,.sfs]"
+
give_latest_from_dates() {
sed 's,-20,~20,g' | \
sort -k +1 -n -t '~' |\
awk -F\~ \
- 'BEGIN{i=$1; o=$0};
- { if($1 != i && i != "") { print o; }; i=$1; o=$0; }
+ 'BEGIN{i=$1; o=$0};
+ { if($1 != i && i != "") { print o; }; i=$1; o=$0; }
END { print o; };' | \
tr '~' '-'
}
@@ -46,7 +58,7 @@ pre_build() {
# Symlink the latest stages3 to build from
for d in ${BUILD_SRCDIR_BASE}/{default,hardened} ; do
pushd $d
- for f in $(ls stage3*bz2 | grep -v latest | give_latest_from_dates ) ; do
+ for f in $(ls stage3*${EXTENSIONS} | grep -v latest | give_latest_from_dates ) ; do
of=${f/20[0-9][0-9].[0-9]/latest} # for 20XX.Y stuff
of=${of/20[0-9][0-9][0-1][0-9][0-9][0-9]/latest} # for 20YYMMDD stuff
ln -sf $f $of
diff --git a/tools/catalyst-auto-amd64.conf b/tools/catalyst-auto-amd64.conf
index 279ddfdb..48dd9cfe 100644
--- a/tools/catalyst-auto-amd64.conf
+++ b/tools/catalyst-auto-amd64.conf
@@ -53,8 +53,8 @@ give_latest_from_dates() {
sed 's,-20,~20,g' | \
sort -k +1 -n -t '~' |\
awk -F\~ \
- 'BEGIN{i=$1; o=$0};
- { if($1 != i && i != "") { print o; }; i=$1; o=$0; }
+ 'BEGIN{i=$1; o=$0};
+ { if($1 != i && i != "") { print o; }; i=$1; o=$0; }
END { print o; };' | \
tr '~' '-'
}
diff --git a/tools/catalyst-auto-ia64.conf b/tools/catalyst-auto-ia64.conf
index 20c88204..8d7e3e5c 100644
--- a/tools/catalyst-auto-ia64.conf
+++ b/tools/catalyst-auto-ia64.conf
@@ -12,7 +12,6 @@ OPTIONAL_SPECS="installcd-stage1.spec installcd-stage2-minimal.spec"
KCONFIG_DIR=${GITDIR}/releases/weekly/kconfig/ia64
-
give_latest_from_dates() {
sed 's,-20,~20,g' | \
sort -k +1 -n -t '~' |\
diff --git a/tools/catalyst-auto-s390.conf b/tools/catalyst-auto-s390.conf
index 7e379974..f87fb031 100644
--- a/tools/catalyst-auto-s390.conf
+++ b/tools/catalyst-auto-s390.conf
@@ -12,7 +12,6 @@ SET_netboot_SPECS="netboot/netboot.spec"
KCONFIG_DIR=${GITDIR}/releases/weekly/kconfig/s390
-
give_latest_from_dates() {
sed 's,-20,~20,g' | \
sort -k +1 -n -t '~' |\
diff --git a/tools/catalyst-auto-s390x.conf b/tools/catalyst-auto-s390x.conf
index 39047e72..24a13847 100644
--- a/tools/catalyst-auto-s390x.conf
+++ b/tools/catalyst-auto-s390x.conf
@@ -12,7 +12,6 @@ SET_netboot_SPECS="netboot/netboot.spec"
KCONFIG_DIR=${GITDIR}/releases/weekly/kconfig/s390
-
give_latest_from_dates() {
sed 's,-20,~20,g' | \
sort -k +1 -n -t '~' |\
diff --git a/tools/catalyst-auto-sparc64.conf b/tools/catalyst-auto-sparc64.conf
index 72ade0a6..2f1834a8 100644
--- a/tools/catalyst-auto-sparc64.conf
+++ b/tools/catalyst-auto-sparc64.conf
@@ -12,8 +12,6 @@ SET_multilib_SPECS="multilib/stage1.spec multilib/stage2.spec multilib/stage3.sp
KCONFIG_DIR=${GITDIR}/releases/weekly/kconfig/sparc
-EMAIL_SUBJECT_PREPEND="[sparc64-auto]"
-
give_latest_from_dates() {
sed 's,-20,~20,g' | \
sort -k +1 -n -t '~' |\
diff --git a/tools/catalyst-auto-x86-experimental.conf b/tools/catalyst-auto-x86-experimental.conf
index ece0e5ab..379adc0e 100644
--- a/tools/catalyst-auto-x86-experimental.conf
+++ b/tools/catalyst-auto-x86-experimental.conf
@@ -9,10 +9,15 @@ source /etc/catalyst/release/build.env
SPECS_DIR=${REPO_DIR}/releases/weekly/specs/${ARCH}
-SETS="i486 i686 hardened"
+SETS="
+ i486
+ i686
+ hardened
+"
SET_i486_SPECS="stage1.spec stage2.spec stage3.spec"
SET_i486_OPTIONAL_SPECS="installcd-stage1.spec installcd-stage2-minimal.spec"
+
SET_i686_SPECS="i686/stage1.spec i686/stage2.spec i686/stage3.spec"
SET_hardened_SPECS="hardened/stage1.spec hardened/stage2.spec hardened/stage3.spec"
@@ -20,6 +25,8 @@ SET_hardened_OPTIONAL_SPECS="hardened/admincd-stage1.spec hardened/admincd-stage
KCONFIG_DIR=${REPO_DIR}/releases/weekly/kconfig/${ARCH}
+EXTENSIONS="[.tar.xz,.tar.bz2,.tar.gz,.tar,.sfs]"
+
give_latest_from_dates() {
sed 's,-20,~20,g' | \
sort -k +1 -n -t '~' |\
@@ -38,7 +45,7 @@ pre_build() {
# Symlink the latest stages3 to build from
for d in ${BUILD_SRCDIR_BASE}/{default,hardened} ; do
pushd $d
- for f in $(ls stage3*bz2 | grep -v latest | give_latest_from_dates ) ; do
+ for f in $(ls stage3*${EXTENSIONS} | grep -v latest | give_latest_from_dates ) ; do
of=${f/20[0-9][0-9].[0-9]/latest} # for 20XX.Y stuff
of=${of/20[0-9][0-9][0-1][0-9][0-9][0-9]/latest} # for 20YYMMDD stuff
ln -sf $f $of