aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <mthode@mthode.org>2017-12-01 16:53:39 -0600
committerMatthew Thode <mthode@mthode.org>2017-12-01 16:53:39 -0600
commit1ce3bc7326a9cd27e341d2d94462c80acc770bf5 (patch)
tree54a9db0dc3e70650776fd6767cc315e870ae84e0
parentstop building cloud stage4 stages (diff)
downloadreleng-1ce3bc73.tar.gz
releng-1ce3bc73.tar.bz2
releng-1ce3bc73.zip
arm64 stage building
this is steev's work
-rw-r--r--releases/weekly/specs/arm64/stage1.spec9
-rw-r--r--releases/weekly/specs/arm64/stage2.spec8
-rw-r--r--releases/weekly/specs/arm64/stage3.spec8
-rw-r--r--tools/catalyst-auto-arm64.conf49
4 files changed, 74 insertions, 0 deletions
diff --git a/releases/weekly/specs/arm64/stage1.spec b/releases/weekly/specs/arm64/stage1.spec
new file mode 100644
index 00000000..dfe2203b
--- /dev/null
+++ b/releases/weekly/specs/arm64/stage1.spec
@@ -0,0 +1,9 @@
+subarch: arm64
+version_stamp: 2008.0
+target: stage1
+rel_type: default
+profile: default/linux/arm64/13.0
+snapshot: 2008.0
+source_subpath: default/stage3-arm64-latest
+pkgcache_path: /var/tmp/catalyst/packages/stage1
+update_seed: yes
diff --git a/releases/weekly/specs/arm64/stage2.spec b/releases/weekly/specs/arm64/stage2.spec
new file mode 100644
index 00000000..65d7d49a
--- /dev/null
+++ b/releases/weekly/specs/arm64/stage2.spec
@@ -0,0 +1,8 @@
+subarch: arm64
+version_stamp: 2008.0
+target: stage2
+rel_type: default
+profile: default/linux/arm64/13.0
+snapshot: 2008.0
+source_subpath: default/stage1-arm64-2008.0
+pkgcache_path: /var/tmp/catalyst/packages/stage2
diff --git a/releases/weekly/specs/arm64/stage3.spec b/releases/weekly/specs/arm64/stage3.spec
new file mode 100644
index 00000000..6b1a6692
--- /dev/null
+++ b/releases/weekly/specs/arm64/stage3.spec
@@ -0,0 +1,8 @@
+subarch: arm64
+version_stamp: 2008.0
+target: stage3
+rel_type: default
+profile: default/linux/arm64/13.0
+snapshot: 2008.0
+source_subpath: default/stage2-arm64-2008.0
+pkgcache_path: /var/tmp/catalyst/packages/stage3
diff --git a/tools/catalyst-auto-arm64.conf b/tools/catalyst-auto-arm64.conf
new file mode 100644
index 00000000..bede1247
--- /dev/null
+++ b/tools/catalyst-auto-arm64.conf
@@ -0,0 +1,49 @@
+# This is the config file for the catalyst-auto script. It should be pretty
+# self-explanatory.
+
+REPO_DIR=/root/releng/
+
+SPECS_DIR=${REPO_DIR}/releases/weekly/specs/arm64
+SUBARCH=`grep subarch $SPECS_DIR/stage1.spec | awk '{print $2}'`
+
+SETS="default"
+
+SET_default_SPECS="stage1.spec stage2.spec stage3.spec"
+#SET_default_OPTIONAL_SPECS="installcd-stage1.spec installcd-stage2-minimal.spec"
+
+#KCONFIG_DIR=${REPO_DIR}/releases/weekly/kconfig/sparc
+
+EMAIL_SUBJECT_PREPEND="[${SUBARCH}-auto]"
+
+give_latest_from_dates() {
+ sed 's,-20,~20,g' | \
+ sort -k +1 -n -t '~' |\
+ awk -F\~ \
+ 'BEGIN{i=$1; o=$0};
+ { if($1 != i && i != "") { print o; }; i=$1; o=$0; }
+ END { print o; };' | \
+ tr '~' '-'
+}
+
+
+pre_build() {
+ cd ${REPO_DIR}
+ git pull
+
+ # Symlink the latest stages3 to build from
+ for d in ${BUILD_SRCDIR_BASE}/builds/default ; do
+ pushd $d
+ for f in $(ls stage3-${SUBARCH}-*bz2 | grep -v latest | give_latest_from_dates ) ; do
+ of=${f/20[0-9][0-9].[0-9]/latest} # for 20XX.Y stuff
+ of=${of/20[0-9][0-9][0-1][0-9][0-9][0-9]/latest} # for $
+ ln -sf $f $of
+ done
+ popd
+ done
+}
+
+
+post_build() {
+ rsync -e 'ssh -i /root/.ssh/id_rsa' ${BUILD_SRCDIR_BASE}/builds/default/stage3-${SUBARCH}-*${DATESTAMP}*.tar.bz2* arm@nightheron.gentoo.org:
+ # Need to update this still.
+}